FIX: L'errore non viene segnalato nuovamente al client se un'attivitā di attivitā TransactionScopeActivity contenuta in un'attivitā di ReceiveActivity ha esito negativo in .NET Framework 3.5 SP1

Traduzione articoli Traduzione articoli
Identificativo articolo: 959362 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

Sintomi

Se un'attivitā di attivitā TransactionScopeActivity (TSA) che č contenuta in un'attivitā di ReceiveActivity non riesce, l'errore non č riportato nuovamente al client. Il client che chiama l'attivitā di ReceiveActivity attende che la chiamata alla fine timeout.

Cause

Questo problema si verifica perché l'attivitā di ReceiveActivity scrive lo stato al momento del checkpoint in modo non corretto. Quando un'attivitā TSA ha esito negativo, lo stato del flusso di lavoro ripristinato il checkpoint creato durante l'attivitā TSA č stato immesso. Il problema č descritto nella sezione "Sintomi" si verifica perché lo stato di attivitā di ReceiveActivity non č corretto in questa checkpoint.

Risoluzione

Č ora disponibile un hotfix supportato. Tuttavia č destinato esclusivamente alla risoluzione il problema descritto in questo articolo. Applicarlo solo a sistemi che si verifica questo problema specifico.

Per risolvere il problema, contattare il servizio di supporto clienti di Microsoft per ottenere l'hotfix. Per un elenco completo di numeri di telefono del supporto tecnico clienti Microsoft e per informazioni sui costi dell'assistenza, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota in casi particolari, le spese normalmente addebitate per le chiamate al Servizio Supporto Tecnico Clienti Microsoft potrebbero essere annullate qualora un addetto del Supporto Tecnico Microsoft dovesse determinare che uno specifico aggiornamento risolverā il problema. I normali costi del Servizio Supporto Tecnico Clienti verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.

Prerequisiti

Č necessario .NET Framework 3.5 SP1 installata per applicare questo aggiornamento rapido (hotfix).

Necessitā di riavvio

Non č necessario riavviare il computer dopo avere applicato questo aggiornamento rapido (hotfix).

Informazioni sulla sostituzione della correzione

Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix.

Informazioni sui file

La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per trovare la differenza tra ora UTC e ora locale, utilizzare il fuso orario scheda nella Data e ora nel Pannello di controllo.
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOra
System.workflowservices.dll3.5.594.4019507,90429-01-200900: 38
System.workflowservices.dll3.5.594.4019479.23229-01-200900: 43
System.workflowservices.dll3.5.594.4019479.23229-01-200901: 26

Status

Microsoft ha confermato che questo problema riguarda i prodotti sono elencati nella sezione "Si applica a".

Informazioni

Per ulteriori informazioni sull'utilizzo dell'attivitā di attivitā TransactionScopeActivity, visitare il sito di Web di Microsoft:
http://msdn.microsoft.com/en-us/library/ms733613(VS.85).aspx

Proprietā

Identificativo articolo: 959362 - Ultima modifica: martedė 17 marzo 2009 - Revisione: 1.0
Le informazioni in questo articolo si applicano a:
  • Microsoft .NET Framework 3.5 Service Pack 1
Chiavi: 
kbmt kbhotfixserver kbexpertiseadvanced kbqfe kbsurveynew KB959362 KbMtit
Traduzione automatica articoli
Il presente articolo č stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non č sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pių o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non č la sua. Microsoft non č responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 959362
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com