Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

In Microsoft BizTalk Server 2006 or in Microsoft BizTalk Server 2006 R2, messages may be processed slowly. When this problem occurs, the MessageBox_Parts_Cleanup_BizTalkMsgBoxDb SQL Server Agent job takes a long time to finish. For example, the MessageBox_Parts_Cleanup_BizTalkMsgBoxDb SQL Server Agent job takes more than several minutes to finish. You notice this problem in SQL Server Management Studio in Microsoft SQL Server 2005 or in Enterprise Manager in Microsoft SQL Server 2000.

Note Typically, the MessageBox_Parts_Cleanup_BizTalkMsgBoxDb SQL Server Agent job takes several seconds to finish.

Cause

This problem occurs because of a problem in the SQL stored procedure for the MessageBox_Parts_Cleanup_BizTalkMsgBoxDb SQL Server Agent job.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.


If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

There are two versions of this hotfix:

  • BizTalk Server 2006

  • BizTalk Server 2006 R2

Rollback Information

Warning If this hotfix contains a SQL script (.sql), you cannot use Add or Remove to roll back this hotfix from the BizTalk Server environment. Therefore, make sure that you fully test this hotfix in a test environment before you apply this hotfix to a production environment. Do not try to use Add or Remove Programs to remove this hotfix because Add or Remove Programs does not roll back the database changes and leaves the BizTalk Server environment in an inconsistent state. For more information, see the Readme.txt file that is included in the hotfix package. If this hotfix only updates .dll files and does not update any .sql files, you can roll back this hotfix by using Add or Remove Programs.

Note You can review the Setup.xml file to see which files are updated by this hotfix.

  1. Before you apply this hotfix, do a full backup of all the BizTalk Server databases.

    Note You must backup and restore all the BizTalk Server databases. For more information on backing up and restoring the BizTalk Server databases on BizTalk Server 2006 and BizTalk Server 2006 R2, visit the following MSDN site:

    http://msdn2.microsoft.com/en-us/library/aa561125.aspxFor more information on backing up and restoring the BizTalk Server databases on BizTalk Server 2004, visit the following MSDN site:

    http://msdn2.microsoft.com/en-us/library/ms962203.aspx

  2. To roll back this hotfix after it has been installed:

    1. Stop all BizTalk services and SQL Server Agent.

    2. In Add or Remove Programs, select this hotfix and then click Remove.

    3. Restore the full backups of all the BizTalk databases.

      Note You must backup and restore all the BizTalk databases.

      For more information on backing up and restoring the BizTalk Server databases on BizTalk Server 2004, visit the following MSDN site:

      http://msdn2.microsoft.com/en-us/library/ms962203.aspxFor more information on backing up and restoring the BizTalk Server databases on BizTalk Server 2006 and BizTalk Server 2006 R2, visit the following MSDN site:

      http://msdn2.microsoft.com/en-us/library/aa561125.aspx

    4. Restart all the BizTalk services and SQL Server Agent.


      Note Do not run any .sql files.

Known issue



Some BizTalk databases may not be updated if you change the BizTalk Server group name before you apply this hotfix package. To avoid this issue, rename the BizTalk Server group back to the following default name before you apply the hotfix:

BizTalk Group

Prerequisites

You must have BizTalk Server 2006 installed to apply the BizTalk 2006 version of this hotfix. You must have BizTalk Server 2006 R2 installed to apply the BizTalk 2006 R2 version of this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

BizTalk Server 2006

File name

File version

File size

Date

Time

Platform

Msgboxlogic.sql

Not applicable

543,026

16-Dec-2008

13:34

Not applicable

BizTalk Server 2006 R2

File name

File version

File size

Date

Time

Platform

Msgboxlogic.sql

Not applicable

566,634

11-Dec-2008

16:49

Not applicable

Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about the BizTalk Server message database structure and jobs, visit the following Microsoft Web site:

http://msdn.microsoft.com/en-us/library/aa561960.aspxFor more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×