Only the header and footer information in an XPS document are printed when you print the document on a computer that is running Windows XP, Windows Vista SP1, or Windows Server 2008

Article translations Article translations
Article ID: 959554 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

When you print a document on a computer that is running Windows XP, Windows Vista SP1, or Windows Server 2008, only the header and footer information is printed in the document.

This problem occurs most frequently when you use the XPS Document Writer.

CAUSE

This problem occurs because an internal GDI structure is not initialized correctly when a print job is processed.

RESOLUTION

Hotfix information

Windows XP A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To apply this hotfix, the computer must run one of the following:
  • Windows XP Service Pack 2
  • Windows XP Service Pack 3
Restart requirement
You have to restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other previously released hotfixes.
Methods to enable this hotfix
Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows XP SP2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Gdi32.dll5.1.2600.3498284,16022-Dec-200813:13x86

Windows XP SP3, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Gdi32.dll5.1.2600.5732286,72022-Dec-200813:16x86

Windows Vista and Windows Server 2008

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the “Hotfix Request” page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.
Prerequisites
To apply this hotfix, the computer must run one of the following:
  • Windows Vista Service Pack 1
  • Windows Server 2008
Restart requirement
You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.
Methods to enable this hotfix
Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista and Windows Server 2008 file information notes
The MANIFEST files (.manifest) and MUM files (.mum) installed for each environment are listed separately. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files (attributes not listed) are signed with a Microsoft digital signature.

For all supported 32-bit versions of Windows Server 2008 and of Windows Vista
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Gdi32.dll6.0.6001.22332297,47217-Dec-200804:28x86

For all supported 64-bit versions of Windows Server 2008 and of Windows Vista
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformService branch
Gdi32.dll6.0.6001.22332389,63217-Dec-200804:44x64Not Applicable
Gdi32.dll6.0.6001.22332303,61617-Dec-200804:33x86WOW

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

An XPS document is a new Microsoft document format that you can use to archive content in a standardized format or to publish content in an easily viewable form. You can also use this format to make sure that no one can edit your original work.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information for Windows Server 2008 and for Windows Vista

Additional files for all supported 32-bit versions of Windows Server 2008 and of Windows Vista
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Package_for_kb959554_client_1~31bf3856ad364e35~x86~~6.0.2.0.mumNot Applicable1,36717-Dec-200823:40Not Applicable
Package_for_kb959554_client~31bf3856ad364e35~x86~~6.0.2.0.mumNot Applicable1,43117-Dec-200823:40Not Applicable
Package_for_kb959554_sc_0~31bf3856ad364e35~x86~~6.0.2.0.mumNot Applicable1,42117-Dec-200823:40Not Applicable
Package_for_kb959554_sc~31bf3856ad364e35~x86~~6.0.2.0.mumNot Applicable1,42317-Dec-200823:40Not Applicable
Package_for_kb959554_server_0~31bf3856ad364e35~x86~~6.0.2.0.mumNot Applicable1,42517-Dec-200823:40Not Applicable
Package_for_kb959554_server~31bf3856ad364e35~x86~~6.0.2.0.mumNot Applicable1,43117-Dec-200823:40Not Applicable
Package_for_kb959554_winpesrv_0~31bf3856ad364e35~x86~~6.0.2.0.mumNot Applicable1,42217-Dec-200823:40Not Applicable
Package_for_kb959554_winpesrv~31bf3856ad364e35~x86~~6.0.2.0.mumNot Applicable1,42917-Dec-200823:40Not Applicable
X86_microsoft-windows-gdi32_31bf3856ad364e35_6.0.6001.22332_none_59e9db636285ac04.manifestNot Applicable5,96417-Dec-200806:00Not Applicable
Additional files for all supported 64-bit versions of Windows Server 2008 and of Windows Vista
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_microsoft-windows-gdi32_31bf3856ad364e35_6.0.6001.22332_none_b60876e71ae31d3a.manifestNot Applicable5,98617-Dec-200806:21Not Applicable
Package_for_kb959554_client_1~31bf3856ad364e35~amd64~~6.0.2.0.mumNot Applicable1,37517-Dec-200823:40Not Applicable
Package_for_kb959554_client~31bf3856ad364e35~amd64~~6.0.2.0.mumNot Applicable1,43917-Dec-200823:40Not Applicable
Package_for_kb959554_sc_0~31bf3856ad364e35~amd64~~6.0.2.0.mumNot Applicable1,42917-Dec-200823:40Not Applicable
Package_for_kb959554_sc~31bf3856ad364e35~amd64~~6.0.2.0.mumNot Applicable1,43117-Dec-200823:40Not Applicable
Package_for_kb959554_server_0~31bf3856ad364e35~amd64~~6.0.2.0.mumNot Applicable1,43317-Dec-200823:40Not Applicable
Package_for_kb959554_server~31bf3856ad364e35~amd64~~6.0.2.0.mumNot Applicable1,43917-Dec-200823:40Not Applicable
Package_for_kb959554_winpesrv_0~31bf3856ad364e35~amd64~~6.0.2.0.mumNot Applicable1,43017-Dec-200823:40Not Applicable
Package_for_kb959554_winpesrv~31bf3856ad364e35~amd64~~6.0.2.0.mumNot Applicable1,43717-Dec-200823:40Not Applicable
Wow64_microsoft-windows-gdi32_31bf3856ad364e35_6.0.6001.22332_none_c05d21394f43df35.manifestNot Applicable6,31417-Dec-200805:53Not Applicable

Properties

Article ID: 959554 - Last Review: October 8, 2011 - Revision: 2.0
APPLIES TO
  • Windows Server 2008 Datacenter without Hyper-V
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 Standard without Hyper-V
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Business
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Ultimate
  • Windows Vista Home Premium
  • Microsoft Windows XP Service Pack 2
  • Microsoft Windows XP Service Pack 3
  • Windows 7 Enterprise
  • Windows 7 Enterprise N
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Home Premium N
  • Windows 7 Professional
  • Windows 7 Professional N
  • Windows 7 Starter
  • Windows 7 Starter N
  • Windows 7 Ultimate
  • Windows 7 Ultimate N
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Datacenter without Hyper-V
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Enterprise without Hyper-V
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 R2 Standard without Hyper-V
  • Windows Web Server 2008 R2
Keywords: 
kbautohotfix kbexpertiseadvanced kbfix kbqfe KB959554

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com