Artigo: 959758 - Última revisão: quarta-feira, 22 de Julho de 2009 - Revisão: 2.0

Não pode configurar um esquema de domínio do Active Directory e o Microsoft Dynamics CRM 4.0 URL independentemente para os utilizadores do Active Directory externos e para utilizadores do Active Directory internos

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Reduzir tudo

Sintomas

Não pode configurar um esquema de domínio do Active Directory e o Microsoft Dynamics CRM 4.0 URL independentemente para os utilizadores do Active Directory externos e para utilizadores do Active Directory internos. Deste modo, os URLs no código de Software Development Kit (SDK) não podem ser resolvidos num domínio.

Causa

Este problema ocorre porque a propriedade CrmServiceFactory que é utilizada, a tubagem e pelo serviço AsyncService sempre utiliza o esquema ADRootDomainScheme na entrada ConfigDB. Quando cria um URL para o serviço CrmService e para o serviço MetadataService, o esquema impede a configurar um computador para utilizar uma esquema diferente.

Resolução

importante Esta secção, método ou tarefa contém passos que indicam como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo de forma incorrecta. Por conseguinte, certifique-se de que segue estes passos cuidadosamente. Criar uma para protecção adicional, cópia de segurança do registo antes de o modificar. Em seguida, pode restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) Como efectuar uma cópia de segurança e restaurar o registo no Windows XP e Windows Vista


Este problema é corrigido no conjunto de actualização cumulativa mais recente do Microsoft Dynamics CRM 4.0.

Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
949256  (http://support.microsoft.com/kb/949256/ ) O Microsoft Dynamics CRM 4.0 actualizações e correcções


Depois de aplicar esta correcção, criar uma chave de registo denominado "ADRootDomainScheme" no servidor do Microsoft Dynamics CRM 4.0. Para o fazer, siga estes passos:
  1. Clique em Iniciar , clique em Executar , escreva regedit e, em seguida, clique em OK .
  2. Localize e, em seguida, clique na seguinte subchave do registo:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM
  3. Clique com o botão direito do rato MSCRM , clique em Novo e em seguida, clique em Valor da cadeia .
  4. Na caixa nome , escreva ADRootDomainScheme .
  5. Clique com o botão direito do rato ADRootDomainScheme e, em seguida, clique em Modificar .
  6. Na caixa valor , escreva http ou https e, em seguida, clique em OK .


In addtion para o ADRootDomainScheme as entradas de registo cadeia seguinte tem de ser adicionadas bem:
  • ADSdkRootDomain (cadeia)
  • ADWebApplicationRootDomain (cadeia)

Se estiver a utilizar autenticação IFD (Internet para implementação) para o CRM existem um conjunto de addtional de entradas de registo que podem ser utilizados da mesma forma como as entradas de registo de autenticação Active Directory (AD).
  • IfdRootDomainScheme (cadeia)
  • IfdSdkRootDomain (cadeia)
  • IfdWebApplicationRootDomain (cadeia)

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

Mais Informação

Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
950542  (http://support.microsoft.com/kb/950542/ ) Plug-ins síncronos não respondem a eventos que são accionados no Microsoft Dynamics CRM 4.0

Mais Informação

Para obter mais informações sobre a terminologia de actualização de software, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/LN/ ) Descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft
Para obter mais informações sobre a Microsoft Business Solutions CRM hotfix e atualização pacote terminologia de software, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
887283  (http://support.microsoft.com/kb/887283/ ) Padrões de nomenclatura do pacote de Microsoft Business Solutions CRM software hotfix e atualização

A informação contida neste artigo aplica-se a:
  • Microsoft Dynamics CRM 4.0
Palavras-chave: 
kbmt kbfix kbexpertiseinter kbsurveynew kbmbsmigrate kbqfe KB959758 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 959758  (http://support.microsoft.com/kb/959758/en-us/ )