ID do artigo: 959758 - Última revisão: quarta-feira, 22 de julho de 2009 - Revisão: 2.0

Não é possível configurar um esquema de domínio do Active Directory e o Microsoft Dynamics CRM 4.0 URLs independentemente para usuários externos do Active Directory e para usuários internos do Active Directory

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Recolher tudo

Sintomas

Não é possível configurar um esquema de domínio do Active Directory e o Microsoft Dynamics CRM 4.0 URLs independentemente para usuários externos do Active Directory e para usuários internos do Active Directory. Devido a isso, as URLs no código de Software Development Kit (SDK) não podem ser resolvidas em um domínio.

Causa

Esse problema ocorre porque a propriedade CrmServiceFactory que é usada pelo pipeline e por serviço AsyncService sempre usa o esquema ADRootDomainScheme na entrada ConfigDB. Quando você cria uma URL para o serviço CrmService e para o serviço MetadataService, o esquema evita que você configurar um computador para usar um esquema diferente.

Resolução

importante Esta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o registro incorretamente. Por isso, certifique-se que você execute essas etapas cuidadosamente. Para proteção adicional, fazer backup do registro antes de modificá-lo. Em seguida, você pode restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322756  (http://support.microsoft.com/kb/322756/ ) Como fazer e restaurar o registro no Windows XP e no Windows Vista


Esse problema é corrigido no pacote cumulativo de atualização cumulativa mais recente para o Microsoft Dynamics CRM 4.0.

Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
949256  (http://support.microsoft.com/kb/949256/ ) Hotfixes e atualizações do Microsoft Dynamics CRM 4.0


Após aplicar esse hotfix, crie uma chave do Registro chamado "ADRootDomainScheme" no servidor do Microsoft Dynamics CRM 4.0. Para fazer isso, execute as seguintes etapas:
  1. Clique em Iniciar , clique em Executar , digite regedit e, em seguida, clique em OK .
  2. Localize e, em seguida, clique na seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM
  3. Clique com o botão direito do mouse em MSCRM , clique em novo e em Valor da seqüência .
  4. Na caixa nome , digite ADRootDomainScheme .
  5. Clique com o botão direito do mouse ADRootDomainScheme e, em seguida, clique em Modificar .
  6. Na caixa valor , digite http ou https e, em seguida, clique em OK .


Addtion para o ADRootDomainScheme as seguintes entradas do Registro seqüência de caracteres devem ser adicionadas bem:
  • ADSdkRootDomain (seqüência de caracteres)
  • ADWebApplicationRootDomain (seqüência de caracteres)

Se você estiver usando autenticação IFD (Internet Facing Deployment) para o CRM há um conjunto de adicionais de entradas do registro que podem ser usados da mesma maneira como as entradas de registro de autenticação do Active Directory (AD).
  • IfdRootDomainScheme (seqüência de caracteres)
  • IfdSdkRootDomain (seqüência de caracteres)
  • IfdWebApplicationRootDomain (seqüência de caracteres)

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
950542  (http://support.microsoft.com/kb/950542/ ) Plug-ins síncronas não responder a eventos que são disparados no Microsoft Dynamics CRM 4.0

Mais Informações

Para obter mais informações sobre terminologia de atualização de software, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684  (http://support.microsoft.com/kb/824684/LN/ ) Descrição da terminologia padrão que é usada para descrever as atualizações de software
Para obter mais informações sobre terminologia para pacote de hotfix e atualização do software do Microsoft Business Solutions CRM, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
887283  (http://support.microsoft.com/kb/887283/ ) Padrões de nomenclatura do pacote de Microsoft Business Solutions CRM software hotfix e atualização

A informação contida neste artigo aplica-se a:
  • Microsoft Dynamics CRM 4.0
Palavras-chave: 
kbmt kbfix kbexpertiseinter kbsurveynew kbmbsmigrate kbqfe KB959758 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 959758  (http://support.microsoft.com/kb/959758/en-us/ )