Makale numarası: 959758 - Son Gözden Geçirme: 22 Temmuz 2009 Çarşamba - Gözden geçirme: 2.0

Bir Active Directory etki alanı şeması ve Microsoft Dynamics CRM 4.0 URL'leri bağımsız olarak iç Active Directory Kullanıcıları ve harici bir Active Directory kullanıcılar için yapılandırılamıyor

Sistem İpucuBu makale, kullandığınızdan farklı bir işletim sistemine yöneliktir. Sizinle ilgili olmayabilecek makale içeriği devre dışı bırakıldı.
Hepsini aç | Hepsini kapa

Belirtiler

Bir Active Directory etki alanı şeması ve Microsoft Dynamics CRM 4.0 URL'leri bağımsız olarak iç Active Directory Kullanıcıları ve harici bir Active Directory kullanıcılar için yapılandıramazsınız. Bu nedenle, bir etki alanında URL'lerinde Software Development Kit'e (SDK) kodu çözülemiyor.

Neden

Ardışık Düzen ve AsyncService hizmeti her zaman kullanılan CrmServiceFactory özelliği ConfigDB girdisinde ADRootDomainScheme şeması kullandığından, bu sorun oluşur. Bir URL CrmService hizmeti ve hizmetin MetadataService oluşturduğunuzda, düzeni farklı bir düzen kullanmak üzere bir bilgisayar yapılandırmalarını engeller.

Çözüm

Önemli Bu bölüm, yöntem veya görev kayıt defterini nasıl söyleyin adımları içerir. Ancak kayıt defterini hatalı olarak değiştirirseniz önemli sorunlar oluşabilir. Bu nedenle, bu adımları dikkatlice uyguladığınızdan emin olun. Ek koruma için, kayıt defterini değiştirmeden önce yedeklemeyi unutmayın. Bir sorun oluşursa kayıt defterini daha sonra geri yükleyebilirsiniz. Kayıt defterini yedekleme ve geri yükleme hakkında daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
322756  (http://support.microsoft.com/kb/322756/ ) Windows XP ve Windows Server 2003'te kayıt defteri nasıl yedeklenir, düzenlenir ve geri yüklenir


Bu sorun, Microsoft Dynamics CRM 4.0 için en son toplu güncelleştirme toplamasına giderilmiştir.

Daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
949256  (http://support.microsoft.com/kb/949256/ ) Microsoft Dynamics CRM 4.0 güncelleştirmelerini ve düzeltmeleri


Bu düzeltmeyi uyguladıktan sonra Microsoft Dynamics CRM 4.0 sunucuda "ADRootDomainScheme" adlı bir kayıt defteri anahtarı oluşturun. Bunu yapmak için şu adımları izleyin:
  1. Başlat ' ı tıklatın, Çalıştır ' ı tıklatın, regedit yazın ve Tamam ' ı tıklatın.
  2. Aşağıdaki kayıt defteri alt anahtarını bulup tıklatın:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM
  3. MSCRM sağ tıklatın, Yeni ' yi tıklatın ve sonra Dize değeri ' ni tıklatın.
  4. Ad kutusuna ADRootDomainScheme yazın.
  5. ADRootDomainScheme ' ı sağ tıklatın ve sonra Değiştir ' i tıklatın.
  6. Değer kutusuna http veya https yazın ve Tamam ' ı tıklatın.


Addtion the ADRootDomainScheme için aşağıdaki dize kayıt defteri girdilerini de eklenmesi gerekir:
  • ADSdkRootDomain (dize)
  • ADWebApplicationRootDomain (dize)

CRM IFD (ınternet dağıtım karşılıklı) kimlik doğrulaması kullanıyorsanız, bir Active Directory (AD) kimlik doğrulaması kayıt defteri girdileri olarak bir aynı zamanda kullanılabilir kayıt defteri girdilerini addtional kümesi vardır.
  • IfdRootDomainScheme (dize)
  • IfdSdkRootDomain (dize)
  • IfdWebApplicationRootDomain (dize)

Durum

Microsoft, "Geçerli Olduğu Ürünler" bölümünde listelenen Microsoft ürünlerinde bu sorunun olduğunu onaylamıştır.

Daha fazla bilgi

Daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
950542  (http://support.microsoft.com/kb/950542/ ) Microsoft Dynamics CRM 4. 0'da Tetiklenen olay için zaman uyumlu eklentileri yanıt vermiyor

Daha fazla bilgi

Yazılım güncelleştirme terminolojisi hakkında daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
824684  (http://support.microsoft.com/kb/824684/LN/ ) Microsoft yazılım güncelleştirmelerini açıklamak için kullanılan standart terminolojinin açıklaması
Microsoft Business Solutions CRM yazılım düzeltmesi ve güncelleştirme paketi terminolojisi hakkında daha fazla bilgi için Microsoft Knowledge Base'deki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
887283  (http://support.microsoft.com/kb/887283/ ) Microsoft Business Solutions CRM yazılım düzeltmesi ve güncelleştirme paketi adlandırma standartları

Bu makaledeki bilginin uygulandığı durum:
  • Microsoft Dynamics CRM 4.0
Anahtar Kelimeler: 
kbmt kbfix kbexpertiseinter kbsurveynew kbmbsmigrate kbqfe KB959758 KbMttr
Otomatik TercümeOtomatik Tercüme
ÖNEMLİ: Bu makale, bir kişi tarafından çevrilmek yerine, Microsoft makine-çevirisi yazılımı ile çevrilmiştir. Microsoft size hem kişiler tarafından çevrilmiş, hem de makine-çevrisi ile çevrilmiş makaleler sunar. Böylelikle, bilgi bankamızdaki tüm makalelere, kendi dilinizde ulaşmış olursunuz. Bununla birlikte, makine tarafından çevrilmiş makaleler mükemmel değildir. Bir yabancının sizin dilinizde konuşurken yapabileceği hatalar gibi, makale; kelime dağarcığı, söz dizim kuralları veya dil bilgisi açısından yanlışlar içerebilir. Microsoft, içeriğin yanlış çevrimi veya onun müşteri tarafından kullanımından doğan; kusur, hata veya zarardan sorumlu değildir. Microsoft ayrıca makine çevirisi yazılımını sıkça güncellemektedir.
Makalenin İngilizcesi aşağıdaki gibidir:959758  (http://support.microsoft.com/kb/959758/en-us/ )