AD FS nemůže připojit k úložišti ADAM přes připojení SSL na serveru se systémem Windows Server 2003 R2

Překlady článku Překlady článku
ID článku: 959923 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Předpokládejme následující situaci:
  • Služba Active Directory federace Services (AD FS) je nainstalován na serveru se systémem Windows Server 2003 R2.
  • AD FS připojit úložiště Active Directory Application Mode (ADAM).
  • Je zaškrtnuto políčko Povolit Transport Layer Security (TLS) a protokoly protokol SSL (Secure Sockets Layer) (SSL).
V tomto scénáři ukládat připojení mezi AD FS a ADAM nezdaří. Zobrazí se také následující chybová zpráva:
Server není funkční
Když nastane tento problém je v protokolu ladění federace Server zaznamenána následující informace:

[INFO] GetClaimsForUserNameWorker (LDAP): called for user user name
[VERBOSE] GetClaimsForUserNameWorker (LDAP): Got COMException 18446744071562534970: The server is not operational.

Příčina

K tomuto problému dochází, protože v systému Windows Server 2003 R2 FS AD nepodporuje připojení k ADAM přes připojení SSL.

Řešení

Tento problém vyřešit, nainstalovat opravu hotfix 959923 na serveru se systémem Windows Server 2003 R2, který má nainstalovanou FS AD. Po instalaci této opravy hotfix AD FS můžete připojit k ADAM úložišť přes připojení SSL.

Informace o opravě hotfix

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Tuto opravu hotfix instalujte pouze do systémů, ve kterých dochází k potížím popsaným v tomto článku. Tato oprava hotfix může být dále testována. Pokud Vás tento problém závažně nepostihuje, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Pokud tento oddíl nevidíte, obraťte se na Technickou podpora společnosti Microsoft pro získání opravy hotfix.

Poznámka: Pokud vyskytnout další problémy nebo jakékoli řešení potíží je vyžadován, pravděpodobně budete muset vytvořit zvláštní požadavek na službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Zobrazí formulář "Hotfix stažení k dispozici" jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.

Požadavky

Chcete-li použít tuto opravu hotfix, musí mít Windows Server 2003 R2 a FS AD na serveru nainstalován.

Požadavek na restartování

Máte po použití této opravy hotfix restartovat počítač.

Informace o nahrazení opravy hotfix

Tato oprava hotfix nenahrazuje dříve vydanou opravu hotfix.

Informace o registru

Pokud chcete použít tuto opravu hotfix, nemusíte provádět žádné změny v registru.

INFORMACE O SOUBORECH

Anglická verze této opravy hotfix má následující (nebo pozdější) atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním ČASEM a najít, použijte kartu časové pásmo v položce datum a čas v ovládacím.
Windows Server 2003 R2 x 86 verze
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatformaPožadavek na aktualizaci SP
Adfsreg.exe5.2.3790.32847,68020 Leden 200913: 29X86SP1
System.web.Security.singlesignon.dll5.2.3790.3284581,63221 Leden 200907: 29X86SP1
Windows Server 2003 R2 Service Pack 2, x 86 verze
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatformaPožadavek na aktualizaci SP
Adfsreg.exe5.2.3790.44497,68020 Leden 200913: 35X86SP2
System.web.Security.singlesignon.dll5.2.3790.4449581,63221 Leden 200907: 55X86SP2
Windows Server 2003 R2 pro verze x 64
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatformaPožadavek na aktualizaci SP
Adfsreg.exe5.2.3790.32849,21621 Leden 200906: 29X64SP1
System.web.Security.singlesignon.dll5.2.3790.3284581,63221 Leden 200906: 29X86SP1
Windows Server 2003 R2 Service Pack 2, verze x 64
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatformaPožadavek na aktualizaci SP
Adfsreg.exe5.2.3790.44499,21621 Leden 200906: 41X64SP2
System.web.Security.singlesignon.dll5.2.3790.4449581,63221 Leden 200906: 41X86SP2

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt.

Další informace

AD FS je součást systému Windows Server 2003 R2. Další informace naleznete na webu Microsoft TechNet:
http://technet2.microsoft.com/WindowsServer/en/library/050392bc-c8f5-48b3-b30e-bf310399ff5d1033.mspx
Další informace o terminologii používané v aktualizacích softwaru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
824684Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft

Vlastnosti

ID článku: 959923 - Poslední aktualizace: 11. února 2009 - Revize: 1.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Datacenter x64 Edition
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Standard x64 Edition
Klíčová slova: 
kbmt kbautohotfix kbexpertiseadvanced kbfix kbsurveynew kbqfe kbhotfixserver KB959923 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:959923

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com