Article ID: 959959 - Last Review: December 17, 2008 - Revision: 1.0

When you try to uninstall Exchange Server 2007, the uninstall operation stops responding when it runs the task to remove Exchange files

Expand all | Collapse all

SYMPTOMS

You start to uninstall Microsoft Exchange Server 2007 by using the Add or Remove Programs item in Control Panel. When you do this, the following tasks are completed successfully:
  • All server roles are removed.
  • The Exchange organization is removed.
However, the uninstall operation stops responding when it runs the task to remove Exchange files. Although the progress bar indicates that 100 percent of the task is completed, the operation does not continue to the next step.

Additionally, when you open Task Manager, the Powershell.exe process constantly displays 25 percent CPU usage.

CAUSE

This problem occurs because a custom action invokes the Powershell.exe process but never executes the action.

RESOLUTION

To resolve this problem, open Task Manager, and then end the Powershell.exe process. The Powershell.exe process will restart immediately and then complete the uninstall operation.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about how to completely remove Exchange Server 2007, visit the following Microsoft Web site:
http://technet.microsoft.com/en-us/library/bb123893.aspx (http://technet.microsoft.com/en-us/library/bb123893.aspx)

APPLIES TO
  • Microsoft Exchange Server 2007 Enterprise Edition
  • Microsoft Exchange Server 2007 Standard Edition
Keywords: 
kbfile kbstoprespond kbsurveynew kbuninstall kbexpertiseadvanced kbbug kbtshoot KB959959
 

Article Translations

 

Related Support Centers