Article ID: 960052 - Last Review: October 23, 2009 - Revision: 7.1

80070570 error when you try to download content from Xbox LIVE

On This Page

Expand all | Collapse all

SYMPTOMS

When you try to download content from the Xbox LIVE Marketplace, the download stops, and you receive the following error code:
80070570
Because of this error, the content may have to be redownloaded.

CAUSE

This problem occurs because there may be an issue on the Xbox LIVE Servers with the content that you are trying to download. Maintenance may need to be performed on the content that you are trying to download.

THINGS TO TRY

Redownload the content

Because the problem may occur because of network problems or other temporary issues, first retry to download the content from your download history. To do this, follow these steps:
  1. Cancel any pending downloads in your active downloads queue. For more information, see the following article in the Xbox Support Knowledge Base:
    919422  (http://support.microsoft.com/kb/919422/ ) Description of and how to use the Xbox LIVE active downloads list
  2. Delete any partly completed downloads for the item that you are trying to download. To do this, follow these steps:
    1. In the My Xbox area, select System Settings.
    2. Select Memory, and then select your storage device.
    3. Locate the content type that you are trying to download and select it.
    4. In the list of items, look for the game or video item that you are trying to download. If the item is listed, select the item, and then select Delete.
  3. In the My Xbox area, select your Xbox LIVE profile.
  4. Select Manage Account.
  5. Locate Download History, and then press A.
  6. To try to redownload content, select the item, and press A.
  7. Select Download Again.

Maintenance may have to be performed on the content that you are trying to download

To notify the Xbox Customer Support team of this issue, contact Xbox Support by telephone. To view contact information for your region, please visit the following Xbox Support Web site:
http://www.xbox.com/support/contact (http://www.xbox.com/support/contact)

APPLIES TO
  • Microsoft XBox 360 Video Game System
  • Microsoft Xbox Live
  • Microsoft Xbox
Keywords: 
kbxbox360pacrimportal kbxbox360europeportal kbxbox360americasportal kbxboxts kbxbox360pacrimportal kbxbox360americasportal kbxbox360europeportal kbxboxgames kbxboxlivefeatures KB960052
 

Article Translations

 

Related Support Centers