FIX: An error message is logged, and the synchronization may take a long time to finish when you use an application to synchronize a merge replication that contains a SQL Server 2005 Compact Edition subscriber

Article translations Article translations
Article ID: 960142 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

You create a merge replication in an application that contains a Microsoft SQL Server 2005 Compact Edition subscriber. When you synchronize the merge replication, the synchronization may take a long time to complete. If you enable logging in SQL Server 2005 Compact Edition Client Agent, the following error message is logged in the Client Agent log file:
SQLCECA30: <Date>-<Time> UpdateStatistics Start app=<AppName>
SQLCECA30:<Date>-<Time> UpdateStatistics End hr=0 app=<AppName>
Note In this error message, <AppName> is a placeholder for the name of the application that synchronizes the merge replication.

CAUSE

This problem occurs because the automatic update statistics operation takes a long time to complete at the end of the synchronization.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites for installing this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Eula_en.rtfNot applicable114,90023-Apr-200717:40
Sqlceca30.dll3.0.5300.8294,28010-Nov-200823:53
Sqlcecompact30.dll3.0.5300.860,29610-Nov-200823:53
Sqlceer30en.dll3.0.5300.8136,60010-Nov-200823:57
Sqlceme30.dll3.0.5300.852,10410-Nov-200823:53
Sqlceoledb30.dll3.0.5300.8140,16810-Nov-200823:53
Sqlceqp30.dll3.0.5300.8533,38410-Nov-200823:53
Sqlcese30.dll3.0.5300.8291,72010-Nov-200823:53
System.data.sqlserverce.dll3.0.5300.8236,44010-Nov-200822:21

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

REFERENCES

For more information about the Incremental Servicing Model for SQL Server, click the following article number to view the article in the Microsoft Knowledge Base:
935897 An Incremental Servicing Model is available from the SQL Server team to deliver hotfixes for reported problems
For more information about the same problem that occurs on SQL Server Compact 3.5, click the following article number to view the article in the Microsoft Knowledge Base:
963060 FIX: An error message is logged, and the synchronization may take a long time to finish when you synchronize a merge replication that contains a SQL Server Compact 3.5 subscriber: "UpdateStatistics Start app=&lt;UserAppName&gt;.exe"
For more information about the naming schema for SQL Server updates, click the following article number to view the article in the Microsoft Knowledge Base:
822499 New naming schema for Microsoft SQL Server software update packages
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 960142 - Last Review: August 24, 2009 - Revision: 4.0
APPLIES TO
  • Microsoft SQL Server 2005 Compact Edition
Keywords: 
kbsurveynew kbautohotfix kbfix kbqfe kbexpertiseadvanced kbhotfixserver KB960142

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com