Non vengono eliminati alcuni archivi dello stato utente scaduti su System Center Configuration Manager 2007 State Migration Point

Identificativo articolo: 960189 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Si consideri lo scenario seguente:
  • È possibile configurare un ruolo di punto di migrazione dello stato in un server del sito RTM di System Center Configuration Manager 2007.
  • Acquisire alcuni stati utente e quindi ripristinarli.
  • Attendere il tempo necessario per l'archivio dello stato da eliminare nel punto di migrazione dello stato.
Dopo l'eliminazione di archivio di stato si verifica, è possibile trovare che solo due archivi scaduti vengono eliminati. Altri archivi scaduti non vengono eliminati.

Inoltre, il file Smpmgr.log indica che l'eliminazione di archivio prima sia stata eseguita correttamente ma il secondo l'eliminazione di archivio non riesce con il seguente messaggio di errore:
CheckAndDeleteSMPStores non riuscita con codice di errore (80004005)

Cause

Il modulo dello stato della migrazione punto non inizializza correttamente la lunghezza di nome computer per l'iterazione successiva quando si elimina lo stato scaduto archivi in un ciclo. Il problema fa sì che il secondo tentativo di rimuovere l'archivio scaduto. Dopo l'eliminazione di archivio scaduti, viene visualizzato il messaggio di errore.

Risoluzione

Informazioni su Service Pack

Per risolvere il problema, procurarsi l'ultimo service pack per Microsoft System Center Configuration Manager 2007, disponibile da questo sito web Microsoft: http://www.microsoft.com/downloads/details.aspx?FamilyID=3318741a-c038-4ab1-852a-e9c13f8a8140
Per un elenco dei problemi risolti in questo service pack, fare clic sul numero di articolo riportato di seguito nel della Microsoft Knowledge Base:
971348Elenco di aggiornamenti rapidi e gli aggiornamenti contenuti in System Center Configuration Manager 2007 Service Pack 2

Informazioni sull'hotfix

È disponibile un hotfix supportato. Tuttavia, questo hotfix è destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Applicare questo aggiornamento rapido (hotfix) solo per i sistemi in cui si verificano il problema descritto in questo articolo. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale aggiornamento rapido (hotfix).

Se l'aggiornamento rapido (hotfix) è disponibile per il download, non vi è una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se in questa sezione non viene visualizzato, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se è necessaria la risoluzione dei problemi, potrebbe essere necessario creare una richiesta di assistenza separata. I normali costi del servizio supporto tecnico clienti Microsoft verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido (hotfix). Se non viene visualizzata la lingua in uso, è perché un aggiornamento rapido (hotfix) non è disponibile per tale lingua.

Prerequisiti

È necessario disporre di System Center Configuration Manager 2007 per applicare questo aggiornamento rapido (hotfix).

Necessità di riavvio

Non è necessario riavviare il computer dopo avere applicato questo aggiornamento rapido (hotfix).

Informazioni sulla sostituzione della correzione

Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri aggiornamenti rapidi (hotfix).

Informazioni sui file

La versione in lingua inglese di questo hotfix presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e ore dei file sono elencate in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario nell'elemento di Data e ora nel Pannello di controllo.
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Smpmgr.dll4.0.5931.14986,88031/12 / 200722: 00x 86

Nota Le informazioni di attributo di file valide per x 86 piattaforma, la piattaforma x 64, ICP1 e ICP2.

Status

Microsoft ha confermato che si tratta di un problema con i prodotti elencati nella sezione "Si applica a".

Informazioni

Per ulteriori informazioni sui file di registro per la distribuzione del sistema operativo nei sistemi System Center Configuration Manager 2007 Service Pack 1 (SP1), visitare il seguente sito Web Microsoft:
http://technet.microsoft.com/en-us/library/bb932135.aspx
Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
961269Solo due archivi dello stato utente scaduti vengono eliminati su un server di sito è in esecuzione System Center Configuration Manager 2007 Service Pack 1


Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Proprietà

Identificativo articolo: 960189 - Ultima modifica: martedì 3 marzo 2009 - Revisione: 1.1
Le informazioni in questo articolo si applicano a:
  • Microsoft System Center Configuration Manager 2007
Chiavi: 
kbmt kbautohotfix kbexpertiseinter kbsurveynew kbbug kbfix kbhotfixserver kbqfe kbpubtypekc KB960189 KbMtit
Traduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 960189
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti