A hyperlink control that is used to open a file or an e-mail message fails in an application that uses MSXML 6.0 on a Windows XP-based or Windows Vista-based computer

Article translations Article translations
Article ID: 960380 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

On a Windows XP-based or Windows Vista-based computer, you run an application that uses Microsoft XML Core Services (MSXML) 6.0. The application contains a hyperlink control that users can use to open a file or an e-mail message. However, in this scenario, the hyperlink control may fail.

This issue occurs if the following conditions are true:
  • The file URL or the e-mail message URL is encoded in the UTF-8 format.
  • The output is in the HTML format.
Note This issue does not occur if the URL starts with http://.

CAUSE

XSL Transformation (XSLT) does not recognize the UTF-8-encoded URL because there is no "no-uri-escaping" XSLT flag in MSXML 6.0.

RESOLUTION

Hotfix information for Windows XP

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 3 installed on the computer.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported x86-based versions of Windows XP
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Msxml6.dll6.20.1100.01,382,40011-Dec-200814:00

Hotfix information for Windows Vista and Windows Server 2008

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the “Hotfix Request” page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

Prerequisites

To apply this hotfix, you must have Windows Vista, Windows Vista Service Pack 1 (SP1), or Windows Server 2008 installed on the computer.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported x86-based versions of Windows Server 2008 and Windows Vista
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Msxml6.dll6.20.1101.01,343,48812-Dec-200805:40
Msxml6r.dll6.0.3883.02,04812-Dec-200805:40
Msxml6.dll6.20.1101.01,335,29612-Dec-200805:48
Msxml6r.dll6.0.3883.02,04812-Dec-200805:48
For all supported x64-based versions of Windows Server 2008 and Windows Vista
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Msxml6.dll6.20.1101.01,764,86412-Dec-200806:15x64
Msxml6r.dll6.0.3883.02,04812-Dec-200806:15x64
Msxml6.dll6.20.1101.01,732,60812-Dec-200806:09x64
Msxml6r.dll6.0.3883.02,04812-Dec-200806:09x64
For all supported Itanium-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Msxml6.dll6.20.1101.03,764,73612-Dec-200805:51
Msxml6r.dll6.0.3883.02,04812-Dec-200805:51

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 960380 - Last Review: October 8, 2011 - Revision: 3.0
APPLIES TO
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Business
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Windows Server 2008 Datacenter without Hyper-V
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 Standard without Hyper-V
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
Keywords: 
kbautohotfix kbexpertiseadvanced kbfix kbsurveynew kbqfe KB960380

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com