The IRET and IRETD instructions do not support the Nested Task (NT) flag in protected mode in a Windows Server 2008 Hyper-V environment

Article translations Article translations
Article ID: 960578 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

You have a program that uses an IRET or an IRETD instruction that matches the Intel specification. When you run this program in a Windows Server 2008 Hyper-V environment, this program may not execute the IRET or IRETD instruction.

Note This problem occurs only when this program runs in a virtual machine.

CAUSE

Hyper-V emulates the IRET and IRETD instructions that are used in virtual machines. However, these emulated instructions do not support the Nested Task (NT) flag in protected mode.

Note The Intel CPU runs in protected mode.

RESOLUTION


Service Pack information

To resolve this problem, obtain the latest service pack for Windows Server 2008. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
968849 How to obtain the latest service pack for Windows Server 2008

Hotfix information


A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the “Hotfix Request” page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

Prerequisites

To apply this hotfix, the computer must be running Windows Server 2008 with Hyper-V.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2008 file information notes

The .manifest files and the .mum files that are installed in each environment are listed separately in the "Additional file information for Windows Server 2008" section. These files and their associated .cat (security catalog) files are critical to maintaining the state of the updated component. The .cat files are signed with a Microsoft digital signature. The attributes of these security files are not listed.
For all supported versions of Windows Server 2008 with Hyper-V
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Hvax64.exe6.0.6001.22319707,58427-Nov-200803:09x64
Hvboot.sys6.0.6001.22319109,83227-Nov-200805:52x64
Hvix64.exe6.0.6001.22319732,16027-Nov-200803:09x64
Virtualization.events.xmlNot applicable1,38411-Jul-200820:06Not applicable

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the IRET and IRETD instructions, visit the following Intel Web site:
http://www.intel.com/software/products/documentation/vlin/mergedprojects/analyzer_ec/mergedprojects/reference_olh/mergedProjects/instructions/instruct32_hh/vc143.htm
Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base: -
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information for Windows Server 2008

Additional files for all supported versions of Windows Server 2008 with Hyper-V
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_microsoft-hyper-v-drivers_31bf3856ad364e35_6.0.6001.22319_none_c5d8288ec8f19a2b.manifestNot applicable9,21627-Nov-200807:10Not applicable
Package_for_kb960578_sc_0~31bf3856ad364e35~amd64~~6.0.1.0.mumNot applicable1,52829-Nov-200821:02Not applicable
Package_for_kb960578_sc~31bf3856ad364e35~amd64~~6.0.1.0.mumNot applicable1,43029-Nov-200821:02Not applicable
Package_for_kb960578_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mumNot applicable1,53229-Nov-200821:02Not applicable
Package_for_kb960578_server~31bf3856ad364e35~amd64~~6.0.1.0.mumNot applicable1,43829-Nov-200821:02Not applicable

Properties

Article ID: 960578 - Last Review: October 8, 2011 - Revision: 2.0
APPLIES TO
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
Keywords: 
kbhyperv kbexpertiseadvanced kbfix kbautohotfix kbsurveynew kbqfe KB960578

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com