REVISIÓN: El proceso de host de la aplicación se bloquea cuando se llama al método CounterExists o el método Exists en un equipo multiprocesador en IIS 6.0

Seleccione idioma Seleccione idioma
Id. de artículo: 960718 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Tenga en cuenta la situación siguiente:
  • Tiene una aplicación ASP.NET o una aplicación basada en .NET Framework.
  • La aplicación se ejecuta en un equipo multiprocesador.
  • La aplicación llama al método PerformanceCounterCategory.CounterExists o el método PerformanceCounterCategory.Exists .
En esta situación, observa que el proceso de host de la aplicación se bloquea. Al mismo tiempo, puede anotarse un evento que se parece al siguiente en el registro de sucesos de Windows:

Tipo de suceso: información
Origen del suceso: Error de aplicación
Categoría de evento: (100)
ID. de suceso: 1004
<date>Fecha: <fecha>
<time>Tiempo: <hora>
Usuario: N/d equipo: nombre_equipo
Descripción: Errores de aplicación (w3wp.exe), versión 6.0.3790.3959, módulo con error desconocido, versión 0.0.0.0, dirección con error < dirección de memoria >.

Causa

Este problema se produce debido a un problema en el archivo Aspperf.dll.

Solución

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Esta revisión sólo se aplican a sistemas que experimenten el problema descrito en este artículo. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Debe tener para aplicar este hotfix instalado el Service Pack 2 (SP2) de Windows Server 2003.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.

x 86

Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Aspperf.dll6.0.3790.442321.50410 De diciembre de 200804: 53x 86

X 64

Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataformaRequisito de SPTipo de servicio
Aspperf.dll6.0.3790.442327,64810 De diciembre de 200802: 37x 64SP2No aplicable
Waspperf.dll6.0.3790.442321.50410 De diciembre de 200802: 37x 86SP2GUAU

IA-64

Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataformaRequisito de SPTipo de servicio
Aspperf.dll6.0.3790.442347.10410 De diciembre de 200802: 37IA-64SP2No aplicable
Waspperf.dll6.0.3790.442321.50410 De diciembre de 200802: 37x 86SP2GUAU

Solución

Para evitar este problema, utilice uno de los métodos siguientes:
  • Evite una llamada al método System.Diagnostics.PerformanceCounterCategory.CounterExists o el método System.Diagnostics.PerformanceCounterCategory.Exists .
  • Llamar la función LoadLibray en el archivo Aspperf.dll antes de llamar al método CounterExists . No llame a la función FreeLibrary hasta que finalice el método CounterExists .
  • Elimine la clave del Registro siguiente para desinstalar los contadores de rendimiento de ASP:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ASP

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Este problema se produce con más frecuencia en un entorno virtualizado.

Para obtener más información acerca de los métodos PerformanceCounterCategory , visite el siguiente sitio Web de Microsoft:
http://msdn.microsoft.com/en-us/library/system.diagnostics.performancecountercategory_methods.aspx

Referencias

Para obtener más información acerca de la terminología relativa de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 960718 - Última revisión: lunes, 2 de febrero de 2009 - Versión: 1.0
La información de este artículo se refiere a:
  • Servicios de Microsoft Internet Information Server 6.0
Palabras clave: 
kbmt kbhotfixserver kbautohotfix kbexpertiseinter kbexpertiseadvanced kbqfe kbsurveynew KB960718 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 960718

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com