When you search some specific terms in the German version of Windows XP, the search results are incorrect

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Article ID: 961067 - View products that this article applies to.
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SYMPTOMS

When you search some specific terms in the German version of Windows XP, the search results are incorrect.

CAUSE

The issue occurs because of an error in the word breaker for the German version of Windows XP. The word breaker (Infosoft.dll) breaks some words incorrectly.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 2 (SP2) or a later service pack installed.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Restart requirement

Although you do not have to restart the computer after you apply this hotfix, you must still rebuild the index to apply the new functionality to the index when you use one of the following products:
  • Windows Desktop Search 2.6.x
  • Windows Desktop Search 3.x
  • Windows Search 4.0
  • Windows XP Indexing Service
To rebuild the index, follow these steps for Windows Desktop Search or for Windows Search:
  1. Click Start, click Control Panel, and then click System and Maintenance.
  2. Click Indexing Options.
  3. In the Indexing Options window, click Advanced.
  4. Click Rebuild, and then click OK.
To rebuild the index, follow these steps for Windows XP Indexing Service:
  1. Click Start, click Run, type ciadv.msc, and then click OK.
  2. Expand the appropriate catalog.
  3. In the Directories section, right-click each directory that you want to rescan, point to All Tasks, and then click Rescan (Full).

Hotfix replacement information

This hotfix does not replace any other hotfixes.

Registry information

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
This hotfix updates the DWORD value of the following RemoveAltWords registry entry to 1:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ContentIndex\RemoveAltWords

Note If you set the value of the RemoveAltWords registry entry to 0, the registry will disable this hotfix, and the system will revert to its old behavior.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP with Service Pack 2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Infosoft.dll5.1.2600.3493449,02415-Dec-200814:15x86
Windows XP with Service Pack 3, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Infosoft.dll5.1.2600.5726449,02415-Dec-200813:58x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For help with Windows Search problems in Windows Vista, visit the following Microsoft web page:
Fix problems in which Windows Search is not working or searches are slower

Properties

Article ID: 961067 - Last Review: October 8, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Keywords: 
kbautohotfix kbexpertiseinter kbfix kbbug kbsurveynew kbqfe kbHotfixServer KB961067

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