Article ID: 961267 - Last Review: April 22, 2009 - Revision: 2.0

FIX: The application crashes when more than approximately 50 users connect to Visual Studio Team System Web Access 2008 SP1

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SYMPTOMS

You have Team System Web Access (TSWA) 2008 Service Pack 1 (SP1) installed on the system. When more than approximately 50 users connect to TSWA, the application crashes. Additionally, a “request time out” event that resembles the following is logged in the event log:

Event Type: Warning
Event Source: ASP.NET 2.0.50727.0
Event Category: Web Event
Event ID: 1309
Date: 11/11/2008
Time: 5:07:14 PM
User: N/A
Computer: Computer Name
Description:
Event code: 3001
Event message: The request has been aborted.

Process information:
Process ID: 2736
Process name: w3wp.exe
Account name: NT AUTHORITY\NETWORK SERVICE

Exception information:
Exception type: HttpException
Exception message: Request timed out.

CAUSE

This problem occurs because of a deadlock in the Work Item Tracking Object Model.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Visual Studio Team Explorer 2008 Service Pack 1 and Visual Studio Team System Web Access 2008 SP1 Power Tools installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
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File nameFile versionFile sizeDateTimePlatform
Microsoft.teamfoundation.workitemtracking.client.datastore.dll9.0.30729.40281,479,68005-Feb-200917:19x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Visual Studio Team System 2008 Team Foundation Server Service Pack 1
Keywords: 
kbexpertiseadvanced kbqfe kbsurveynew KB961267
 

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