Update: Der BizTalk Adapter für TIBCO EMS löscht keine Nachrichten aus der Warteschlange JMS-nachdem der Adapter erfolgreich die Nachrichten in BizTalk Server 2006 R2 empfängt

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 961346 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Auf dieser Seite

Problembeschreibung

Sollten Sie sich folgende Szenario in Microsoft BizTalk Server 2006 R2:
  • Verwenden Sie Microsoft BizTalk Adapter für TIBCO Enterprise Message Service (EMS) als ein Empfangsadapter.
  • Verwenden Sie BizTalk Adapter für TIBCO EMS, um Daten aus der Warteschlange Java Message Service (JMS) auf einem Server TIBCO EMS abzufragen.
  • Sie setzen dieTransaktion verwendenParameter auf "Ja" auf der Eigenschaftenseite des BizTalk Adapter für TIBCO EMS.
Nachdem der BizTalk Adapter für TIBCO EMS erfolgreich die Nachrichten empfängt, werden die Nachrichten in diesem Szenario nicht aus der JMS-Warteschlange auf dem TIBCO EMS-Server gelöscht.

Ursache

Dieses Problem tritt aufgrund eines Problems in der BizTalk-Adapter für TIBCO EMS.

Lösung

Hotfix-Informationen

A unterstützter Hotfix ist von Microsoft erhältlich. Allerdings ist dieser Hotfix vorgesehen. Um nur das Problem zu beheben, das in diesem Artikel beschrieben wird. Wendet diese Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt.

Wenn der Hotfix zum Download verfügbar ist, besteht ein "Hotfixdownload Verfügbare"Abschnitt am Anfang dieses Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, senden Sie eine Anforderung an Microsoft Customer Service and Support den Hotfix zu erhalten.

HinweisWenn weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich ist, Sie müssen möglicherweise eine separate Serviceanfrage erstellen. Normale Servicegebühren gelten für zusätzliche Supportfragen und Probleme, die weder für diesen speziellen Hotfix. Eine vollständige Liste der Microsoft-Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen möchten, besuchen Sie die folgende Microsoft-Website:
http://Support.Microsoft.com/contactus/?WS=Support
HinweisDas Formular "Hotfixdownload available" (Hotfixdownload verfügbar"zeigt die Sprachen für der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix ist nicht für diese Sprache zur Verfügung.

Voraussetzungen:

Sie müssen die Microsoft BizTalk Adapter für Enterprise-Anwendungen, die für diesen Hotfix installiert verfügen.

Neustartanforderung

Sie haben keinen Neustart des Computers nach der Installation dieses Hotfixes. Allerdings müssen Sie die BizTalk-Host-Instanz neu starten, nachdem Sie diesen Hotfix anwenden.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keinen zuvor veröffentlichten Hotfix.

Schritte nach der Installation

Nachdem Sie diesen Hotfix angewendet haben, steht ein neuer Registrierungswert DeleteAfterPoll aufgerufen. Der Registrierungswert DeleteAfterPoll gibt an, ob die Nachrichten aus der JMS-Warteschlange gelöscht werden, nachdem Sie von BizTalk Adapter für TIBCO EMS erfolgreich empfangen werden.

Wenn Sie festlegen, dieTransaktion verwendenParameter fürJaauf der Eigenschaftenseite des BizTalk Adapter für TIBCO EMS und möchten sicherstellen, dass die Nachrichten aus der JMS-Warteschlange gelöscht werden, nachdem Sie von BizTalk Adapter für TIBCO EMS empfangen werden müssen Sie die folgenden Registrierungsänderungen vornehmen:
  1. Klicken Sie aufStart, klicken Sie aufAusführen, TypRegedit, und klicken Sie dann aufOK.
  2. Suchen Sie, und klicken Sie dann auf den folgenden Registrierungsunterschlüssel:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\BizTalkAdapters\Config\Global\Adapters\TibcoEMS
  3. Auf derBearbeitenMenü, zeigen Sie aufNeue, und klicken Sie dann aufString-Wert.
  4. TypDeleteAfterPoll, und drücken Sie dann die EINGABETASTE.
  5. Auf derBearbeitenMenü, klicken Sie aufÄndern.
  6. TypTrueum den Wert festzulegen.

    Notizen
    • Dieser Wert ist die Groß-und Kleinschreibung berücksichtigt.
    • Wenn der Registrierungswert DeleteAfterPoll nicht vorhanden ist oder nicht auf einen beliebigen Wert festgelegt istTrue, Nachrichten werden nicht aus der JMS-Warteschlange gelöscht, nachdem die Nachrichten vom BizTalk Adapter für TIBCO EMS empfangen werden.
  7. Starten Sie die BizTalk-Host-Instanz neu.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher), die in der folgenden Tabelle aufgelistet sind. Die Datums- und Uhrzeitangaben für diese Dateien werden in Coordinated Universal Time (UTC) aufgelistet. Wenn Sie die Dateiinformationen anzeigen, wird es in die lokale Zeit konvertiert. Um die Differenz zwischen UTC-Zeit und lokaler Zeit zu suchen, verwenden Sie dieZeitzonedie Registerkarte derDatum und UhrzeitElement in der Systemsteuerung.
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumZeitPlattform
Microsoft.BizTalk.Adapters.tibcoems.dll1.0.5018.075,64029-Dec-200815: 31X 86
HinweisAufgrund von Dateiabhängigkeiten, das neueste Update, enthält diese Dateien können auch weitere Dateien enthalten.

Status

Microsoft hat bestätigt, dass es sich um ein Problem bei den Microsoft-Produkten handelt, die aufgeführt sind im Abschnitt "Betrifft".

Weitere Informationen

Wenn Sie festlegenTransaktion verwendenParameter fürNeinauf der Eigenschaftenseite des BizTalk-Adapter für TIBCO EMS-Adapter werden die Nachrichten automatisch aus der JMS-Warteschlange gelöscht, nachdem Sie von BizTalk Adapter für TIBCO EMS empfangen werden.

Weitere Informationen zu BizTalk Adapter für TIBCO EMS finden Sie auf der folgenden MSDN-Websites:
http://msdn.Microsoft.com/en-us/library/aa578375.aspx
http://msdn.Microsoft.com/en-us/library/aa559575.aspx
Weitere Informationen zur Terminologie für Softwareupdates finden Sie in folgendem Artikel der Microsoft Knowledge Base anzuzeigen:
824684Beschreibung der Standardterminologie, die zum Beschreiben von Microsoft-Softwareupdates verwendet wird

Eigenschaften

Artikel-ID: 961346 - Geändert am: Mittwoch, 16. Februar 2011 - Version: 1.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft BizTalk Server 2006 R2 Standard Edition
  • Microsoft BizTalk Server 2006 R2 Enterprise Edition
  • Microsoft BizTalk Server 2006 R2 Developer Edition
  • Microsoft BizTalk Server 2006 R2 Branch
Keywords: 
kbbtsadapters kbautohotfix kbbiztalk2006r2sp1fix kbbug kbexpertiseinter kbfix kbhotfixserver kbqfe kbmt KB961346 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 961346
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com