Full support for unattended installation and uninstallation is added to Intelligent Application Gateway 2007 Client Components setup

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Article ID: 961348 - View products that this article applies to.
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SYMPTOMS

You want to perform an unattended installation of Microsoft Intelligent Application Gateway (IAG) 2007 Client Components. To do this, you run the Setup.exe program together with an -s switch. Or, you run the MSI offline installer together with a /q switch. However, in any of the following scenarios, the installation is not completely unattended:
  • A computer restart is required when the Client Components are upgraded from an earlier version.
  • A version mismatch occurs, or some Client Components modules are corrupted.
In either scenario, you receive a corresponding message on the client computer.

Additionally, the only way that you can uninstall is by using Add or Remove Programs in Control Panel.

CAUSE

This problem occurs for the following reasons:
  • The unattended installation switch is not checked before messages are displayed.
  • Unattended un-installation from a command line is not supported.

RESOLUTION

Both reasons for this problem are resolved in Intelligent Application Gateway 2007 Service Pack 2 Update 1. After you apply this update, the following information is true:
  • By using the provided MSI offline installers, the Client Components can be installed without any user interaction. No messages are displayed during installation. If a computer restart is required, the computer will restart automatically.
  • The Client Components can be uninstalled silently by using one of MSI offline installation files.
To obtain this update, click the following article number to view the article in the Microsoft Knowledge Base:
968384 Description of Update 1 for Intelligent Application Gateway 2007 Service Pack 2

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Relevant updated files
  • WhlClientSetup.msi
  • WhlClientSetupAll.msi
  • WhlClientSetupOnlyNC.msi
  • WhlClientSetupSF.msi
  • WhlClientSetupWIO.msi
To uninstall IAG client components, follow these steps:
  1. Open a Command Prompt window. If you perform this operation on a Windows Vista-based computer, you must open an elevated Command Prompt by using an administrator account.
  2. Locate the folder that contains the MSI installer file.
  3. Type the following command, and then press ENTER:
    WhlClientSetup.msi /q UNINSTALL=1
  4. If a computer restart is required, the computer will restart automatically.
Note The client components offline installer (MSI) in Update 1 can even uninstall earlier versions of the client components. However, you cannot silently uninstall earlier versions.

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 961348 - Last Review: May 5, 2009 - Revision: 1.0
APPLIES TO
  • Microsoft Intelligent Application Gateway 2007
Keywords: 
kbexpertiseinter kbsurveynew kbbug kbfix kbqfe KB961348

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