Active Directory Certificate Services stürzt ab bei den Startvorgang, wenn die Einstellung FIM 2010 Certificate Management Beendigungsmodul auf Windows Server 2008-basierten Systemen aktiviert ist

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 961715 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Auf dieser Seite

Problembeschreibung

Stellen Sie sich das folgende Szenario vor:
  • Die Active Directory Certificate Services-Rolle ist auf einem Windows Server 2008 x 64-basierten Computer aktiviert.
  • Microsoft Forefront Identity Manager (FIM) 2010 Certificate Management wird installiert, und der Certificate Management Beendigungsmodul aktiviert ist in den Zertifikatdiensten.
In diesem Szenario stürzt ab bei den Startvorgang Active Directory-Zertifikatdienste.

Ursache

Wenn FIM-Verbindungs-Manager eine Ausnahme behandelt wird, überprüft er, ob der aktuelle Thread ausreichend zugesicherten Stapelspeicher verfügt. Auf X 64-basierte Systeme, schlägt diese Überprüfung fehl. Aus diesem Grund abstürzen Zertifikatsdienste.

Lösung

Hotfix-Informationen

Ein unterstützter Hotfix ist von Microsoft erhältlich. Der Hotfix ist jedoch nur zur Behebung des Problems das in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die das in diesem Artikel beschriebene Problem auftritt. Dieser Hotfix wird möglicherweise zu einem späteren Zeitpunkt weiteren Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf das nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download zur Verfügung steht, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an Microsoft-Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Normale Servicegebühren werden jedoch für weitere Fragen und Problemlösungen, die für diesen bestimmten Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen finden Sie auf folgender Website von Microsoft:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen, die für die der Hotfix verfügbar ist. Wenn Sie Ihre Sprache nicht angezeigt werden, liegt dies daran, dass ein Hotfix nicht für diese Sprache zur Verfügung steht.

Wichtige Hotfixes für Windows Vista und Windows Server 2008 sind in der gleichen Paketen enthalten. Allerdings kann nur eines dieser Produkte auf der Seite ? Hotfix Request ? aufgeführt werden. Um das Hotfix-Paket anzufordern, das für Windows Vista und Windows Server 2008 gilt, wählen Sie einfach das Produkt, das auf der Seite aufgeführt ist.

Voraussetzungen

Es gelten keine Voraussetzungen für Windows Server 2008. Um diesen Hotfix anwenden zu können, müssen Sie die Zertifikatsdienste-Serverrolle installiert haben.

Neustartanforderung

Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix installiert haben.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keinen zuvor veröffentlichten Hotfix.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind aufgelistet, in Coordinated Universal Time (UTC). Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC-Zeit und lokaler Zeit zu ermitteln, verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung.

Hinweise zu den Dateiinformationen für Windows Vista und Windows Server 2008

  • Service Pack 1 ist in Windows Server 2008 integriert. Aus diesem Grund gelten Dateien des RTM-Meilensteins nur für Windows Vista. Dateien RTM-Meilensteins weisen eine 6.0.0000. xxxxxx Versionsnummer.
  • Die Dateien MANIFEST (. Manifest) und MUM (.mum) Dateien, die installiert werden für jede Umgebung sind listed separately. Die MUM und MANIFEST-Dateien sowie die zugeordneten (.cat) Sicherheitskatalogdateien, sind wichtig, um den Status der aktualisierten Komponente beizubehalten. Die Sicherheitskatalogdateien, deren Attribute nicht aufgelistet sind, werden mithilfe einer Microsoft signiert digitale Signatur.
Für alle unterstützten x 64-basierten Versionen von Windows Vista und Windows Server 2008
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Certsrv.exe6.0.6001.22352710,65613-Jan-200904: 25X 64
Certsvcctrs.hNicht anwendbar1,72118-DEC-200721: 29Nicht anwendbar
Certsvcctrs.iniNicht anwendbar4,02018-DEC-200721: 29Nicht anwendbar
Microsoft-Windows-certificateservices-CA-ppdlic.xrm-MSNicht anwendbar4,26913-Jan-200905: 00Nicht anwendbar

Status

Microsoft hat bestätigt, dass dies ein Problem bei den Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind.

Weitere Informationen

Um die Einstellung FIM Certificate Management Beendigungsmodul in den Zertifikatdiensten zu konfigurieren, gehen Sie folgendermaßen vor:
  1. Installieren Sie die Forefront Identity Manager Certificate Management Zertifizierungsstelle (Certification Authority, CA) Komponenten für eine ZERTIFIZIERUNGSSTELLE.
  2. Starten Sie das Zertifizierungsstellen-MMC-Snap-in, und öffnen Sie das Dialogfeld Eigenschaften.
  3. Klicken Sie auf die Registerkarte Beendigungsmodul.
  4. Klicken Sie auf FIM Certificate Management Beendigungsmodul.
  5. Klicken Sie auf Eigenschaften.

Weitere Dateiinformationen für Windows Vista und Windows Server 2008

Weitere Dateien für alle unterstützten x 64-basierten Versionen von Windows Vista und Windows Server 2008
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Amd64_microsoft-Windows-Certificateservices-ca_31bf3856ad364e35_6.0.6001.22352_none_377b8f861c075493.manifestNicht anwendbar34,93013-Jan-200905: 23Nicht anwendbar
Package_for_kb961715_server_0 ~ 31bf3856ad364e35 ~ amd64 ~ ~ 6.0.1.0.mumNicht anwendbar1,63213-Jan-200916: 30Nicht anwendbar
Package_for_kb961715_server ~ 31bf3856ad364e35 ~ amd64 ~ ~ 6.0.1.0.mumNicht anwendbar1,43813-Jan-200916: 30Nicht anwendbar

Eigenschaften

Artikel-ID: 961715 - Geändert am: Montag, 7. Dezember 2009 - Version: 2.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Windows Server 2008 Standard
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Standard without Hyper-V
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 Datacenter without Hyper-V
Keywords: 
kbmt kbautohotfix kbexpertiseinter kbfix kbsurveynew kbqfe kbhotfixserver KB961715 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 961715
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com