Active Directory Certificate Services crashes during its startup process when the FIM 2010 Certificate Management Exit Module setting is enabled on Windows Server 2008-based systems

Article translations Article translations
Article ID: 961715 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

Consider the following scenario:
  • The Active Directory Certificate Services role is enabled on a Windows Server 2008 based computer.
  • Microsoft Forefront Identity Manager (FIM) 2010 Certificate Management is installed, and the Certificate Management Exit Module setting is enabled in Certificate Services.
In this scenario, Active Directory Certificate Services crashes during its startup process.

CAUSE

When FIM CM handles an exception, it verifies whether the current thread has sufficient committed stack space. On Windows Server 2008-based systems, this verification fails. Therefore, Certificate Services crashes.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the “Hotfix Request” page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

Prerequisites

No prerequisites are required for Windows Server 2008. To apply this hotfix, you must have the Certificate Services role installed.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Vista and Windows Server 2008 file information notes

  • Service Pack 1 is integrated into Windows Server 2008. Therefore, RTM milestone files apply only to Windows Vista. RTM milestone files have a 6.0.0000.xxxxxx version number.
  • The MANIFEST (.manifest) files and the MUM (.mum) files that are installed for each environment are listed separately. The MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files, whose attributes are not listed, are signed by using a Microsoft digital signature.
For all supported x86-based versions of Windows Vista and of Windows Server 2008


Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Certsrv.exe6.0.6001.22352520,70413-Jan-200903:44x86
Certsvcctrs.hNot Applicable1,72118-Dec-200721:29Not Applicable
Certsvcctrs.iniNot Applicable4,02018-Dec-200721:29Not Applicable
Microsoft-windows-certificateservices-ca-ppdlic.xrm-msNot Applicable4,26913-Jan-200903:57Not Applicable
For all supported x64-based versions of Windows Vista and of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Certsrv.exe6.0.6001.22352710,65613-Jan-200904:25x64
Certsvcctrs.hNot Applicable1,72118-Dec-200721:29Not Applicable
Certsvcctrs.iniNot Applicable4,02018-Dec-200721:29Not Applicable
Microsoft-windows-certificateservices-ca-ppdlic.xrm-msNot Applicable4,26913-Jan-200905:00Not Applicable

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

To configure the FIM Certificate Management Exit Module setting in Certificate Services, follow these steps:
  1. Install the Forefront Identity Manager Certificate Management certification authority (CA) components on a CA.
  2. Start the Certification Authority MMC snap-in, and then open the properties dialog box.
  3. Click the Exit Module tab.
  4. Click FIM Certificate Management Exit Module.
  5. Click Properties.

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008

Collapse this tableExpand this table
File namePackage_1_for_kb961715~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,992
Date (UTC)13-Jan-2009
Time (UTC)16:30
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size1,618
Date (UTC)13-Jan-2009
Time (UTC)16:30
PlatformNot Applicable
File nameX86_a1ede196f33d94898433d5e7816efe52_31bf3856ad364e35_6.0.6001.22352_none_b699b870efce1901.manifest
File versionNot Applicable
File size710
Date (UTC)13-Jan-2009
Time (UTC)16:30
PlatformNot Applicable
File nameX86_microsoft-windows-certificateservices-ca_31bf3856ad364e35_6.0.6001.22352_none_db5cf40263a9e35d.manifest
File versionNot Applicable
File size34,874
Date (UTC)13-Jan-2009
Time (UTC)04:43
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_microsoft-windows-certificateservices-ca_31bf3856ad364e35_6.0.6001.22352_none_377b8f861c075493.manifestNot Applicable34,93013-Jan-200905:23Not Applicable
Package_for_kb961715_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,63213-Jan-200916:30Not Applicable
Package_for_kb961715_server~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,43813-Jan-200916:30Not Applicable

Properties

Article ID: 961715 - Last Review: October 7, 2011 - Revision: 4.0
APPLIES TO
  • Windows Server 2008 Standard
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Standard without Hyper-V
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 Datacenter without Hyper-V
Keywords: 
kbfix kbqfe KB961715

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com