Si verifica un errore irreversibile in un server basato su Windows Server 2003 quando un utente accede a file condivisi sul server utilizzando una connessione SMB

Traduzione articoli Traduzione articoli
Identificativo articolo: 961799 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando un utente accede a file condivisi sul server utilizzando una connessione block (SMB) del messaggio di server, degli errori di stop riportati di seguito si verifica uno in un server basato su Windows Server 2003:
  • 0X0000000A (IRQL_NOT_LESS_OR_EQUAL)
  • 0X0000001E (KMODE_EXCEPTION_NOT_HANDLED)
  • 0 X 00000050 (PAGE_FAULT_IN_NONPAGED_AREA)
  • 0X000000C5 (DRIVER_CORRUPTED_EXPOOL)
  • 0X000000D1 (DRIVER_IRQL_NOT_LESS_OR_EQUAL)
  • 0X0000007E (SYSTEM_THREAD_EXCEPTION_NOT_HANDLED)
  • 0 X 00000024 (NTFS_FILE_SYSTEM)
Questo problema Ŕ stato osservato in genere su piattaforme server terminal in cui l'attivitÓ dell'utente sulla rete pu˛ causare errori.

Nota A causa di genericitÓ dei problemi di danneggiamento della memoria, non sono necessariamente interessati da questo problema specifico se si verifica un errore di interruzione in questo elenco sul server. Si consiglia di contattare supporto tecnico clienti di Microsoft per determinare se il problema si verifica o non.

Cause

Questo problema si verifica perchÚ il driver di rete (NetBIOS) NetBT.sys non gestisce correttamente un buffer quando viene ricevuto un pacchetto non valido dalla rete.

Campi non validi in un pacchetto non valido sono molto rari. Tuttavia, questo problema Ŕ stato segnalato in determinate circostanze su server precedenti alla versione 2.0.28 Samba.

Questo problema Ŕ stato segnalato anche su reti durante il switch di rete non funziona correttamente danneggiato alcuni pacchetti di dati sulla rete.

Risoluzione

Informazioni sull'hotfix per Windows Server 2003

╚ disponibile un hotfix supportato. Questo hotfix Ŕ tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica il problema descritto in questo articolo. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si Ŕ notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix Ŕ disponibile per il download, Ŕ una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, Ŕ necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi Ŕ necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui Ŕ disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, Ŕ perchÚ un aggiornamento rapido (hotfix) non Ŕ disponibile per tale lingua.

Prerequisiti

Per applicare questo aggiornamento rapido (hotfix), il server deve eseguire Windows Server Windows Server 2003 Service Pack 2.

NecessitÓ di riavvio

╚ necessario riavviare il computer dopo avere applicato questo aggiornamento rapido (hotfix).

Informazioni sulla sostituzione della correzione

Questo aggiornamento rapido (hotfix) sostituisce i seguenti hotfix:
955860Utilizzo elevato della CPU si verifica per sei secondi in un computer basato su Windows Server 2003 che dispone di pi¨ schede di rete
948354A causa di un problema di temporizzazione nel modulo "NetBIOS su TCP/i IP", un computer basato su Windows Server 2003 pu˛ riavviare in modo imprevisto e quindi generare un 0x000000D1 errore irreversibile

Informazioni del Registro di sistema

Per utilizzare questo aggiornamento rapido (hotfix), non si dispone apportare modifiche al Registro di sistema.

Informazioni sui file

La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello Data e ora nel Pannello di controllo.

Windows Server 2003 Service Pack 2, versione 86 e x
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
NetBT.sys5.2.3790.4452180.22427-Gen-200911: 40x 86
Windows Server 2003 Service Pack 2, versione basata su Itanium
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
NetBT.sys5.2.3790.4452561,66427-Gen-200914: 00IA-64
Windows Server 2003 Service Pack 2, versione 64 x
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
NetBT.sys5.2.3790.4452347,13627-Gen-200914: 02x 64
Windows XP Service Pack 2, versione 64 x
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
NetBT.sys5.2.3790.4452347,13627-Gen-200914: 02x 64

Workaround

Per ovviare al problema, utilizzare uno dei metodi descritti di seguito.

Soluzione alternativa 1

Se nell'ambiente di rete vengono utilizzati server Samba precedenti alla versione 2.0.28, aggiornare i server Samba 2.0.28 versione o una versione successiva.

Soluzione 2

Se si identifica l'hardware di rete funziona correttamente, Ŕ necessario ripristinare l'hardware. Supporto tecnico clienti Microsoft Ŕ possibile estrarre l'indirizzo IP di origine del pacchetto non valido dallo stack di chiamate.

Soluzione 3

╚ possibile ridurre significativamente il numero di occorrenze di questo problema disattivando remoto notifica delle modifiche di sottocartella in Esplora. Questo metodo, il problema del principale non viene risolto, ma riduce notevolmente determinato traffico di rete (i pacchetti SMB) che pu˛ essere interessato da pacchetti errati. Di conseguenza, questo problema si verifica meno frequentemente.

Per implementare questa soluzione alternativa, installare l'hotfix 831129. Seguire le istruzioni nella sezione "Informazioni di installazione" di articolo della Microsoft knowledge base 831129.Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
831129Struttura di cartelle sfarfallio quando si visualizza un'unitÓ di rete mappata in Esplora risorse
note
  • Se il server Ŕ in esecuzione Windows Server 2003 Service Pack 2, non Ŕ necessario installare aggiornamento rapido (hotfix) 831129. Infatti, aggiornamento rapido (hotfix) 831129 giÓ Ŕ inclusa in Windows Server 2003 Service Pack 2.
  • Quando si attiva la voce del Registro di sistema di NoRemoteRecursiveEvents o la voce di NoRemoteChangeNotify del Registro di sistema in un computer che utilizza una configurazione basati sulla rete (ad esempio quando una variabile % USERPROFILE % punti di in un'unitÓ di rete o di un percorso UNC), Windows Explorer non viene automaticamente aggiornata la visualizzazione quando le modifiche di file o cartella modifiche vengono apportate da altri utenti.

Status

Microsoft ha confermato che questo problema riguarda i prodotti sono elencati nella sezione "Si applica a".

Informazioni

I codici di errore stop menzionati nella sezione "Sintomi" sono molto comuni e potrebbero verificarsi a causa di qualsiasi tipo di danneggiamento della memoria. Per risolvere correttamente il problema, Ŕ necessario identificare una causa della rete.

Quando di risolvere il problema utilizzando il dump di memoria che viene generato dopo l'errore Stop, Ŕ possibile trovare il netbt! NbtCopyToStartOfIndicate funzione all'inizio dello stack di chiamata di un processore nel sistema.

Per ulteriori informazioni sulle immagini della memoria, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
254649Panoramica delle opzioni di file dump di memoria per Windows Server 2003, Windows XP e Windows 2000


Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
824684 Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft


I prodotti di terze parti che in questo articolo viene descritto sono forniti da produttori indipendenti. Microsoft non rilascia alcuna garanzia, implicita o esplicita, sulle prestazioni o all'affidabilitÓ di questi prodotti.

ProprietÓ

Identificativo articolo: 961799 - Ultima modifica: mercoledý 1 aprile 2009 - Revisione: 2.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Datacenter x64 Edition
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Chiavi:á
kbmt kbautohotfix kbexpertiseadvanced kbfix kbsurveynew kbqfe kbhotfixserver KB961799 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 961799
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com