Article ID: 961804 - Last Review: April 30, 2012 - Revision: 5.0

Virtual machines are missing in the Hyper-V Manager Console or when you create or start a virtual machine, you receive one of the following error codes: "0x800704C8", "0x80070037" or "0x800703E3"

System TipThis article applies to a different operating system than the one you are using. Article content that may not be relevant to you is disabled.
If you are a Small Business customer, find additional troubleshooting and learning resources at the Support for Small Business (http://smallbusiness.support.microsoft.com) site.
Notice
Important This article contains information that shows you how to help lower security settings or how to turn off security features on a computer. You can make these changes to work around a specific problem. Before you make these changes, we recommend that you evaluate the risks that are associated with implementing this workaround in your particular environment. If you implement this workaround, take any appropriate additional steps to help protect the computer.
Expand all | Collapse all

SYMPTOMS

When you try to create or start a virtual machine on a Windows Server 2008-based computer that has the Hyper-V role installed or on a Microsoft Hyper-V Server 2008 or on a Microsoft Hyper-V Server 2008 R2 computer, you experience one of the following problems:
  • You receive one of the following error messages:
    Error message 1
    The requested operation cannot be performed on a file with a user-mapped section open. (0x800704C8)
    Error message 2
    VMName’ Microsoft Synthetic Ethernet Port (Instance ID{7E0DA81A-A7B4-4DFD-869F-37002C36D816}): Failed to Power On with Error 'The specified network resource or device is no longer available.' (0x80070037).
    Error message 3
    The I/O operation has been aborted because of either a thread exit or an application request. (0x800703E3)
  • Virtual machines disappear from the Hyper-V Management Console.

CAUSE

These problems can be caused by antivirus software that is installed in the parent partition if the real-time scanning component is configured to monitor the Hyper-V virtual machine files.

RESOLUTION

Warning This workaround may make a computer or a network more vulnerable to attack by malicious users or by malicious software such as viruses. We do not recommend this workaround but are providing this information so that you can implement this workaround at your own discretion. Use this workaround at your own risk. If your system performance or stability is improved by the recommendations that are made in this article, contact your antivirus software vendor for instructions or for an updated version of the antivirus software. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
822158  (http://support.microsoft.com/kb/822158/ ) Virus scanning recommendations for Enterprise computers that are running currently supported versions of Windows

To resolve this issue, configure the real-time scanning component within your antivirus software to exclude the following directories and files:
  • Default virtual machine configuration directory (C:\ProgramData\Microsoft\Windows\Hyper-V)
  • Custom virtual machine configuration directories
  • Default virtual hard disk drive directory (C:\Users\Public\Documents\Hyper-V\Virtual Hard Disks)
  • Custom virtual hard disk drive directories
  • Snapshot directories
  • Vmms.exe (Note: May need to be configured as process exclusions within the antivirus software)
  • Vmwp.exe (Note: May need to be configured as process exclusions within the antivirus software)
Additionally, when you use Live Migration together with Cluster Shared Volumes on Windows Server 2008 R2, exclude the CSV path "C:\Clusterstorage" and all its subdirectories.

Notes
  • If virtual machines are missing from the Hyper-V Management console, you must configure the antivirus exclusions, and then restart the Hyper-V Virtual Machine Management service.
  • If you receive error code 0x800704C8, it is likely that the virtual machine configuration file was corrupted. In this case, and if restarting the Hyper-V Virtual Machine Management service does not resolve the issue, the virtual machine has to be re-created or restored from a backup.

MORE INFORMATION

To protect your virtual machines, we recommend that you install the antivirus software within the virtual machine.

For more information about best practices for Hyper-V security, please see the following article on the Microsoft TechNet Web site:
http://technet.microsoft.com/en-us/library/cc974516.aspx (http://technet.microsoft.com/en-us/library/cc974516.aspx)

APPLIES TO
Keywords: 
kbhyperv kberrmsg kbtshoot kbexpertiseinter kbsurveynew kbprb KB961804