FIX: You experience issues with Microsoft XPS signature when you use the XPS viewer or the XPS APIs

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Artigo: 962225 - Ver produtos para os quais este artigo se aplica.
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Sintomas

You experience one or more of the following issues when you use the XML Paper Specification (XPS) viewer or the XPS APIs:



NoteIn this article, when a computer is running Windows Vista, Windows 2008, Windows XP, or Windows Server 2003 and does not have this hotfix installed, the XPS viewer is known as "unpatched XPS viever" and the XPS APIs are known as "unpatched XPS APIs".
  • Issue 1

    You apply a signature to an XPS document that contains a thumbnail image by using the Windows 7 XPS Viewer. However, the signature does not appear in neither the unpatched System.Windows.Xps.Packaging.XpsDocument.Signatures collection nor in the unpatched XPS Viewer.
  • Issue 2

    You apply a signature to an XPS document that contains document structure elements by using the Windows 7 XPS Viewer. The signature does not appear in neither the unpatched System.Windows.Xps.Packaging.XpsDocument.Signatures collection nor in the unpatched XPS Viewer. Additionally, if you apply a signature to this XPS document by using the unpatched XPS Viewer or the System.Windows.Xps.Packaging.XpsDocument.SignDigitally method, the signature is invalid when you use the Windows 7 XPS Viewer to view the XPS document.

Causa

Cause of Issue 1

This problem occurs because the unpatched System.Windows.Xps.Packaging.XpsDocument class requires that the thumbnail relationships must be included in an XPS document signature. This differs from the XPS specification.

Cause of Issue 2

This problem occurs because of an incompatible feature. The unpatched System.Windows.Xps.Packaging.XpsDocument.SignDigitally method does not sign the StoryFragment parts. However, the method in the Windows 7 XPS Viewer signs the StoryFragment parts for each XPS document according to the XPS specification.

Resolução

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

To download this hotfix from the MSDN Code Gallery, visit the following Microsoft Web site:
http://code.msdn.microsoft.com/KB962225
Note The MSDN Code Gallery displays the languages for which the hotfix is available. If you do not see your language listed, it is because the Code Gallery resource page is not available for that language.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note Alternatively, you can download this hotfix rollup from the following Microsoft Connect Web site:
https://connect.microsoft.com/VisualStudio/Downloads/DownloadDetails.aspx?DownloadID=25198

Prerequisites

You must have .NET Framework 3.5 Service Pack 1 installed to apply this hotfix.

Restart requirement

You don't have to restart the computer after you install the hotfix if no relatvie instance is in use.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
x86 version for Windows Server 2003 and Windows XP
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File nameFile versionFile sizeDateTimePlatform
Reachframework.dll3.0.6920.4000532,48028-Jan- 200922:47x86
Windowsbase.dll3.0.6920.40001,245,1842 8-Jan-200922:47x86
x64 version for Windows Server 2003 and Windows XP
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File nameFile versionFile sizeDateTimePlatform
Reachframework.dll3.0.6920.4000532,48028-Jan- 200921:36x64
Windowsbase.dll3.0.6920.40001,105,9202 8-Jan-200921:36x64
x86 version for Windows Vista SP1 and Windows Server 2008
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File nameFile versionFile sizeDateTimePlatform
Reachframework.dll3.0.6920.4000532,48005-Feb- 200900:20x86
Windowsbase.dll3.0.6920.40001,245,1840 5-Feb-200900:20x86
x64 version for Windows Vista SP1 and Windows Server 2008
Reduzir esta tabelaExpandir esta tabela
File nameFile versionFile sizeDateTimePlatform
Reachframework.dll3.0.6920.4000532,48005-Feb- 200900:26x86
Windowsbase.dll3.0.6920.40001,105,9200 5-Feb-200900:26x86

Ponto Da Situação

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Propriedades

Artigo: 962225 - Última revisão: 14 de janeiro de 2010 - Revisão: 3.0
A informação contida neste artigo aplica-se a:
  • Microsoft .NET Framework 3.5 Service Pack 1
Palavras-chave: 
kbmt kbhotfixserver kbexpertiseadvanced kbqfe kbsurveynew KB962225 KbMtpt
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Clique aqui para ver a versão em Inglês deste artigo: 962225

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