Many "Shutdown occurred" events are logged unnecessarily in the System log for every shutdown on a computer that is running Windows Server 2008 or Windows Vista Service Pack 1

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Article ID: 962920 - View products that this article applies to.
Support for Windows Vista Service Pack 1 (SP1) ends on July 12, 2011. To continue receiving security updates for Windows, make sure you're running Windows Vista with Service Pack 2 (SP2). For more information, refer to this Microsoft web page: Support is ending for some versions of Windows.
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Symptoms

You run Windows Server 2008 or Windows Vista Service Pack 1 on a computer that supports the Intelligent Platform Management Interface (IPMI) standard. An application on the computer uses the Microsoft IPMI driver to schedule system shutdowns. In this scenario, many "Shutdown occurred" events are logged unnecessarily in the System log for every system shutdown. Therefore, if the System log is constrained to a specific size, the additional "Shutdown occurred" events may override important hardware defect messages that were logged previously.

Cause

By default, the IPMI driver logs shutdown comments in the System log. However, the IPMI driver allocates only two bytes for the comment text of each event. Therefore, if the comment text is long, it is split into many "Shutdown occurred" events.

Resolution

To resolve this problem, apply this hotfix, and then follow the instructions in the "Registry information" section.

Hotfix information

Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the “Hotfix Request” page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

After the hotfix is installed, we recommend that you clear the System event logs after you successfully start the computer. If you are a developer, see ClearLog method of the RecordLog class on MSDN for more information.

Prerequisites

To apply this hotfix to a Windows Server 2008-based computer, no prerequisites are required.

To apply this hotfix to a Windows Vista-based computer, you must have Windows Vista Service Pack 1 installed on the computer. For more information about Windows Vista service packs, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

Registry information

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
For Windows Server 2008 R2 and newer operating systems, this fix has been included. To disable the comment text for "Shutdown occurred" events, follow these steps:

Note The following steps also work in Windows Server 2012. If the registry key does not exist, you can manually create the registry key.
  1. Open Registry Editor. To do this, click Start, type regedit in the Start Search box, and then press Enter.
  2. Locate and then right-click the following registry subkey:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\IPMI
  3. Point to New, and then click DWORD Value.
  4. Type DisableSELShutdownComment, and then press Enter.
  5. Right-click DisableSELShutdownComment, and then click Modify.
  6. In the Value data box, type 1, and then click OK.
  7. Exit Registry Editor.
  8. Restart the computer.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Vista and Windows Server 2008 file information notes

  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    Collapse this tableExpand this table
    VersionProductMilestoneService branch
    6.0.6000.16xxxWindows VistaRTMGDR
    6.0.6000.20xxxWindows VistaRTMLDR
    6.0.6001.18xxxWindows Vista SP1 and Windows Server 2008 SP1SP1GDR
    6.0.6001.22xxxWindows Vista SP1 and Windows Server 2008 SP1SP1LDR
  • Windows Server 2008 Service Pack 1 is integrated into Windows Server 2008.
  • The MANIFEST (.manifest) files and MUM (.mum) files that are installed for each environment are listed separately. MUM and MANIFEST files and their associated security catalog (.cat) files are critical to maintaining the state of the updated component. The security catalog files are signed with a Microsoft digital signature. The attributes of these files are not listed.
All supported x86-based versions of Windows Server 2008 and of Windows Vista
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ipmidrv.infNot applicable4,92022-Jan-200900:40Not applicable
Ipmidrv.sys6.0.6001.2235864,51222-Jan-200903:07x86
All supported x64-based versions of Windows Server 2008 and of Windows Vista
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ipmidrv.infNot applicable4,94422-Jan-200900:53Not applicable
Ipmidrv.sys6.0.6001.2235876,80022-Jan-200904:00x64
All supported Itanium-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ipmidrv.infNot applicable4,93221-Jan-200923:33Not applicable
Ipmidrv.sys6.0.6001.22358161,79222-Jan-200902:18IA-64

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information for Windows Server 2008 and for Windows Vista

Additional files for all supported x86-based versions of Windows Server 2008 and of Windows Vista

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Package_for_kb962920_client_1~31bf3856ad364e35~x86~~6.0.1.0.mumNot applicable1,36722-Jan-200916:15Not applicable
Package_for_kb962920_client~31bf3856ad364e35~x86~~6.0.1.0.mumNot applicable1,43122-Jan-200916:15Not applicable
Package_for_kb962920_sc_0~31bf3856ad364e35~x86~~6.0.1.0.mumNot applicable1,42122-Jan-200916:15Not applicable
Package_for_kb962920_sc~31bf3856ad364e35~x86~~6.0.1.0.mumNot applicable1,42322-Jan-200916:15Not applicable
Package_for_kb962920_server_0~31bf3856ad364e35~x86~~6.0.1.0.mumNot applicable1,42522-Jan-200916:15Not applicable
Package_for_kb962920_server~31bf3856ad364e35~x86~~6.0.1.0.mumNot applicable1,43122-Jan-200916:15Not applicable
Package_for_kb962920_winpesrv_0~31bf3856ad364e35~x86~~6.0.1.0.mumNot applicable1,42222-Jan-200916:15Not applicable
Package_for_kb962920_winpesrv~31bf3856ad364e35~x86~~6.0.1.0.mumNot applicable1,42922-Jan-200916:15Not applicable
X86_ipmidrv.inf_31bf3856ad364e35_6.0.6001.22358_none_fc04853d04d14a5f.manifestNot applicable1,67422-Jan-200916:17Not applicable

Additional files for all supported x64-based versions of Windows Server 2008 and of Windows Vista

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_ipmidrv.inf_31bf3856ad364e35_6.0.6001.22358_none_582320c0bd2ebb95.manifestNot applicable1,67622-Jan-200916:19Not applicable
Package_for_kb962920_client_1~31bf3856ad364e35~amd64~~6.0.1.0.mumNot applicable1,37522-Jan-200916:15Not applicable
Package_for_kb962920_client~31bf3856ad364e35~amd64~~6.0.1.0.mumNot applicable1,43922-Jan-200916:15Not applicable
Package_for_kb962920_sc_0~31bf3856ad364e35~amd64~~6.0.1.0.mumNot applicable1,42922-Jan-200916:15Not applicable
Package_for_kb962920_sc~31bf3856ad364e35~amd64~~6.0.1.0.mumNot applicable1,43122-Jan-200916:15Not applicable
Package_for_kb962920_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mumNot applicable1,43322-Jan-200916:15Not applicable
Package_for_kb962920_server~31bf3856ad364e35~amd64~~6.0.1.0.mumNot applicable1,43922-Jan-200916:15Not applicable
Package_for_kb962920_winpesrv_0~31bf3856ad364e35~amd64~~6.0.1.0.mumNot applicable1,43022-Jan-200916:15Not applicable
Package_for_kb962920_winpesrv~31bf3856ad364e35~amd64~~6.0.1.0.mumNot applicable1,43722-Jan-200916:15Not applicable

Additional files for all supported Itanium-based versions of Windows Server 2008

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ia64_ipmidrv.inf_31bf3856ad364e35_6.0.6001.22358_none_fc06293304cf535b.manifestNot applicable1,67522-Jan-200916:15Not applicable
Package_for_kb962920_sc_0~31bf3856ad364e35~ia64~~6.0.1.0.mumNot applicable1,42522-Jan-200916:15Not applicable
Package_for_kb962920_sc~31bf3856ad364e35~ia64~~6.0.1.0.mumNot applicable1,42622-Jan-200916:15Not applicable
Package_for_kb962920_server_0~31bf3856ad364e35~ia64~~6.0.1.0.mumNot applicable1,42922-Jan-200916:15Not applicable
Package_for_kb962920_server~31bf3856ad364e35~ia64~~6.0.1.0.mumNot applicable1,43422-Jan-200916:15Not applicable
Package_for_kb962920_winpesrv_0~31bf3856ad364e35~ia64~~6.0.1.0.mumNot applicable1,42622-Jan-200916:15Not applicable
Package_for_kb962920_winpesrv~31bf3856ad364e35~ia64~~6.0.1.0.mumNot applicable1,43322-Jan-200916:15Not applicable

Properties

Article ID: 962920 - Last Review: June 27, 2014 - Revision: 8.0
Applies to
  • Windows Server 2008 Standard
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Datacenter without Hyper-V
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Server 2008 Standard without Hyper-V
  • Windows Vista Service Pack 1, when used with:
    • Windows Vista Ultimate
    • Windows Vista Home Premium
    • Windows Vista Home Basic
    • Windows Vista Enterprise
    • Windows Vista Business
    • Windows Vista Business 64-bit Edition
    • Windows Vista Ultimate 64-bit Edition
    • Windows Vista Home Premium 64-bit Edition
    • Windows Vista Home Basic 64-bit Edition
    • Windows Vista Enterprise 64-bit Edition
Keywords: 
kbautohotfix kbexpertiseinter kbsurveynew kbbug kbfix kbqfe KB962920

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