การแก้ไข: คุณได้รับข้อความข้อผิดพลาด 0x0000007e ทำให้หยุดชะงักบนหน้าจอสีน้ำเงินเมื่อมีการตั้งค่าแอตทริบิวต์ AppPoolCredentials จริงและคุณใช้บัญชีโดเมนเป็นรหัสประจำตัวการพูลโปรแกรมประยุกต์ใน IIS 7.0

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 962943 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

พิจารณาสถานการณ์ต่อไปนี้::
  • โปรแกรมประยุกต์เว็บที่ใช้ในข้อมูลบริการทางอินเทอร์เน็ต (IIS) 7.0 บนคอมพิวเตอร์ที่ใช้ Windows Vista หรือ ในคอมพิวเตอร์ที่ใช้ Windows Server 2008 คุณได้
  • คุณมีการพิสูจน์ตัวจริงของ Windows และโหมดเคอร์เนลตรวจสอบที่เปิดใช้งาน

    หมายเหตุ:นี่คือ โดยค่าเริ่มต้น
  • คุณได้useAppPoolCredentialsแอตทริบิวต์การตั้งค่าเป็นจริงในส่วนการรับรองความถูกต้องในแฟ้ม Applicationhost.config คุณอาจเพิ่มแอตทริบิวต์นี้เพื่ออนุญาตให้ใช้การรับรองความถูกต้อง Kerberos เมื่อคุณใช้บัญชีโดเมนสำหรับรหัสประจำตัวของพูลโปรแกรมประยุกต์ ตัวอย่างเช่น แอตทริบิวต์นี้ต้องเพิ่มเมื่อคุณกำลังเรียกใช้ Microsoft Office SharePoint Server ไซต์ ส่วนการรับรองความถูกต้องมีลักษณะดังต่อไปนี้
    <windowsAuthentication enabled="true" useKernelMode="true" useAppPoolCredentials="true"/>
    หมายเหตุ:แฟ้ม Applicationhost.config จะอยู่ในนั้นไดรฟ์: \Windows\System32\inetsrv\config โฟลเดอร์
ในสถานการณ์สมมตินี้ ระบบปฏิบัติการอาจมีปัญหา นอกจากนี้ คุณได้รับข้อความข้อผิดพลาด 0x0000007e ทำให้หยุดชะงักบนหน้าจอสีน้ำเงิน

หมายเหตุ:เกิดปัญหานี้โดยทั่วไปบนเว็บเซิร์ฟเวอร์ที่โฮสต์ Office SharePoint Server 2007 ปัญหานี้เกิดขึ้นเนื่องจากความความต้องการตั้งค่าคอนฟิกของ Office SharePoint Server 2007 เมื่อมีใช้การรับรองความถูกต้องของ Kerberos อย่างไรก็ตาม ปัญหาอาจเกิดขึ้นสำหรับชนิดใดเว็บไซต์ที่กำลังใช้โหมดเคอร์เนลตรวจสอบ การรับรองความถูกต้องของ Kerberos และบัญชีโดเมนเป็นข้อมูลเฉพาะตัวของพูลโปรแกรมประยุกต์ที่กำหนดเอง

สาเหตุ

ปัญหานี้เกิดขึ้นเนื่องจากมีปัญหาที่เกิดขึ้นในโปรแกรมควบคุมโหมดเคอร์เนล HTTP (HTTP.sys)

การแก้ไข

ข้อมูลโปรแกรมแก้ไขด่วน

โปรแกรมแก้ไขด่วนที่ได้รับการสนับสนุนจาก Microsoft พร้อมใช้งานแล้ว อย่างไรก็ตาม โปรแกรมแก้ไขด่วนนี้มีเป้าหมายเพื่อการแก้ไขปัญหาที่อธิบายไว้ในบทความนี้เท่านั้น นำโปรแกรมแก้ไขด่วนนี้ไปใช้กับระบบที่พบปัญหาที่อธิบายไว้ในบทความนี้เท่านั้น โปรแกรมแก้ไขด่วนนี้อาจได้รับการทดสอบเพิ่มเติม ดังนั้น หากคุณไม่ได้รับความเสียหายรุนแรงจากปัญหานี้ เราขอแนะนำให้คุณรอการปรับปรุงซอฟต์แวร์ถัดไปที่มีโปรแกรมแก้ไขด่วนนี้

หากมีโปรแกรมแก้ไขด่วนพร้อมสำหรับการดาวน์โหลด คุณจะเห็นส่วน "โปรแกรมแก้ไขด่วนพร้อมดาวน์โหลด" อยู่ที่ด้านบนของบทความฐานความรู้นี้ หากส่วนนี้ไม่ปรากฏขึ้น โปรดติดต่อฝ่ายบริการสนับสนุนลูกค้าของ Microsoft เพื่อขอรับโปรแกรมแก้ไขด่วน

หมายเหตุ:หากเกิดปัญหาอื่น ๆ หรือ ถ้ามีการแก้ไขปัญหาเป็นสิ่งจำเป็น คุณอาจต้องสร้างการร้องขอบริการแยกต่างหาก ค่าใช้จ่ายในการสนับสนุนปกติจะเกิดขึ้นเมื่อมีคำถามและประเด็นการสนับสนุนอื่นๆ ซึ่งไม่จัดอยู่ในโปรแกรมแก้ไขด่วนเฉพาะที่กล่าวถึงนี้ สำหรับรายการของหมายเลขโทรศัพท์ของฝ่ายบริการและการสนับสนุนลูกค้าของ Microsoft ทั้งหมด หรือถ้าต้องการสร้างคำขอรับการสนับสนุนแยกต่างหาก โปรดเข้าสู่เว็บไซต์ของ Microsoft ต่อไปนี้::
http://support.microsoft.com/contactus/?ws=support
หมายเหตุ:แบบฟอร์ม "โปรแกรมแก้ไขด่วนพร้อมดาวน์โหลด" แสดงภาษาในโปรแกรมแก้ไขด่วนมีอยู่ หากคุณไม่เห็นภาษาของคุณ เป็นเพราะไม่มีโปรแกรมแก้ไขด่วนสำหรับภาษานั้น

โปรแกรมแก้ไขด่วนที่สำคัญของ Windows Vista และ Windows Server 2008 จะมีอยู่ในแพคเกจเดียวกัน อย่างไรก็ตาม หนึ่งเดียวของผลิตภัณฑ์เหล่านี้อาจจะแสดงอยู่บนหน้า “การร้องขอโปรแกรมแก้ไขด่วน ” หากต้องการร้องขอแพคเกจโปรแกรมแก้ไขด่วนที่ใช้กับทั้ง Windows Vista และ Windows Server 2008 เพียงแค่เลือกผลิตภัณฑ์ที่อยู่ในรายการในหน้านั้น

ข้อกำหนดเบื้องต้น

คุณต้องมี Windows Vista Service Pack 1 (SP1) หรือ Windows Server 2008 ที่ติดตั้งเมื่อต้องการใช้โปรแกรมแก้ไขด่วนนี้

ข้อกำหนดในการเริ่มต้นระบบคอมพิวเตอร์ใหม่

คุณต้องเริ่มระบบของคอมพิวเตอร์ใหม่หลังจากใช้โปรแกรมแก้ไขด่วนนี้

ข้อมูลการทดแทนโปรแกรมแก้ไขด่วน

โปรแกรมแก้ไขด่วนนี้ไม่ได้แทนที่โปรแกรมแก้ไขด่วนก่อนหน้านี้

ข้อมูลแฟ้ม

โปรแกรมแก้ไขด่วนรุ่นภาษาอังกฤษนี้มีแอตทริบิวต์แฟ้ม (หรือแอตทริบิวต์แฟ้มหลังจากนี้) ซึ่งแสดงในตารางต่อไปนี้ วันที่และเวลาของแฟ้มเหล่านี้จะปรากฏในรูปแบบเวลามาตรฐานสากล (UTC) เมื่อคุณดูข้อมูลแฟ้ม ข้อมูลจะถูกแปลงเป็นเวลาท้องถิ่น เมื่อต้องการค้นหาความแตกต่างระหว่างเวลา UTC กับเวลาท้องถิ่น ใช้โซนเวลาแท็บในนั้นวันที่และเวลารายการใน'แผงควบคุม'
iis 7.0, x 86
ยุบตารางนี้ขยายตารางนี้
ชื่อแฟ้มรุ่นของแฟ้มขนาดแฟ้มวันที่เวลาแพลทฟอร์ม
Http.sys6.0.600 1.22375401,40812 2009 Feb03:33x86
iis 7.0, x 64
ยุบตารางนี้ขยายตารางนี้
ชื่อแฟ้มรุ่นของแฟ้มขนาดแฟ้มวันที่เวลาแพลทฟอร์ม
Http.sys6.0.600 1.22375596,48012 2009 Feb04:10x64
iis 7.0, ia-64
ยุบตารางนี้ขยายตารางนี้
ชื่อแฟ้มรุ่นของแฟ้มขนาดแฟ้มวันที่เวลาแพลทฟอร์ม
Http.sys6.0.600 1.223751,143,80812 2009 Feb02:54ia 64

การหลีกเลี่ยงปัญหา

เมื่อต้องการแก้ไขปัญหานี้ การรับรองความถูกต้องของโหมดเคอร์เนลที่ปิดใช้งาน โดยใช้วิธีการต่อไปนี้อย่างใดอย่างหนึ่ง

วิธีที่ 1:

กำหนดค่าของการuseKernelModeองค์ประกอบเป็นเท็จในส่วน windowsauthentication ที่เหมาะสมในแฟ้ม ApplicationHost.config
<windowsAuthentication enabled="true" useKernelMode="false"/>

วิธีที่ 2

การปิดใช้งานการรับรองความถูกต้องของโหมดเคอร์เนล โดยใช้ตัวจัดการ IIS โดยให้ทำตามขั้นตอนต่อไปนี้::
  1. คลิกเริ่มการทำงานคลิกเรียกใช้ประเภท:inetmgr.exeแล้ว คลิกตกลง.
  2. ใน'ตัวจัดการ IIS ' ขยายServer Nameขยายเว็บไซต์แล้ว คลิกเว็บไซต์ที่คุณต้องการเปลี่ยนแปลง
  3. คลิกสองครั้งรับรองความถูกต้องคลิกการพิสูจน์ตัวจริงของ windowsการเน้นมัน แล้ว คลิกการตั้งค่าขั้นสูงในบานหน้าต่างการดำเนินการ
  4. คลิกเพื่อยกเลิกเลือกนั้นการเปิดใช้งานการรับรองความถูกต้องของโหมดเคอร์เนลกล่อง
หลังจากที่คุณปิดใช้งานการรับรองความถูกต้องของโหมดเคอร์เนล คุณต้องเริ่มต้นบริการ HTTP ซึ่งจะหยุด IIS เรียกใช้คำสั่งต่อไปนี้พรอมต์คำสั่งที่ยกระดับ
  • net stop http
  • net http เริ่มต้น
  • iisreset /start
หมายเหตุ:คำสั่งเหล่านี้จะหยุดการบริการ HTTP เมื่อคุณหยุดการบริการ HTTP คุณได้รับข้อความแสดงข้อความแจ้งเตือนที่ให้บริการต่าง ๆ ที่ขึ้นอยู่กับบริการ HTTP จะยังถูกหยุดลง จดระวังบริการเหล่านี้ขึ้นเพื่อ ให้คุณสามารถกำหนดว่า คุณต้องการดำเนินต่อ และเพื่อ ให้คุณสามารถรีเหล่านั้นหลังจากที่คุณเริ่มต้นบริการ HTTP บริการต่าง ๆ ที่ขึ้นอยู่กับบริการ HTTP จะขึ้นอยู่กับบทบาทของ Windows และโปรแกรมประยุกต์ที่มีการติดตั้งอยู่บนคอมพิวเตอร์

สถานะ

Microsoft ยืนยันว่าปัญหานี้เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ซึ่งมีการระบุไว้ในส่วน "การใช้งาน"

ข้อมูลเพิ่มเติม

เรียกสแตกออก

ถ้าคุณใช้การแก้จุดบกพร่องเครื่องมือสำหรับ Windows และเซิร์ฟเวอร์สัญลักษณ์ของ Microsoft เพื่อตรวจสอบแฟ้มการถ่ายโอนข้อมูลหน่วยความจำที่ถูกสร้างขึ้นหลังจากเกิดความล้มเหลว คุณจะสังเกตเห็นกองซ้อนเรียกสายที่มีลักษณะดังต่อไปนี้:
Child-SP          RetAddr           Call Site
fffffa60`02ff5b58 fffff800`01ba3644 nt!KeBugCheckEx
fffffa60`02ff5b60 fffff800`01b60f71 nt!PspUnhandledExceptionInSystemThread+0x24
fffffa60`02ff5ba0 fffff800`018c87d8 nt!PspSystemThreadStartup+0x9e
fffffa60`02ff5bd0 fffff800`018c86bd nt!_C_specific_handler+0x8c
fffffa60`02ff5c40 fffff800`018cfcff nt!RtlpExecuteHandlerForException+0xd
fffffa60`02ff5c70 fffff800`0188cd83 nt!RtlDispatchException+0x22f
fffffa60`02ff6360 fffff800`018b51a9 nt!KiDispatchException+0xc3
fffffa60`02ff6960 fffff800`018b3fa5 nt!KiExceptionDispatch+0xa9
fffffa60`02ff6b40 00000000`00010005 nt!KiPageFault+0x1e5
fffffa60`02ff6cd8 fffffa60`0805129e 0x10005
fffffa60`02ff6ce0 fffff800`01ad7ff3 HTTP!UlpThreadPoolWorker+0x28e
fffffa60`02ff6d50 fffff800`018ef546 nt!PspSystemThreadStartup+0x57
fffffa60`02ff6d80 00000000`00000000 nt!KxStartSystemThread+0x16
หมายเหตุ:ส่วนของสแตกการเรียกที่บ่งชี้ว่า เกิดความล้มเหลวเฉพาะระบบนี้ได้HTTP ! UlpThreadPoolWorker.

ข้อมูลอ้างอิง

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับการใช้การรับรองความถูกต้อง Kerberos ร่วมกับ Office SharePoint Server แวะไปที่เว็บไซต์ต่อไปนี้:
http://www.harbar.net/archive/2008/05/18/Using-Kerberos-with-SharePoint-on-Windows-Server-2008.aspx
http://blogs.msdn.com/webtopics/archive/2009/01/19/service-principal-name-spn-checklist-for-kerberos-authentication-with-iis-7-0.aspx

คุณสมบัติ

หมายเลขบทความ (Article ID): 962943 - รีวิวครั้งสุดท้าย: 16 มกราคม 2554 - Revision: 4.0
ใช้กับ
  • Microsoft Internet Information Services 7.0
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Server 2008 Standard without Hyper-V
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Windows Web Server 2008
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise
  • Windows Vista Ultimate
Keywords: 
kbHotfixServer kbautohotfix kbexpertiseinter kbexpertiseadvanced kbqfe kbsurveynew kbmt KB962943 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:962943

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com