FIX: Authorization rules in Microsoft Internet Information Services (IIS) 7.0 do not work if these rules contain a user who does not exist

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Article ID: 967070 - View products that this article applies to.
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SYMPTOMS

In Microsoft Internet Information Services (IIS) 7.0, you configure authorization rules by using IIS Manager or by editing the system.webServer/security/authorization section of the web.config file. These rules help you restrict users' access to Web content.

However, you may find that some of these authorization rules do not work. Specifically, some users whose permissions are set to Allow cannot access the content. Additionally, some users whose permissions are set to Deny can access the content.

CAUSE

The issue occurs because of a problem in the URL Authorization module (Urlauthz.dll). When this issue occurs, IIS stops processing any remaining rules if a user who is specified in the authorization rules does not exist.

If you examine the web.config file, you find that the authorization rules contain a user who does not exist.

For example, the system.webServer/security/authorization section of your web.config resembles the following:
<system.webServer>
        <security>
            <authorization>
                <remove users="*" roles="" verbs="" />
                <add accessType="Allow" users="domain\user1" />
                <add accessType="Allow" users="domain\user2" />
                <add accessType="Allow" users="domain\user3" />
                <add accessType="Allow" users="domain\user4" />
                <add accessType="Allow" users="domain\user5" />
                ...            
            </authorization>
        </security>
    </system.webServer>
If domain\user2 does not exist in Active Directory, the Allow permission is granted only for domain\user1. The permissions for the users who are listed after domain\user2 are ignored.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the “Hotfix Request” page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

Prerequisites

You must have Windows Vista Service Pack 1 or Windows Server 2008 installed to apply this hotfix.

Restart requirement

You must restart the computer if IIS is running when you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported x86-based versions of Windows Vista and of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Urlauthz.dll7.0.6001.2242524,06404-May-200912:21
Urlauthz.dll7.0.6002.2212824,06404-May-200910:31
For all supported x64-based versions of Windows Vista and of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Urlauthz.dll7.0.6001.2242527,13604-May-200912:40
Urlauthz.dll7.0.6002.2212827,13604-May-200912:19
For all supported IA-64-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Urlauthz.dll7.0.6001.2242555,29604-May-200912:30
Urlauthz.dll7.0.6002.2212855,29604-May-200912:13

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about URL Authorization in IIS 7.0, visit the following Web sites:
http://learn.iis.net/page.aspx/142/understanding-iis-7-url-authorization/
http://msdn.microsoft.com/en-us/library/ms691347.aspx

Properties

Article ID: 967070 - Last Review: June 10, 2009 - Revision: 2.1
APPLIES TO
  • Microsoft Internet Information Services 7.0
Keywords: 
kbhotfixserver kbautohotfix kbexpertiseadvanced kbqfe kbsurveynew KB967070

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