Some task sequences may not run on the client computers in System Center Configuration Manager 2007 Service Pack 1-based systems

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Article ID: 967359 - View products that this article applies to.
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SYMPTOMS

Not all advertised task sequences are processed in Microsoft System Center Configuration Manager 2007 Service Pack 1 (SP1)-based systems.

CAUSE

This problem occurs because of a synchronization issue in execution manager. Some tasks are deleted before they are handled in the pending task sequence queue.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft System Center Configuration Manager 2007, available from this Microsoft web site: http://www.microsoft.com/downloads/details.aspx?FamilyID=3318741a-c038-4ab1-852a-e9c13f8a8140
For a list of issues resolved in this service pack, click on the following article number in the Microsoft Knowledgebase:
971348 List of hotfixes and updates that are contained in System Center Configuration Manager 2007 Service Pack 2

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have System Center Configuration Manager 2007 Service Pack 1 (SP1) installed on the computer.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

System Center Configuration Manager 2007 SP1
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File nameFile versionFile sizeDateTimePlatform
Ccmdts.dll4.0.6221.1151367,99230-Nov-200822:10x86
Createtsmediaadm.dll4.0.6221.1151891,25630-Nov-200822:10x86
Mp.msiNot Applicable9,233,40830-Nov-200822:10Not Applicable
Osdsetuphook.exe4.0.6221.11511,302,39230-Nov-200822:10x86
Policyagentendpoint.dll4.0.6221.1151479,09630-Nov-200822:10x86
Sccm2007ac-sp1-kb967359-x86.mspNot Applicable2,313,21630-Nov-200822:10Not Applicable
Tscore.dll4.0.6221.11511,154,93630-Nov-200822:10x86
Tsprogressui.exe4.0.6221.1151695,16030-Nov-200822:10x86
Createtsmediaadm.dll4.0.6221.11517,886,20030-Nov-200822:10IA-64
Osdsetuphook.exe4.0.6221.11516,164,85630-Nov-200822:10IA-64
Tscore.dll4.0.6221.11515,347,18430-Nov-200822:10IA-64
Tsprogressui.exe4.0.6221.11515,652,84830-Nov-200822:10IA-64
Createtsmediaadm.dll4.0.6221.11514,119,92030-Nov-200822:10x64
Osdsetuphook.exe4.0.6221.11513,393,90430-Nov-200822:10x64
Tscore.dll4.0.6221.11512,328,94430-Nov-200822:10x64
Tsprogressui.exe4.0.6221.11513,017,08030-Nov-200822:10x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

If the following error message is logged in the PolicyAgentProvider.log file on the System Center Configuration Manager 2007 client, the asynchronous delivery queue has overflowed:
Event sink has been notified of an error (<80041061>). Description 0x80041061:
WBEM_E_QUEUE_OVERFLOW 2147749985 0x80041061
This behavior occurs when the event consumer becomes too slow.

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
To resolve this issue, change the following WMI registry values:
  • Change the value of following registry key to 35000000:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WBEM\CIMOM\Low Threshold On Events (B)

    Note The default value is 10000000.
  • Change the value of the following registry key to 55000000:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WBEM\CIMOM\High Threshold On Events (B)

    Note The default value is 20000000.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 967359 - Last Review: October 7, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft System Center Configuration Manager 2007
Keywords: 
kbautohotfix kbexpertiseinter kbsurveynew kbbug kbfix kbqfe KB967359

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