Si verificano problemi con replica DFS in un ambiente Active Directory basato su Windows Server 2003 R2

Traduzione articoli Traduzione articoli
Identificativo articolo: 967507 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

PUBBLICAZIONE RAPIDA

PUBBLICAZIONE RAPIDA GLI ARTICOLI CONTENGONO INFORMAZIONI IN RISPOSTA A EMERGENTI O ARGOMENTI UNIVOCI E POSSONO ESSERE AGGIORNATE APPENA SARANNO DISPONIBILI NUOVE INFORMAZIONI.

Sintomi

Si consideri lo scenario seguente:
  1. È possibile configurare DFSR (Distributed File System Replication) tra due basato su Windows Server 2003 R2 computer Server1 e il server 2.
  2. È possibile inserire un nuovo server, Server3, in questo gruppo di replica. La replica funziona correttamente.
  3. Rimuovere il server 3 da questo gruppo di replica ed eseguire il comando pollad dfsrdiag .
  4. È aggiornare Active Directory per eliminare il contenuto della cartella del server 3.
In questo scenario, quando si inserisce nuovamente Server 3 in questo gruppo di replica, potrebbero verificarsi perdite dei dati. Inoltre, potresti ricevere dati non corretti.

Cause

DFSR tiene traccia delle cartella principale FID ed elabora un meccanismo che viene chiamato la rimozione definitiva. Quando il server e la cartella replicata vengono rimossi dai dati di set di repliche viene mantenuti in Active Directory, il set di contenuti si trova in uno stato rimosso definitivamente.

Nella stessa cartella viene aggiunto nuovamente al set di repliche, è la stessa cartella e pertanto il FID stesso, il servizio DFSR non eseguirà la sincronizzazione nuovamente.

Questo problema si verifica perché la rimozione della cartella dal gruppo di replica e del server è il risultato di tutte le modifiche non intenzionali o latenza di replica di Active Directory.

Workaround

Per aggirare il problema, utilizzare uno dei seguenti metodi.

Metodo 1

Eliminare la cartella originale e quindi creare un'altra cartella con lo stesso nome.

Metodo 2

Disattivare la cartella replicata, eliminare il contenuto e quindi riattivare la cartella.

Status

Questo comportamento legato alla progettazione.

MICROSOFT E/O RELATIVE RAPPRESENTAZIONI DI NON DI CREAZIONE RISPETTIVI FORNITORI RELATIVAMENTE ALL'ADEGUATEZZA DELLE INFORMAZIONI CONTENGONO IN DOCUMENTI E IMMAGINI RELATIVE SI PUBBLICATO SU QUESTO SITO WEB PER QUALSIASI SCOPO. I DOCUMENTI E IMMAGINI RELATIVE PUBBLICATI SUL SITO WEB POSSONO INCLUDERE INACCURATEZZE TECNICHE O ERRORI DI BATTITURA. LE MODIFICHE VENGONO AGGIUNTI PERIODICAMENTE LE INFORMAZIONI NEL PRESENTE DOCUMENTO. MICROSOFT E/O I RELATIVI FORNITORI POTREBBERO RENDERE MIGLIORAMENTI E/O LE MODIFICHE NEL PRODOTTO (S) E/O (S) IL PROGRAMMA DESCRITTO DI SEGUITO IN QUALSIASI MOMENTO.

Per ulteriori informazioni sulla terminologia di utilizzo, visitare il seguente sito Web:
http://support.microsoft.com/tou/

Proprietà

Identificativo articolo: 967507 - Ultima modifica: lunedì 2 marzo 2009 - Revisione: 1.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Standard x64 Edition
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003 R2 Datacenter x64 Edition
Chiavi: 
kbmt kbexpertiseinter kbtshoot kbsurveynew kbprb KB967507 KbMtit
Traduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 967507
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com