Users cannot log on again after the automatic logoff period has elapsed if you use ADFS as the authentication scheme in Intelligent Application Gateway 2007

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Article ID: 967737 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario.
  • In Microsoft Intelligent Application Gateway 2007, you configure a trunk to use Active Directory Federation Services (ADFS) as its authentication scheme.
  • The Automatic scheduled logoff functionality is enabled in the trunk properties.
  • When the automatic logoff period has elapsed after a user logs on, the user receives the following message:
    This is a scheduled logoff from "PortalName." To continue working press OK within x seconds and log in again.
  • The user clicks OK within the allowed time and then is redirected to the logon page.
In this scenario, the User Name box on the logon page is unavailable (grayed out). Additionally, the User Name box is pre-populated with the user's ADFS group instead of with the user's name. In this situation, the user may not recognize the pre-populated ADFS group name. Also, an ADFS group does not have a password. Therefore, the user cannot log on to continue working.

CAUSE

In Intelligent Application Gateway 2007, only the same lead user can log on again after a scheduled logoff action. ADFS groups cannot log on again. Additionally, Intelligent Application Gateway does not redirect users to ADFS logon.

RESOLUTION

To resolve this problem, apply Intelligent Application Gateway 2007 Service Pack 2 Update 1. After you apply the hotfix, when the automatic scheduled logoff procedure occurs, a complete logoff procedure is enforced, and the user is redirected to a logoff page. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
968384 Description of Update 1 for Intelligent Application Gateway 2007 Service Pack 2

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 967737 - Last Review: May 5, 2009 - Revision: 1.0
APPLIES TO
  • Microsoft Intelligent Application Gateway 2007
Keywords: 
kbexpertiseinter kbsurveynew kbbug kbfix kbqfe KB967737

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