Article ID: 968003 - Last Review: February 5, 2012 - Revision: 3.0

Error: 0x80070005 when you try to install updates using Microsoft Update or Windows Update

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Symptom

When you try to install Windows Updates, you get error:
0x80070005

Cause

This issue can occur when accessing or copying files during the Windows Update process. Access can be denied if you are logged on to the computer as a standard user and this account does not have the proper permissions to install updates. This can also be the result of missing registry keys, due to malware.

Resolution

To fix this issue, follow the methods below. If the first method doesn't resolve the error, proceed to the next:

Method 1: Log in as an administrator

To check if you have an account with administrator permissions, follow the steps below. If you do have an admistrator account, you can log in to Windows with it and install the latest Windows Updates.
To log on as an administrator, you need to have a user account on the computer with an Administrator account type. To do this, click the lonk below to view the article on the Microsoft website and follow the steps for your scenario:

How do I log on as an administrator? (http://windows.microsoft.com/en-US/windows7/How-do-I-log-on-as-an-administrator)

Once you are logged on as an administrator, attempt to install updates again.

If the issue is not resolved, proceed to Method 2.

Method 2: Scan for malware.

Open your anti-virus software and run a scan to detect and remove any detected malware. 

If you don't have an anti-virus program on your computer you can use the Microsoft Safety Scanner to do this, follow these steps: 
  1. Go to the Microsoft Safety Scanner site at: Microsoft Safety Scanner (http://www.microsoft.com/security/scanner/en-us/default.aspx)
  2. Click Download Now.
  3. If prompted, click Run. Follow the on-screen instructions to download and install the Microsoft Safety Scanner. When prompted, add a shortcut to the Microsoft Safety Scanner to your desktop.
  4. From your desktop, double click the Microsoft Safety Scanner icon. When the Microsoft Safety Scanner program launches, click Scan Type, then click Full Scan, then click Next.
  5. After the scan is complete, remove all detected malware entries , and try to install Windows Updates again.
If the issue is still not resolved, proceed to Method 3.

Method 3: Edit your registry.

You can update the permissions on your PC using a script to resolve this issue. To do this, follow these steps.

Important: When you make changes to a registry key or subkey, we recommend that you export, or make a backup copy, of the key or subkey. You can save the backup copy to a location you specify, such as a folder on your hard disk or a removable storage device. If you make changes that you want to undo, you can import the backup copy. For information on how to backup your registry, visit: Back up the registry (http://windows.microsoft.com/en-US/windows7/Back-up-the-registry) (Windows 7) or Back up the registry (http://windows.microsoft.com/en-US/windows-vista/Back-up-the-registry) (Windows Vista).
  1. Go to: Download Center (http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=23510)
  2. Click Download. Follow the on-screen instructions to download the SubInACL tool. When prompted, save a shortcut of the tool to your desktop.
  3. Double click the SubInACL icon from your desktop. Follow the on-screen instructions to install the tool. When prompted, choose C:\Windows\System32 as the destination folder. NOTE: If Windows is installed elsewhere, choose the correct path for the Windows\System32 folder.
  4. Click the Start button, in the Search box type Notepad. Click Notepad.
  5. Highlight the text below, then right click the text, then left click Copy.

    @echo offsubinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=fsubinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=fsubinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=fsubinacl /subdirectories %SystemDrive% /grant=administrators=fsubinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=system=fsubinacl /subkeyreg HKEY_CURRENT_USER /grant=system=fsubinacl /subkeyreg HKEY_CLASSES_ROOT /grant=system=fsubinacl /subdirectories %SystemDrive% /grant=system=f@Echo =========================@Echo Finished.@Echo =========================@pause
  6. Right click anywhere in Notepad, then click Paste.
  7. Click File from the Notepad toolbar, then click Save As.
  8. In the File name box, type reset.cmd. In the left pane, click Desktop, then click Save.
  9. From your Desktop, right click the reset.cmd icon, then click Run asadministrator.
  10. A DOS-like window will appear processing commands. Note: It may take several minutes. Please be patient. When it is completed, you will be prompted with the message: Finished, press any key to continue.
Attempt to install the update again.

More Information

For more information about Windows Update, visit: Windows Update (http://windows.microsoft.com/en-US/windows/help/windows-update)

For more information about administrator accounts, visit: What is an administrator account? (http://windows.microsoft.com/en-GB/windows-vista/What-is-an-administrator-account)

For more information about malware prevention and elimination, visit: Computer viruses: description, prevention, and recovery (http://support.microsoft.com/kb/129972)


APPLIES TO
  • Microsoft Update
  • Microsoft Windows Update
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
Keywords: 
kbrapidpub kbnomt KB968003