Office Communications Server o servicios de extremo de Lync Server 2010 frente producirá un error después de mover la base de datos back-end

Seleccione idioma Seleccione idioma
Id. de artículo: 968100 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

Este problema se produce si uno o más de las siguientes condiciones son verdaderas:
  • Utilice el de Management Studio de SQL Server para mover las bases de datos back-end Office Communications Server o Lync Server 2010 a un nuevo SQL
    Instancia del servidor
  • Actualización de Office Communications Server o grupo de servidores front-end de Lync Server 2010 para que apunte a la nueva SQL Server la instancia que
    aloja las bases de datos back-end

El siguiente suceso de advertencia se registrará en el registro de sucesos de Lync Server 2010 :

Nombre del registro: Lync Server
Fuente: Servicios de usuario de LS
Fecha: dd/mm/aaaa hh: mm: AM|]PM
ID. de suceso: 32118
Categoría de tarea: (1006)
Nivel: advertencia
Palabras clave: clásico
Usuario: N/d
Equipo: servidor01.contoso.com
Descripción:
Servidor SQL entre la opción de encadenamiento de base de datos está deshabilitada para la base de datos rtc o rtcdyn. Esto puede deberse a adjuntar o restaurar
una base de datos existente. Puesto que esta condición provoca problemas de rendimiento, base de datos no puede adquirir hasta que se resuelva el problema.

Servidor de back-end: server01.contoso.com\lync base de datos: la cadena de conexión rtc:
Driver = {SQL Server Native Client 10.0};Trusted_Connection = yes;AutoTranslate=no;server=server01.contoso.com\lync;database=rtc;
Causa: Compruebe la descripción del registro de sucesos.

Resolución:
Habilite cross opción de encadenamiento de base de datos (mediante "sp_dboption '<dbname>', 'db encadenamiento', TRUE") para bases de datos rtc y rtcdyn.
Una vez hecho esto, el servicio automáticamente volverá a conectarse para el back-end.

El siguiente suceso de Error se registrará en el registro de eventos de Office Communications Server :

Nombre del registro: Communications Server
Origen: Servidor de OCS
Fecha: dd/mm/aaaa hh: mm: AM|]PM
ID. de suceso: 12304
Categoría de tarea: (1000)
Nivel: Error
Palabras clave: clásico
Usuario: N/d
Equipo: servidor01.contoso.com

Descripción:
Los servicios de usuario del componente Live Communications (aplicación: por defecto) informó de un error crítico: código C3EE7D3D (servidor SQL entre la opción de encadenamiento de base de datos está deshabilitada para la base de datos rtc o rtcdyn. Esto puede deberse a adjuntar o restaurar una base de datos. Puesto que esta condición provoca problemas de rendimiento, servicio se detendrá y no se iniciará hasta que se resuelva el problema.

Se mostrará el siguiente error de Office Communications Server:

Windows no puede iniciar el cliente de Office Communications Server en el equipo Local. Para obtener más información, revise el registro de sucesos del sistema. Si se trata de un servicio de Microsoft, póngase en contacto con el proveedor de servicio y haga referencia al código de error específico de servicio-1007780547
</dbname>

Causa

Este problema se produce si se ha deshabilitado la opción de encadenamiento entre bases de datos de la base de datos RTC y de la base de datos de RTCDyn. Siempre debe habilitarse la opción de encadenamiento entre bases de datos. Sin embargo, esta opción está deshabilitada cuando separar y volver a adjuntar las bases de datos.

Solución

Para resolver este problema, siga estos pasos para habilitar el encadenamiento de entre bases de datos de la base de datos RTC y de la base de datos de RTCdyn:
  1. En un equipo que ejecuta Microsoft SQL Server, conectar a la RTC de base de datos y a continuación, ejecute el siguiente SQL comando de SQL Server Management Studio:
    "sp_dboption rtc, 'db chaining', TRUE"
  2. Conectarse a la base de datos de RTCdyn y, a continuación, ejecute lo siguiente Comando SQL de SQL Server Management Studio:
    "sp_dboption rtcdyn,  'db chaining', TRUE"
  3. Iniciar los servicios Front-End.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Se refiere a:".

Propiedades

Id. de artículo: 968100 - Última revisión: domingo, 22 de abril de 2012 - Versión: 3.1
La información de este artículo se refiere a:
  • Microsoft Office Communications Server 2007 Standard Edition
  • Microsoft Office Communications Server 2007 Enterprise Edition
  • Microsoft Office Communications Server 2007 R2 Enterprise Edition
  • Microsoft Office Communications Server 2007 R2 Standard Edition
  • Microsoft Lync Server 2010 Enterprise Edition
  • Microsoft Lync Server 2010 Standard Edition
Palabras clave: 
kbexpertiseinter kbtshoot kbsurveynew kbprb kbmt KB968100 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 968100

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com