O Office Communications Server ou serviços do Lync Server 2010 Front End falhar após mover banco de dados back-end

Traduções de Artigos Traduções de Artigos
Artigo: 968100 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Sintomas

Esse problema ocorre se uma ou mais das seguintes condições forem verdadeiras:
  • Use o SQL Server Management Studio para mover os bancos de dados back-end Office Communications Server ou o Lync Server 2010 para uma nova SQL
    Instância do servidor
  • Atualização do Office Communications Server ou a instância de pool do servidor front-end Lync Server 2010 para apontar para o novo SQL Server
    hospeda os bancos de dados back-end

O seguinte evento de aviso será registrado no log de eventos do Lync Server 2010 :

Nome do log: Lync Server
Fonte: LS usuário serviços
Data: dd/mm/aaaa hh: mm: ssPM
Identificação de evento: 32118
Categoria de tarefa: (1006)
Nível: aviso
Palavras-chave: clássico
Usuário: n / a
Computador: server01.contoso.com
Descrição:
Servidor SQL entre a opção encadeamento de banco de dados está desabilitado para o banco de dados rtc ou rtcdyn. Isso pode ser causado por anexação ou restauração
banco de dados existente. Desde que essa condição causa problemas de desempenho, banco de dados não ser adquirido até que o problema seja resolvido.

Servidor back-end: server01.contoso.com\lync banco de dados: seqüência de conexão do rtc:
driver = {SQL Server 10.0 nativo do cliente};Trusted_Connection = yes;AutoTranslate=no;server=server01.contoso.com\lync;database=rtc;
Causa: Verifique a descrição do log de eventos.

Resolução:
Habilite entre o encadeamento de opção de banco de dados (usando "sp_dboption '<dbname>', 'db encadeamento', TRUE") para bancos de dados rtc e rtcdyn.
Feito isso, serviço reconectará automaticamente para o back-end.

O seguinte evento de erro será registrado no log de eventos do Office Communications Server :

Nome do log: Communications Server
Fonte: Servidor do OCS
Data: dd/mm/aaaa hh: mm: ssPM
Identificação de evento: 12304
Categoria de tarefa: (1000)
Nível: erro
Palavras-chave: clássico
Usuário: n / a
Computador: server01.contoso.com

Descrição:
Os serviços de usuário do componente Live Communications (aplicativo: padrão) relatou um erro crítico: código C3EE7D3D (servidor SQL entre a opção encadeamento de banco de dados está desabilitado para o banco de dados rtc ou rtcdyn. Isso pode ser causado por anexar ou restaurar um banco de dados existente. Desde que essa condição causa problemas de desempenho, o serviço será interrompido e não será iniciado até que o problema seja resolvido.

O seguinte erro será exibido Office Communications Server:

Windows não pôde iniciar o front-end do Office Communications Server no computador Local. Para obter mais informações, examine o Log de eventos do sistema. Se este for um serviço não-Microsoft, contate o fornecedor do serviço e consulte o código de erro específico do serviço-1007780547
</dbname>

Causa

Esse problema ocorre se a opção encadeamento entre bancos de dados foi desabilitada para o banco de dados RTC e o banco de dados RTCDyn. A opção encadeamento entre bancos de dados deve estar sempre ativada. No entanto, essa opção é desativada quando você desconecte e reconecte os bancos de dados.

Resolução

Para resolver esse problema, siga estas etapas para habilitar a propriedade de banco de dados encadeamento para o banco de dados RTC e o banco de dados RTCdyn:
  1. Em um computador que esteja executando o Microsoft SQL Server, conectar para o RTC banco de dados e execute o seguinte SQL comando de SQL Server Management Studio:
    "sp_dboption rtc, 'db chaining', TRUE"
  2. Conectar ao banco de dados RTCdyn e execute o seguinte Comando SQL do SQL Server Management Studio:
    "sp_dboption rtcdyn,  'db chaining', TRUE"
  3. Inicie os serviços de Front-End.

Ponto Da Situação

Microsoft confirmou que este é um problema nos produtos Microsoft que estão listados na seção "Aplica-se a".

Propriedades

Artigo: 968100 - Última revisão: 22 de abril de 2012 - Revisão: 3.1
A informação contida neste artigo aplica-se a:
  • Microsoft Office Communications Server 2007 Standard Edition
  • Microsoft Office Communications Server 2007 Enterprise Edition
  • Microsoft Office Communications Server 2007 R2 Enterprise Edition
  • Microsoft Office Communications Server 2007 R2 Standard Edition
  • Microsoft Lync Server 2010 Enterprise Edition
  • Microsoft Lync Server 2010 Standard Edition
Palavras-chave: 
kbexpertiseinter kbtshoot kbsurveynew kbprb kbmt KB968100 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 968100

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com