当一台基于 Windows Server 2008 的计算机上的系统状态备份失败时记录事件 id 12290 和 16387

文章翻译 文章翻译
文章编号: 968128 - 查看本文应用于的产品
展开全部 | 关闭全部

症状

当试图在一台基于 Windows Server 2008 的计算机上执行系统状态自动系统恢复 (ASR) 备份时将失败备份,并在应用程序日志中记录类似于下面这样的错误消息:

登录名称: 应用程序
源: VSS
事件 ID: 12290
级别: 警告
描述: 卷影复制服务警告: ASR 编写器错误 0x80070001。hr = 0x00000000。

登录名称: 应用程序
源: SPP
事件 ID: 16387
级别: 错误
描述: 卷影复制创建失败,因为报告的 ASR 编写器错误。更多的信息: 不正确的函数。(0x80070001)。

原因

如果在计算机上活动的 EISA 分区是隐藏的分区,则会出现此问题。Windows Server 2008 中的 ASR 编写器不支持隐藏活动分区。新的操作系统安装完成时在新的计算机上没有第一个完成初始超出体验 (OOBE) 程序制造商的或不使用磁盘实用程序清除磁盘的情况下,可能会将隐藏的 EISA 分区标记为活动。

如果计算机制造商的 OOBE 程序运行在安装 Windows 之前,此问题不会在新的计算机上发生。在这种情况下 OOBE 程序完成后,隐藏的分区被标记为非活动状态。然后,您可以安装 Windows 和备份已成功完成。

解决方案

若要解决此问题,请按照下列步骤操作。
  1. 单击 开始,指向 管理工具、 单击 计算机管理,然后单击 磁盘管理
  2. 单击包含现有的 Windows Server 2008 安装的卷。一般情况下,这是驱动器 c。
  3. 用鼠标右键单击该的卷,然后单击 将分区标为活动
  4. 单击 以确认该操作。

    注意在这种情况下完成其余的步骤之前,不能启动现有的 Windows 安装。
  5. 关闭计算机管理。
  6. 将 Windows Server 2008 安装 DVD 插入到 DVD 驱动器,然后重新启动计算机。
  7. 选择下面的选项,然后单击 下一步
    • 安装语言
    • 时间和货币格式
    • 键盘布局
  8. 单击 修复计算机
  9. 系统恢复选项 对话框中单击所要修复的操作系统,然后单击 下一步
  10. 在请 选择一种恢复工具,单击 命令提示符
  11. 命令提示符键入下面的命令,然后按 ENTER 键:
    副本 c:\windows\boot\PCAT\bootmgr c:\bootmgr
  12. 键入下面的命令,然后按 ENTER 键:
    属性 + h + s c:\bootmgr
  13. 键入下面的命令,然后按 ENTER 键:
    Bootrec /fixboot
  14. 键入下面的命令,然后按 ENTER 键:
    Bootrec /rebuildbcd
  15. 当系统提示您将安装添加到启动列表,请按 Y。
  16. 重新启动计算机。
  17. 请重试了完整的系统状态 ASR 备份。确认备份成功。

更多信息

如果不位于隐藏活动 EISA 分区在同一磁盘上的分区上安装了操作系统,您必须将分区标记为活动位于 EISA 分区所在的驱动器上的分区。 如果没有其他分区 EISA 分区所在的驱动器上存在,您必须创建一个分区并将它标记为活动状态。

属性

文章编号: 968128 - 最后修改: 2009年4月6日 - 修订: 2.0
这篇文章中的信息适用于:
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Datacenter without Hyper-V
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Server 2008 Standard
  • Windows Server 2008 Standard without Hyper-V
  • Windows Small Business Server 2008 Premium
  • Windows Small Business Server 2008 Standard
  • Windows Essential Business Server 2008
关键字:?
kbmt kberrmsg kbexpertiseinter kbexpertiseadvanced kbtshoot kbsurveynew kbprb KB968128 KbMtzh
机器翻译
注意:这篇文章是由无人工介入的微软自动的机器翻译软件翻译完成。微软很高兴能同时提供给您由人工翻译的和由机器翻译的文章, 以使您能使用您的语言访问所有的知识库文章。然而由机器翻译的文章并不总是完美的。它可能存在词汇,语法或文法的问题,就像是一个外国人在说中文时总是可能犯这样的错误。虽然我们经常升级机器翻译软件以提高翻译质量,但是我们不保证机器翻译的正确度,也不对由于内容的误译或者客户对它的错误使用所引起的任何直接的, 或间接的可能的问题负责。
点击这里察看该文章的英文版: 968128
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com