The scan engines are not updated as expected in Forefront Security for SharePoint, and a "Failed to extract the file(s)" error is logged in the ProgramLog.txt file

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Article ID: 968166 - View products that this article applies to.
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SYMPTOMS

The scan engines in Microsoft Forefront Security for SharePoint are not updated as expected. Additionally, the following error is logged in the ProgramLog.txt file:
"ERROR: UpdateException: GetFileCommand failed on <scanengine.dll>. SybSync:UnzipFile CabException: Failed to extract the file(s) from 'C:\Program Files\Microsoft Forefront Security\SharePoint\Data\Engines\x86\<ScanEngineName>\Bin\sybF2.tmp': 11: User aborted. CAB is readable. Failed to open 'C:\Program Files\Microsoft Forefront Security\SharePoint\Data\Engines\x86\<ScanEngineName>\Bin\aveMicrosoft.dll'. Error: 13. File exists. Attribs:'RW'."

"INFORMATION: The <ScanEngineName> scan engine has been rolled back."

CAUSE

This issue occurs because one of the scan engine update files contains a hidden attribute.

WORKAROUND

To work around this problem, follow these steps:
  1. In Windows Explorer, locate the following folder:
    C:\Program Files\Microsoft Forefront Security\SharePoint\Data\Engines\x86\<ScanEngineName>\Bin
  2. Make sure that the hidden files are visible. To do this, follow these steps:
    1. On the Tools menu, click File Options, and then click the View tab.
    2. In the Advanced settings list, click Show hidden files and folders under Hidden files and folders, and then click OK.
  3. Right-click the Ave<Scan_engine_name>.dll file.
  4. Click Properties, and then click to clear the Hidden check box.
  5. In Forefront Server Security Administrator, click Update Now under Scanner Updates to perform a manual update of the engine.

RESOLUTION

To resolve this problem, install Forefront Security for SharePoint Service Pack 3 (SP3).

For more information about Forefront Security for SharePoint Service Pack 3, click the following article number to view the article in the Microsoft Knowledge Base:
967995 Description of Forefront Security for SharePoint Service Pack 3

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 968166 - Last Review: July 1, 2009 - Revision: 1.0
APPLIES TO
  • Microsoft Forefront Security for SharePoint
  • Microsoft Forefront Security for SharePoint Service Pack 1
  • Microsoft Forefront Security for SharePoint Service Pack 2
Keywords: 
kbqfe kbexpertiseinter kbsurveynew kbprb KB968166

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