Hizmetler için geçersiz bir ImagePath belirtildiğinde Sistem Durumu Yedeklemesi başarısız oluyor

Bu makalede, hizmetler için geçersiz bir ImagePath belirtildiğinde Sistem Durumu Yedekleme'nin başarısız olması sorunu açıklanmaktadır.

Şunlar için geçerlidir: Windows Server 2012 R2, Windows 10 - tüm sürümler
Özgün KB numarası: 968247

Belirti

Windows Server 2008 Sistem Durumu Yedeklemesi aşağıdaki hatayla başarısız olabilir:

Yedeklemenin özeti:
Sistem durumunu yedekleme başarısız oldu [<tarih><saati>]
'C:\Windows\Logs\WindowsServerBackup\SystemStateBackup <tarih saati.log' başarıyla yedeklenen dosyaların günlüğü><>
Yedeklemenin başarısız olduğu dosyaların günlüğü
'C:\Windows\Logs\WindowsServerBackup\SystemStateBackup_Error <tarih><saati>.log'
Dosyaların sabit listesi başarısız oldu.
Dosya adı, dizin adı veya birim etiketi söz dizimi yanlış.

Olay günlüğünde aşağıdaki hatalar günlüğe kaydedilir:

Günlük Adı: Uygulama
Kaynak: Microsoft-Windows-Backup
Olay Kimliği: 517
Bilgisayar: <bilgisayar adı>
Açıklama: Yedekleme <şu> hata koduyla başarısız oldu: '2155348237' (Dosyaların sabit listesi başarısız oldu.). Sorun çözüldükten sonra lütfen yedeklemeyi yeniden çalıştırın.

Günlük Adı: Microsoft-Windows-Backup
Kaynak: Microsoft-Windows-Backup
Olay Kimliği: 5
Bilgisayar: <bilgisayar adı>
Açıklama:
<Yedekleme şu hata koduyla başarısız oldu:> '2155348237'.

Neden

Bir hizmet tarafından belirtilen ImagePath yedeklenemediğinden Sistem durumu yedeklemesi başarısız oluyor. Sistem günlüğünün daha yakından incelenmesi, bir hizmetin başlatılamadığını gösterir ve aşağıdaki gibi bir hata alırsınız.

Olay Türü: Hata
Olay Kaynağı: Hizmet Denetim Yöneticisi
Olay Kategorisi: Yok
Olay Kimliği: 7000
Açıklama:
<Servicename> hizmeti şu hata nedeniyle başlatılamadı: Sistem belirtilen yolu bulamıyor.

Başarısız hizmetin ImagePath'in gözden geçirilmesi geçersiz bir yolu veya dosya adını yansıtır.

Çözüm

Bu sorunu çözmek için şu adımları izleyin:

  1. Başlatılmayacak hizmeti belirlemek için Sistem Günlüğü'nü gözden geçirin.

  2. Yanlış ImagePath sorununu çözebilecek bilinen sorunlar ve güncelleştirilmiş yükleme paketi için hizmet yazılım satıcısına başvurun.

  3. Aşağıdaki seçeneklerden birini seçin:

    Seçenek 1: Sorunlu hizmetle ilgili yazılımı kaldırın. Kaldırıldığı anda sistem durumu yedeklemesini yeniden başlatın.

    Seçenek 2: Regedit kullanarak ImagePath'i geçerli bir yola ve dosya adına sahip olacak şekilde düzeltin.

Not

Her hizmetin benzersiz bir ImagePath'i olacağı için, doğru yol ve dosya adı belirgin değilse yazılım satıcısına başvurmanız gerekebilir.

Not

Aşağıdaki blog gönderisi, hatalı ImagePath deyimlerini tanımlamak için kullanılabilecek örnek bir betik içerir. Bu betik olduğu gibi ve garanti olmaksızın sağlanır:

https://blogs.technet.com/b/askcore/archive/2010/06/18/ps-script-for-blog-enumeration-of-the-files-failed.aspx