Forefront Security for Exchange Server cannot initiate Realtime scan jobs at startup, and error codes "0x80030020" and "0x80030021" are logged

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Article ID: 968253 - View products that this article applies to.
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SYMPTOMS

In Microsoft Forefront Security for Exchange Server, the Realtime scan jobs may not be loaded as expected. Additionally, the following errors are logged in the Programlog.txt file or in the HRLog.txt file:
0x80030020 (STG_E_SHAREVIOLATION)
0x80030021 (STG_E_LOCKVIOLATION)

CAUSE

Third-party performance monitoring software loads the FSCPerfMonitor.dll file to gain access to the Forefront Security for Exchange Server performance counters. Under certain circumstances, an exception may occur in the FSCPerfMonitor.dll process. This exception causes the third-party performance monitoring software to leave a handle open to the Scanjobs.fdb file. When Forefront Security for Exchange Server later tries to read from the Scanjobs.fdb file, the Scanjobs.fdb file has a lock on itself. Therefore, Forefront Security for Exchange Server fails to start the Realtime scan jobs.

RESOLUTION

To resolve this problem, install Microsoft Forefront Security for Exchange Server with Service Pack 2 (SP2). For more information, click the following article number to view the article in the Microsoft Knowledge Base:
960465 Description of Forefront Security for Exchange Server with Service Pack 2

Properties

Article ID: 968253 - Last Review: July 1, 2009 - Revision: 1.0
APPLIES TO
  • Microsoft Forefront Security for Exchange Server Service Pack 1
  • Microsoft Forefront Security for Exchange Server
Keywords: 
kbqfe kbexpertiseinter kbsurveynew kbprb KB968253

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