エラー メッセージ "Service Pack に必要とされるシステム コンポーネントが 1 つ以上不足しています" が Windows Vista Service Pack 2 をインストールしようとすると表示される。

文書翻訳 文書翻訳
文書番号: 968279 - 対象製品
すべて展開する | すべて折りたたむ

目次

現象

Windows Vista Service Pack 2 (SP2) をインストールするときに、次のエラー メッセージが表示されます。
Service Pack のインストールを続行できません。
Service Pack に必要とされるシステム コンポーネントが 1 つ以上不足しています。

原因

この問題は、Windows Vista SP2 のインストールに必要なシステム コンポーネントがコンピューター上に存在しないことが原因で発生します。

この問題は、一般的に、vLite を使用して Windows Vista のインストールをカスタマイズし、必要なシステム コンポーネントの一部が削除された場合に発生します。

解決方法

この問題を解決するには、正規の Microsoft ソフトウェア メディアを使用して Windows Vista Service Pack 1 を再インストールした後、Windows Vista SP2 をインストールします。

正規のマイクロソフト ソフトウェアの詳細については、「正規の Windows: よく寄せられる質問」を参照してください。

製品版の Windows Vista を搭載しているコンピューターでの Windows の再インストール

製品版の Windows Vista を購入している場合は、Vista インストール DVD から Vista を再インストールできます。

重要 以下の手順は、上級レベルのコンピューター ユーザーを対象としています。初級レベルのユーザーの場合、または Windows の再インストールに慣れていない場合は、友人に相談するか、マイクロソフトに問い合わせてサポートを受けることができます。詳細については、この資料の「Windows Vista Service Pack に関するサポートを受ける方法」を参照してください。この問題を解決するには、2 つの方法があります。
  • Windows Vista へのインプレース アップグレード
  • Windows Vista の再クリーン インストール
いずれの方法でも、個人データを外部ソースにバックアップする必要があります。また、ハードウェア デバイス (ビデオ カードやプリンターなど) を使用するために必要となる特殊なドライバーまたはソフトウェアを確認して準備する必要があります。

方法 1: Windows Vista のインプレース アップグレードを実行する

Windows Vista インストール DVD を使用してインプレース アップグレードを実行します。インプレース アップグレードでは、個人データおよび設定が可能な限り保持されます。

警告 インプレース アップグレードを実行する前に、結果的にコンピューター上の既存のデータが削除されるという最悪の事態に備える必要があります。このようなデータとして、個人データ、設定、ハードウェア ドライバー情報、ソフトウェア プログラムなどが挙げられます。最悪の事態が発生した場合は、プログラムをすべて再インストールすることが必要となる可能性があります。インプレース アップグレードを実行する前に、必ずディスクまたはその他の外部記憶装置に個人データをバックアップしてください。インプレース アップグレードを実行するには、以下の手順を実行します。

注: 実行前にこれらの手順を印刷しておくと、操作を実行しやすい場合があります。また、これらの手順を完了するのに数時間かかる場合があります。
  1. コンピューターを起動します。
  2. Windows Vista DVD を DVD ドライブに挿入し、ドライブ トレイを閉じます。セットアップ プログラムが自動的に起動するのを待ちます。
  3. セットアップ プログラムが自動的に起動されない場合は、[スタート] ボタン
    元に戻す画像を拡大する
    [スタート] ボタン
    をクリックし、[検索の開始] ボックスに「ドライブ:\setup.exe」と入力し、Enter キーを押します。

    注: この手順で、Drive はコンピューターの DVD ドライブのドライブ文字です。
  4. "今すぐインストール" 画面が表示されたら、[今すぐインストール] をクリックします。

    注: メッセージ "インストールの重要な更新プログラムの取得" が表示された場合は、[インターネットに接続して最新のインストールの更新プログラムを取得する (推奨)] をクリックしないでください。
  5. [インストールの種類] 画面が表示されたら、[アップグレード] をクリックします。
  6. 指示に従って、Windows Vista をインストールします。
  7. コンピューターで Windows Vista が実行されるようになれば、Windows Vista へのアップグレードは完了です。
アップグレードの完了後、Windows Vista のライセンス認証を行う必要があります。 Windows Vista のライセンス認証を行う方法の関連情報を参照するには、以下のサポート技術情報番号をクリックしてください。
940315 Windows Vista のライセンス認証を行う方法

オプション 2: Windows Vista のクリーン再インストールを実行する

警告 クリーン インストールを実行するときには、ドライブをフォーマットすることを選択できます。ドライブをフォーマットする場合、コンピューター上の既存のデータは削除されます。このようなデータとして、個人データ、設定、ハードウェア ドライバー情報、ソフトウェア プログラムなどが挙げられます。オペレーティング システムのインストール後に、プログラムをすべて再インストールする必要があります。新規インストールを実行する前には、ハード ディスク ドライブをフォーマットしない場合でも、必ず個人用のデータをディスクまたは他の外部記憶装置にバックアップしてください。 Windows Vista の再インストール方法の関連情報を参照するには、以下のサポート技術情報番号をクリックしてください。
918884 Windows Vista のインストール方法

プレインストール (OEM) 版の Windows Vista を搭載しているコンピューターでの Windows の再インストール

Windows Vista がプレインストールされた (OEM 版の) コンピューターでこのエラーが表示され、工場出荷時の既定値にリセットするためにサポートが必要な場合は、製造元に連絡する必要があります。元の出荷時の既定設定にリセットすると、Service Pack のインストールに必要なシステム コンポーネントがすべて復元されます。

OEM に問い合わせる前に、個人データをすべてバックアップしておく必要があります。OEM の修復ディスクを使用すると、データが失われることがあります。

OEM の問い合わせ先については、コンピューターに付属しているマニュアルを参照してください。

詳細

関連項目:

この資料で問題を解決できない場合は、以下のリンクをクリックして他のオプションを検索してください。 この資料に記載されているサードパーティ製品は、マイクロソフトと関連のない他社の製品です。明示または黙示にかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。

プロパティ

文書番号: 968279 - 最終更新日: 2012年5月21日 - リビジョン: 3.0
この資料は以下の製品について記述したものです。
  • Windows Vista Service Pack 2
  • Windows Vista Business
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
キーワード:?
kbtshoot kbinfo kbexpertisebeginner kbsurveynew kbprb KB968279
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com