Artikel-id: 968513 - Visa produkter som artikeln gäller.
Visa alla | Dölj alla

På den här sidan

Symptom

När du skriver en adress inuti adressfältet i Windows Internet Explorer 8 kanske ett fönster öppnas med följande meddelande:
Hämta Windows Search för att förbättra resultaten för historik och favoriter

Orsak

Detta problem uppstår om någon av följande förutsättningar föreligger:
  • Windows Search är inte installerat på datorn.
  • Windows Search är inte aktiverat.

Lösning

Diagnostisera och åtgärda problemet automatiskt

Felsökaren Windows Search fungerar inte och sökningen tar lång tid eller stängs av kanske automatiskt kan lösa problemet som beskrivs i artikeln.
Den här felsökaren löser många olika sorters problem.Mer informationKör nu

Jag löser det själv

Om du inte vill få meddelandet kan du använda någon av följande metoder. Välj den metod som passar bäst för din situation.

Metod 1: Hämta Windows Search

Om du använder Windows XP, Windows Vista eller en tidigare version av Windows Server än Windows Server 2008 Service Pack 2 (SP2), hämtar och installerar du den senaste versionen av Windows Search.

Klicka på länken Hämta Windows Search för att förbättra resultaten för historik och favoriter i meddelandefönstret i Internet Explorer.

Mer information om Windows Search finns på följande Microsoft-webbplatser:

Windows Search 4.0 för Windows XP (KB940157)

Windows Search 4.0 för Windows Vista x64-versionen (KB940157)

Windows Search 4.0 för Windows Vista SP1 (KB940157)

Metod 2: Aktivera Windows Search

Om du använder Windows 7, Windows Server 2008 Service Pack 2 (SP2) eller Windows Server 2008 R2 är Windows Search redan installerat på datorn. Du måste kanske dock aktivera funktionen, enligt instruktionerna för ditt operativsystem.

Windows 7
  1. Klicka på Start och sedan på Kontrollpanelen.
  2. Klicka på Program.
  3. Klicka på Aktivera eller inaktivera Windows-funktioner.
  4. Bläddra ned och markera kryssrutan Windows Search och klicka sedan på OK.
Video: Aktivera Windows-funktioner i Windows 7 (videon är på engelska)


Windows Server 2008 SP2 eller Windows Server 2008 R2
Öppna Serverhanteraren och expandera Roller.

Gör så här om rollen Filtjänster inte finns i listan i Rollsammanfattning:
  1. Klicka på Lägg till roller.
  2. Välj Filtjänster och klicka på Nästa.
  3. Klicka på Nästa så många gånger som krävs för att komma till skärmen Välj serverroller.
  4. I listan över tillgängliga rolltjänster markerar du Windows Search-tjänsten.
  5. Klicka på Installera.
Gör så här om rollen Filtjänster redan finns i listan i Rollsammanfattning:
  1. Under Filtjänster expanderar du Rolltjänster.
  2. Klicka på Lägg till rolltjänster.
  3. I fönstret Välj rolltjänster markerar du Windows Search-tjänsten och klickar sedan på Nästa.
  4. Om du vill indexera enheter markerar du dem och klickar på Nästa.
  5. Klicka på Installera.

Mer Information

Om du vill få hjälp att lösa ytterligare Windows Search-problem går du till följande Microsoft-webbplats för att köra den automatiska Windows Search-felsökaren:
Reparera Windows Search när programmet kraschar eller inte visar några resultat

Egenskaper

Artikel-id: 968513 - Senaste granskning: den 21 augusti 2013 - Revision: 10.0
Informationen i denna artikel gäller:
  • Windows Internet Explorer 8 på följande plattformar
    • Windows Vista Business
    • Windows Vista Starter
    • Microsoft Windows XP Home Edition
    • Microsoft Windows Server 2003 Standard Edition
    • Microsoft Windows XP Professional Edition
    • Microsoft Windows Server 2003 Web Edition
    • Microsoft Windows Server 2003, Standard x64 Edition
    • Microsoft Windows Server 2003 Enterprise Edition
    • Microsoft Windows Server 2003, Enterprise x64 Edition
    • Microsoft Windows Server 2003 Datacenter Edition
    • Windows Vista Ultimate
    • Windows Vista Home Premium
    • Windows Vista Home Basic
    • Windows Vista Enterprise
    • Windows Server 2008 Standard
    • Windows Web Server 2008
    • Windows Web Server 2008 R2
    • Windows Server 2008 R2 Datacenter
    • Windows Server 2008 Enterprise
    • Windows Server 2008 Datacenter
    • Windows Server 2008 R2 Standard
    • Windows Server 2008 R2 Enterprise
    • Windows 7 Enterprise
    • Windows 7 Enterprise N
    • Windows 7 Home Basic
    • Windows 7 Home Premium
    • Windows 7 Home Premium N
    • Windows 7 Professional
    • Windows 7 Professional N
    • Windows 7 Starter
    • Windows 7 Starter N
    • Windows 7 Ultimate
    • Windows 7 Ultimate N
Nyckelord: 
kbsurveytest kbfixme kbmatsfixme kbdownload atdownload kbhowto kbtshoot kbexpertisebeginner kbsurveynew kbprb kbvideocontent kbsmbportal KB968513

Ge feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com