Processamento de inventário de software do System Center Configuration Manager 2007 falha quando um arquivo de dados contém uma hora inválida

Traduções deste artigo Traduções deste artigo
ID do artigo: 968594 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Considere o seguinte cenário:
  • Um servidor de site do System Center Configuration Manager 2007 Service Pack 1 (SP1) recebe dados de inventário de software (.SID/.SIC arquivos) que contém uma referência para as datas de arquivo que tenha anos que estão fora do intervalo aceito de CTime de 3000 de 1970.
  • O fuso horário do servidor do site está à frente do Coordinated Universal Time (hora de Greenwich), como GMT+8.
Nesse cenário, o processo de inventário de software falhar e o arquivo inventoried será rejeitado.

Causa

Esse problema ocorre quando o componente de Software Inventory processador de serviço SMS Executive tenta ajustar data nos dados de arquivo que está fora do intervalo CTime para 1 º de janeiro de 1970. No entanto, o componente do processador de inventário de software usa o fuso horário local em vez de UTC quando ele redefine a data do arquivo para 1 º de janeiro de 1970. Quando você converter o fuso horário local em UTC, a data do arquivo é ainda inválida.

Resolução

Informações do Service Pack

Para resolver esse problema, obtenha o service pack mais recente do Microsoft System Center Configuration Manager 2007, disponível a partir deste site da Microsoft na Web: http://www.microsoft.com/downloads/details.aspx?FamilyID=3318741a-c038-4ab1-852a-e9c13f8a8140
Para obter uma lista dos problemas resolvidos neste service pack, clique no número de artigo seguinte na Microsoft Knowledgebase:
971348Lista de hotfixes e atualizações contidas no System Center Configuration Manager 2007 Service Pack 2

Informações do hotfix

Um hotfix suportado está disponível na Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente nos sistemas que apresentarem o problema descrito neste artigo. Este hotfix pode receber testes adicionais. Portanto, se esse problema não o prejudicar, recomendamos que aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo do Knowledge Base. Se esta seção não aparecer, contate o suporte e Atendimento para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou qualquer solução de problemas é necessária, talvez seja necessário criar uma solicitação de serviço separada. Os custos de suporte normais se aplicarão a questões de suporte adicionais e problemas que não se qualificam este hotfix específico. Para obter uma lista completa dos números de telefone de atendimento e suporte ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Você deve ter o Microsoft System Center Configuration Manager 2007 Service Pack 1 instalado para aplicar esse hotfix.
Observação Para resolver esse problema, instale esse hotfix nos servidores de site afetados do System Center Configuration Manager 2007 SP1.

Requisitos de reinicialização

Não é necessário reiniciar o computador após aplicar esse hotfix.

Informações de substituição do hotfix

Esse hotfix não substitui um hotfix lançado anteriormente.

Informações de arquivo

A versão em inglês deste hotfix apresenta os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas na hora universal coordenada (UTC). Quando você exibir as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Sinvproc.dll4.0.6221.1156111,48030 De novembro de 200822: 35x 86

Situação

A Microsoft confirmou que este é um problema nos produtos Microsoft listados na seção "Aplicar a".

Mais Informações

Após esse problema ocorre, você pode encontrar as informações a seguir no arquivo Sinvproc.log:
Processo Inventory arquivos... Processando arquivo: \Microsoft Configuration Manager\inboxes\auth\sinv.box\IVNHR29L.SID Processing Inventory c:\Arquivos de programas (x 86) para máquina: < nome máquina > ResId: 3 [OpCode = 6 Sinv = 1 FC = 0 resync = 0] geradas: < data & hora > SMS_SOFTWARE_INVENTORY_PROCESSOR < data & hora > 3040 (0x0BE0) Aviso: exceção detectada: O parâmetro está incorreto. ~ ~!! Arquivo movido \Microsoft Configuration Manager\inboxes\auth\sinv.box\IVNHR29L.SID c:\Arquivos de programas (x 86) para c:\Arquivos de programas (x 86) \Microsoft Configuration Manager\inboxes\sinv.box\BADSinv\czf1dp5r.SID no Directory BADSINV!!!
Para obter mais informações sobre a terminologia de atualização de software, clique no número abaixo para ler o artigo na Base de dados de Conhecimento:
824684Descrição da terminologia padrão usada para descrever as atualizações de software

Propriedades

ID do artigo: 968594 - Última revisão: segunda-feira, 20 de abril de 2009 - Revisão: 1.1
A informação contida neste artigo aplica-se a:
  • Microsoft System Center Configuration Manager 2007
Palavras-chave: 
kbmt kbexpertiseinter kbautohotfix kbsurveynew kbbug kbfix kbhotfixserver kbqfe kbpubtypekc KB968594 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 968594

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com