Přihlásit se pomocí účtu Microsoft
Přihlaste se nebo si vytvořte účet.
Dobrý den,
Vyberte jiný účet.
Máte více účtů.
Zvolte účet, pomocí kterého se chcete přihlásit.

Příznaky

V aplikaci Microsoft Dynamics CRM 4.0 používáte mnoho pracovních postupů. Tabulky AsyncOperationBase a WorkflowLogBase se zvětšují velmi velké a vyskytují se problémy s výkonem.

Příčina

K tomuto problému dochází proto, že v případě vytvoření pravidel pracovního postupu v tabulkách AsyncOperationBase a WorkflowLogBase databáze MSCRM se vytvoří instance pracovního postupu a záznam pracovního postupu. Po dokončení instance pracovního postupu ale zůstane záznam pracovního postupu v databázi. Proto se tabulky AsyncOperationBase a WorkflowLogBase budou dál rozrůstat. Časem se výkon snižuje.

Poznámka: Vlastnost AsyncOperationType pro tyto záznamy je nastavená na hodnotu 10.

Řešení

Tento problém je opravený v nejnovější kumulativní kumulativní aktualizaci pro Microsoft Dynamics CRM 4.0.
Další informace získáte kliknutím na následující číslo článku ve znalostní bázi Microsoft Knowledge Base:

949256 Aktualizace a oprava hotfix aplikace Microsoft Dynamics CRM 4.0 Důležité: Tato část, metoda nebo úkol obsahují kroky, které popisují, jak



upravit registr. Úprava registru nesprávným způsobem může způsobit vážné problémy. Proto vždy pečlivě zkontrolujte, jestli postupujete přesně podle těchto kroků. Jako dodatečnou ochranu registr před úpravami zálohujte. Potom můžete v případě problému registr obnovit. Další informace o zálohování a obnovení registru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:

322756 Postup zálohování a obnovení registru systému Windows Po instalaci opravy hotfix nám nastavte povolení této opravy hotfix v části Oprava pro

mě. Pokud chcete povolit opravu hotfix sami, přejděte do částiOpravaoprava sama.

Opravit automaticky



Pokud chcete povolit opravu hotfix automaticky, klikněte na tlačítko nebo propojení Opravit. Pak v dialogovém okně Stažení souboru klikněte na položku Spustit a postupujte podle kroků v průvodci opravou.




Poznámky

  • Tento průvodce může být dostupný jenom v angličtině. Tato automatická oprava však funguje i pro ostatní jazykové verze systému Windows.

  • Pokud právě nejste u počítače, který má tyto potíže, můžete opravu uložit na jednotku USB Flash nebo na disk CD a spustit ji v příslušném počítači později.


Pak přejděte do části"Vyřešilo to problém?".



Manuální oprava

Pokud chcete tuto opravu hotfix povolit, postupujte takto:

  1. Klikněte na Start,klikněte na Spustit,zadejte regedit a klikněte na
    OK.

  2. V Editoru registru vyhledejte tento podklíč:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM

  3. Zjistěte, jestli existuje položka registru DWORD s názvem AsyncRemoveCompletedWorkflows. Údaj hodnoty položky registru AsyncRemoveCompletedWorkflows musí být 1.

  4. Pokud položka registru AsyncRemoveCompletedWorkflows neexistuje, přidejte ji. Postupujte takto:

    1. Klikněte pravým tlačítkem myši na MSCRM,přejděte na New, klikněte na Hodnotu DWORD a do pole Název zadejte

      AsyncRemoveCompletedWorkflows.

    2. Poklikejte
      na AsyncRemoveCompletedWorkflowsa do pole Údaj hodnoty zadejte
      hodnotu 1.

    3. Klikněte na Start,klikněte
      na Spustit,zadejte iisreset a klikněte na
      OK.

      Poznámka: Pokud se hodnota v poli Údaj hodnoty pro hodnotu AsyncRemoveCompletedWorkflows typu DWORD vrátí na 0, microsoft Dynamics CRM si i po dokončení úkolů zachová záznamy pracovního postupu v databázi.

Poznámka: Tato oprava hotfix je pouze proaktivní. Pokud tedy nainstalujete a aktivujete opravu hotfix, odstraní se automaticky pouze nové záznamy pracovního postupu. Pokud jsou tabulky AsyncOperationBase a WorkflowLogBase už velké kvůli těmto záznamům pracovního postupu, musíte tyto tabulky vyčistit pomocí skriptu pro čištění Microsoft SQL Server, který je součástí následujícího článku znalostní báze Microsoft Knowledge Base:

968520 Pokud je tabulka AsyncOperationBase příliš velká v aplikaci Microsoft Dynamics CRM 4.0, je výkon pomalý

Byly potíže vyřešeny?

  • Ověřte, zda jsou potíže vyřešeny. Pokud ano, v této části již pro vás nejsou žádné potřebné informace. Pokud potíže přetrvávají, můžete kontaktovat podporu.

  • Budeme rádi, když nám to zpětnou vazbu vychytáte. Pokud nám chcete poslat svůj názor nebo nahlásit problémy s tímto řešením, napište nám prosím komentář na bloguOpravachyby nebo nám pošlete e-mailovou zprávu.

Další informace

Další informace o terminologii aktualizací softwaru najdete v následujícím článku znalostní báze Microsoft Knowledge Base:

824684 Popis standardní terminologie, která se používá k popisu aktualizací softwaru společnosti Microsoft. Další informace o opravě hotfix softwaru Microsoft Business Solutions CRM a terminologii aktualizačních balíčků najdete v následujícím článku znalostní báze Microsoft Knowledge Base:

887283 Oprava hotfix softwaru Microsoft Business Solutions CRM a standardy pojmenovávání aktualizačních balíčků

Potřebujete další pomoc?

Chcete další možnosti?

Prozkoumejte výhody předplatného, projděte si školicí kurzy, zjistěte, jak zabezpečit své zařízení a mnohem více.

Komunity vám pomohou klást otázky a odpovídat na ně, poskytovat zpětnou vazbu a vyslechnout odborníky s bohatými znalostmi.

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou jazyka?
Co ovlivnilo váš názor?
Po stisknutí tlačítka pro odeslání se vaše zpětná vazba použije k vylepšování produktů a služeb Microsoftu. Váš správce IT bude moci tato data shromažďovat. Prohlášení o zásadách ochrany osobních údajů.

Děkujeme vám za zpětnou vazbu.

×