Při použití velkého počtu pracovních postupů v aplikaci Microsoft Dynamics CRM 4.0 jsou tabulky AsyncOperationBase a WorkflowLogBase velmi rozsáhlé a dochází k problémům s výkonem

Překlady článku Překlady článku
ID článku: 968755 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Příznaky

V aplikaci Microsoft Dynamics CRM 4.0 používáte velký počet pracovních postupů. Tabulky AsyncOperationBase a WorkflowLogBase začnou být velmi rozsáhlé a dochází k problémům s výkonem.

Příčina

K těmto problémům dochází z toho důvodu, že se při spouštění pravidel pracovních postupů v tabulkách AsyncOperationBase a WorkflowLogBase v databázi MSCRM vytváří instance pracovních postupů a záznamy pracovních postupů. Po dokončení činnosti instance pracovního postupu však záznam daného pracovního postupu zůstane v databázi. Proto tabulky AsyncOperationBase a WorkflowLogBase neustále rostou. Po určité době dochází ke snížení výkonu.

Poznámka: Vlastnost AsyncOperationType pro tyto záznamy je nastavena na hodnotu 10.

Řešení

Tyto potíže jsou opraveny v nejnovější kumulativní aktualizaci pro aplikaci Microsoft Dynamics CRM 4.0. Další informace naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
949256 Aktualizace a opravy hotfix pro aplikaci Microsoft Dynamics CRM 4.0


Důležité: Tato část, metoda nebo úkol obsahuje kroky, které popisují úpravu registru. V případě úpravy registru nesprávným způsobem však mohou nastat závažné problémy. Proto vždy pečlivě kontrolujte, zda postupujete přesně podle těchto kroků. Jako dodatečnou ochranu registr před úpravami zálohujte. Potom můžete v případě problému registr obnovit. Další informace o zálohování a obnovení registru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
322756 Postup zálohování a obnovení registru v systému Windows


Chcete-li tuto opravu hotfix povolit, postupujte takto:
  1. Klikněte na tlačítko Start a na příkaz Spustit, zadejte příkaz regedit a potom klikněte na tlačítko OK.
  2. V programu Editor registru vyhledejte následující podklíč:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM
  3. Zjistěte, zda existuje položka registru DWORD s názvem AsyncRemoveCompletedWorkflows. Údaj hodnoty položky registru AsyncRemoveCompletedWorkflows musí být 1.
  4. Pokud položka registru AsyncRemoveCompletedWorkflows neexistuje, přidejte ji. Postupujte takto:
    1. Klikněte pravým tlačítkem myši na položku MSCRM, přejděte na příkaz Nový, klikněte na možnost Hodnota DWORD a do pole Název zadejte řetězec AsyncRemoveCompletedWorkflows.
    2. Dvakrát klikněte na položku AsyncRemoveCompletedWorkflows a do pole Údaj hodnoty zadejte hodnotu 1.
    3. Klikněte na tlačítko Start, klikněte na příkaz Spustit, zadejte příkaz iisreset a pak klikněte na tlačítko OK.

      Poznámka: Pokud se údaj v poli Údaj hodnoty u položky DWORD AsyncRemoveCompletedWorkflows vrátí zpět na hodnotu 0, bude aplikace Microsoft Dynamics CRM i nadále uchovávat v databázi záznamy pracovních postupů po dokončení příslušných úloh.
Poznámka: Tato oprava hotfix neúčinkuje zpětně. Po instalaci a aktivaci této opravy hotfix tedy budou automaticky odstraňovány pouze nové záznamy pracovních postupů. Pokud jsou již tabulky AsyncOperationBase a WorkflowLogBase kvůli starým záznamům pracovních postupů příliš rozsáhlé, je třeba tyto tabulky vyčistit pomocí čisticího skriptu systému Microsoft SQL Server, který je poskytnut v následujícím článku znalostní báze Knowledge Base:
968520 Je-li tabulka AsyncOperationBase v aplikaci Microsoft Dynamics CRM 4.0 příliš rozsáhlá, dochází k snížení výkonu

Další informace

Další informace o terminologii používané v aktualizacích softwaru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
824684 Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft
Další informace o standardní terminologii používané k popisu balíčků oprav hotfix a aktualizací softwaru Microsoft Business Solutions CRM naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
887283 Standardy používání názvů u balíčků oprav hotfix a aktualizací softwaru aplikace Microsoft Business Solutions CRM

Vlastnosti

ID článku: 968755 - Poslední aktualizace: 10. října 2011 - Revize: 2.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Dynamics CRM 4.0
Klíčová slova: 
kbmbsworkflow kbsurveynew kbmbsmigrate kbqfe KB968755

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com