As tabelas AsyncOperationBase e WorkflowLogBase crescem bastante e ocorrem problemas de desempenho quando você usa muitos fluxos de trabalho no Microsoft Dynamics CRM 4.0

Traduções deste artigo Traduções deste artigo
ID do artigo: 968755 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Sintomas

É possível usar vários fluxos de trabalho no Microsoft Dynamics CRM 4.0. As tabelas AsyncOperationBase e WorkflowLogBase crescem bastante e ocorrem problemas de desempenho.

Causa

Este problema ocorre porque, quando as regras do fluxo de trabalho são acionadas, uma instância e um registro são criados nas tabelas AsyncOperationBase e WorkflowLogBase do MSCRM database. No entanto, quando a instância do fluxo de trabalho é concluída, o registro permanece no banco de dados. Portanto, as tabelas AsyncOperationBase e WorkflowLogBase continuam a crescer. Por fim, o desempenho diminui.

Observação A propriedade AsyncOperationType para esses registros está definida para 10.

Resolução

Esse problema é corrigido no pacote de atualização cumulativa mais recente para o Microsoft Dynamics CRM 4.0. Para obter mais informações, clique no número abaixo para ler o artigo da Base de Dados de Conhecimento Microsoft (alguns artigos podem estar em inglês):
949256 Atualizações e hotfixes do Microsoft Dynamics CRM 4.0


Importante Esta seção, este método ou esta tarefa contém etapas que descrevem como modificar o Registro. No entanto, sérios problemas poderão ocorrer caso você modifique o Registro incorretamente. Portanto, siga essas etapas cuidadosamente. Por precaução, faça um backup do Registro antes de modificá-lo. Dessa forma, se ocorrer algum problema, você poderá restaurar o Registro. Para obter mais informações sobre como fazer backup e restaurar o Registro, clique no número abaixo para ler o artigo da Base de Dados de Conhecimento Microsoft :
322756 Como fazer backup e restaurar o Registro no Windows


Para habilitar o hotfix, siga estas etapas:
  1. Clique em Iniciar, clique em Executar, digite regedit e clique em OK.
  2. No Editor do Registro, localize a seguinte subchave:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM
  3. Verifique a existência de uma entrada de Registro DWORD com o nome AsyncRemoveCompletedWorkflows. Os dados de valor da entrada de Registro AsyncRemoveCompletedWorkflows devem ser 1.
  4. Adicione a entrada de Registro AsyncRemoveCompletedWorkflows se ela não existir. Para fazer isso, execute as seguintes etapas:
    1. Clique com o botão direito em MSCRM, aponte para Novo, clique em Valor DWORD e digite AsyncRemoveCompletedWorkflows na caixa Nome.
    2. Clique duas vezes em AsyncRemoveCompletedWorkflows e digite 1 na caixa Dados do valor.
    3. Clique em Iniciar, em Executar, digite iisreset e clique em OK.

      Observação Se o valor na caixa Dados do valor DWORD de AsyncRemoveCompletedWorkflows for revertido para 0, o Microsoft Dynamics CRM continuará a reter os registros de fluxo de trabalho no banco de dados mesmo se as tarefas forem concluídas.
Observação Este hotfix é somente pró-ativo. Portanto, quando o hotfix é instalado e ativado, somente os novos registros de fluxo de trabalho são excluídos automaticamente. Se as tabelas AsyncOperationBase e WorkflowLogBase já estiverem grandes devido a esses registros de fluxo de trabalho, execute uma limpeza dessas tabelas usando o script do Microsoft SQL Server incluído no artigo da Base de Dados de Conhecimento Microsoft:
968520 Desempenho é lento se tabela AsyncOperationBase se tornar muito grande no Microsoft Dynamics CRM 4.0

Mais Informações

Para obter mais informações sobre a terminologia de atualização de software, clique no número abaixo para ler o artigo da Base de Dados de Conhecimento Microsoft :
824684 Descrição da terminologia padrão usada para descrever as atualizações de software da Microsoft
Para obter mais informações sobre a terminologia de hotfix do software Microsoft Business Solutions CRM e do pacote de atualização, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:
887283 Padrões de nomes do hotfix de software e pacote de atualizações do Microsoft Business Solutions CRM

Propriedades

ID do artigo: 968755 - Última revisão: segunda-feira, 10 de outubro de 2011 - Revisão: 2.0
A informação contida neste artigo aplica-se a:
  • Microsoft Dynamics CRM 4.0
Palavras-chave: 
kbmbsworkflow kbsurveynew kbmbsmigrate kbqfe KB968755

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com