Microsoft hesabıyla oturum açın
Oturum açın veya hesap oluşturun.
Merhaba,
Farklı bir hesap seçin.
Birden çok hesabınız var
Oturum açmak istediğiniz hesabı seçin.

Belirtiler

Microsoft Dynamics CRM 4.0'da birçok iş akışı kullanırsanız. AsyncOperationBase ve WorkflowLogBase tabloları çok büyük ve performans sorunları oluşur.

Neden

Bu sorunun nedeni, iş akışı kurallarının neden olduğu durumlarda, MSCRM veritabanının AsyncOperationBase ve WorkflowLogBase tablolarında bir iş akışı örneği ve iş akışı kaydı oluşturulur. Bununla birlikte, iş akışı örneği tamamlandığında, iş akışı kaydı veritabanında kalır. Bu nedenle, AsyncOperationBase ve WorkflowLogBase tabloları büyümeye devam eder. Daha sonra performans düşer.

Not: Bu kayıtların AsyncOperationType özelliği 10 olarak ayarlanır.

Çözüm

Bu sorun, Microsoft Dynamics CRM 4.0 için en son toplu güncelleştirme paketinde düzeltilmiştir.
Daha fazla bilgi için, Microsoft Bilgi Bankası'nın makalesine görüntülemek üzere aşağıdaki makale numarasına tıklayın:

949256 Microsoft Dynamics CRM 4.0 güncelleştirmeleri ve düzeltmeleri Önemli Bu bölüm, yöntem veya görev, kayıt defterinde nasıl değişiklik yapmak istediğinize yönelik



adımlar içerir. Ancak kayıt defterini hatalı biçimde değiştirirseniz önemli sorunlar oluşabilir. Bu nedenle bu adımları dikkatle uyguladığınızdan emin olun. Ek koruma için kayıt defterini değiştirmeden önce yedeklemeyi unutmayın. Böylece, bir sorun oluşursa kayıt defterini daha sonra geri yükleyebilirsiniz. Kayıt defterini yedekleme ve geri yükleme hakkında daha fazla bilgi için Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasına tıklayın:

322756 Düzeltmeyi yükledikten sonra Windows'da kayıt defteri nasıl yedeklir ve geri yüklenir, sizin için bu düzeltmeyi etkinleştirmemizi sağlamak için " Benim için düzelt

"bölümünegidin. Düzeltmeyi kendiniz etkinleştirmeyi tercih ediyorsanız, "Kendimdüzeltmemeizin ver" bölümüne gidin.

Benim adıma düzelt



Düzeltmeyi otomatik olarak etkinleştirmek için Düzelt düğmesine veya bağlantısına tıklayın. Ardından, Dosya İndirme iletişim kutusunda Çalıştır'a tıklayın ve Bu sorunu düzelt sihirbazındaki adımları izleyin.




Notlar

  • Bu sihirbaz yalnızca İngilizce olabilir. Ancak otomatik düzeltme, Windows’un diğer dil sürümleri için de çalışmaktadır.

  • Sorun olan bilgisayarda değilseniz, Bu sorunu düzelt çözümlerini bir flash sürücüye veya CD'ye kaydedin ve ardından sorunun yaşandığı bilgisayarda çalıştırın.


Ardından, "Bu sorungiderildi mi?" bölümüne gidin.



Kendim düzeltmek istiyorum

Bu düzeltmeyi etkinleştirmek için şu adımları izleyin:

  1. Başlat'atıklayın, Çalıştır'atıklayın, regedit yazın ve Tamam'a
    tıklayın.

  2. Kayıt Defteri Düzenleyicisi'nde aşağıdaki alt anahtarı bulun:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM

  3. AsyncRemoveCompletedWorkflows adlı bir DWORD kayıt defteri girdisi var olup olmadığını belirler. AsyncRemoveCompletedWorkflows kayıt defteri girdisi değer verileri 1 olmalı.

  4. AsyncRemoveCompletedWorkflows kayıt defteri girdisi yoksa, girdiyi ekleyin. Bunu yapmak için aşağıdaki adımları izleyin:

    1. MSCRM'yesağ tıklayın, Yeni'nin üzerine gelin, DWORD Değeri'ne tıklayın ve ardından Ad kutusuna

      AsyncRemoveCompletedWorkflows
      yazın.


    2. AsyncRemoveCompletedWorkflows'açift tıklayın ve Değer veri
      kutusuna 1 yazın.

    3. Başlat'atıklayın,
      Çalıştır'atıklayın, iisreset yazın ve Tamam'a
      tıklayın.

      Not AsyncRemoveCompletedWorkflows DWORD değerinin Değer veri kutusunda yer alan değer 0'a dönerse, görevler tamamlanmış olsa bile Microsoft Dynamics CRM veritabanında İş Akışı kayıtlarını korumaya devam eder.

Not: Bu düzeltme yalnızca proaktif bir düzeltmedir. Bu nedenle, düzeltme yüklenir ve etkinleştirildiğinde, yalnızca yeni iş akışı kayıtları otomatik olarak silinir. Bu iş akışı kayıtları nedeniyle AsyncOperationBase ve WorkflowLogBase tabloları zaten büyükse, aşağıdaki Microsoft Bilgi Bankası makalesinde yer alan Microsoft SQL Server temizleme betiği kullanarak bu tabloların temizleme işlemini gerçekleştirmeniz gerekir:

968520 Microsoft Dynamics CRM 4.0'da AsyncOperationBase tablosu fazla büyük olduğunda performans yavaşlıyor

Bu işlem sorunu düzeltti mi?

  • Sorunun düzeltilip düzeltilmediğini denetleyin. Sorun düzeltilmişse, bu bölümle işiniz bitti demektir. Sorun düzeltilmemişse, destek hizmetlerine başvurabilirsiniz.

  • Görüşleriniz bizim için çok önemli. Geri bildirim sağlamak veya bu çözümle ilgili sorunları rapor etmek için lütfen"Benimiçin düzelt" blogunda bir yorum bırakın veya bize bir e-posta iletisi gönderin.

Ek Bilgi

Yazılım güncelleştirme terminolojisi hakkında daha fazla bilgi için, Microsoft Bilgi Bankası'nın makalesini görüntülemek üzere aşağıdaki makale numarasına tıklayın:

824684 Microsoft yazılım güncelleştirmelerini açıklamak için kullanılan standart terminolojinin açıklaması Microsoft Business Solutions CRM yazılım düzeltmesi ve güncelleştirme paketi terminolojisi hakkında daha fazla bilgi için, Microsoft Bilgi Bankası'nın makalesini görüntülemek için aşağıdaki makale numarasına tıklayın:

887283 Microsoft Business Solutions CRM yazılım düzeltmesi ve güncelleştirme paketi adlandırma standartları

Daha fazla yardıma mı ihtiyacınız var?

Daha fazla seçenek mi istiyorsunuz?

Abonelik avantajlarını keşfedin, eğitim kurslarına göz atın, cihazınızın güvenliğini nasıl sağlayacağınızı öğrenin ve daha fazlasını yapın.

Topluluklar, soru sormanıza ve soruları yanıtlamanıza, geri bildirimde bulunmanıza ve zengin bilgiye sahip uzmanlardan bilgi almanıza yardımcı olur.

Bu bilgi yararlı oldu mu?

Dil kalitesinden ne kadar memnunsunuz?
Deneyiminizi ne etkiledi?
Gönder’e bastığınızda, geri bildiriminiz Microsoft ürün ve hizmetlerini geliştirmek için kullanılır. BT yöneticiniz bu verileri toplayabilecek. Gizlilik Bildirimi.

Geri bildiriminiz için teşekkürler!

×