Una transferencia de datos está dañada al transferir datos desde o a un dispositivo USB en un equipo que ejecuta Windows XP

Seleccione idioma Seleccione idioma
Id. de artículo: 969238 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

En un equipo que ejecuta Windows XP, al transferir datos desde o a un dispositivo de bus serie universal (USB), la transferencia de datos está dañada. Se reinicia el equipo y reciba el siguiente mensaje de error stop:

DETENER 0X000000D1)parámetro1, parámetro2, parámetro3, parámetro4)
DRIVER_IRQL_NOT_LESS_OR_EQUAL
Notas
  • Los cuatro parámetros en el mensaje de error varían, dependiendo de la configuración del equipo.
  • No todos los errores "STOP 0x000000D1" son causados por este problema.
Este problema se produce cuando se cumplen las condiciones siguientes:
  • La transferencia de datos utiliza el modo de transferencia masiva USB.
  • Durante la transferencia de datos, varios bloques de solicitud USB (URB) se envía a la pila de controladores USB de Microsoft Windows sin necesidad de esperar al finalizar cada uno de ellos.

Causa

Un problema en el controlador de controladora de Host mejorada USB 2.0 (archivo Usbehci.sys) hace que la transferencia de datos que se dañe. Este problema, los datos se leen o escriben a direcciones incorrectas en la memoria.

Solución

Información de la revisión

Hay un hotfix soportado por Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplicar esta revisión sólo a los sistemas que experimenten este problema específico.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de la revisión disponible" en la parte superior de este artículo de Knowledge Base. Si no aparece en esta sección, enviar una solicitud de servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota Si se producen problemas adicionales o si necesita solucionar un problema, es posible que deba crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión en cuestión. Para obtener una lista completa de números de teléfono de servicio al cliente de Microsoft y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.Microsoft.com/contactus/?ws=support
Nota El formulario de "Descarga de revisión disponible" muestra los idiomas para los que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar esta revisión, debe tener Windows XP Service Pack 2 o un service pack posterior instalado en el equipo.Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322389Cómo obtener el service pack más reciente para Windows XP

Requisito de reinicio

Debe reiniciar el equipo después de aplicar esta revisión.

Información de sustitución de la revisión

Este hotfix no sustituye a ninguna otra revisión.

Información de archivo

La versión en inglés de esta revisión tiene los atributos de archivo (u otros posteriores) que se enumeran en la tabla siguiente. Las fechas y horas de estos archivos se muestran en hora Universal coordinada (UTC). Cuando vea la información de archivo, se convierte en hora local. Para ver la diferencia entre la hora UTC y la hora local, utilice el Zona horaria ficha en la Fecha y hora elemento en el Panel de Control.
Windows XP con Service Pack 2, versiones basadas en x 86
Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoTamaño de archivoFechaHoraPlataformaRequisito de SP
Usbehci.sys5.1.2600.358330,33608-Jun-200914:18x 86SERVICE PACK 2
Usbohci.sys5.1.2600.358317,15208-Jun-200914:18x 86SERVICE PACK 2
Usbport.sys5.1.2600.3583144,12808-Jun-200914:18x 86SERVICE PACK 2
Usbuhci.sys5.1.2600.358320,60808-Jun-200914:18x 86SERVICE PACK 2
Windows XP con Service Pack 3, las versiones basadas en x 86
Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Usbehci.sys5.1.2600.582530,46408-Jun-200914:56x 86

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Se refiere a:".

Más información

Para obtener más información acerca de URB, visite el siguiente sitio Web de Microsoft:
http://msdn.Microsoft.com/en-us/library/ms793340.aspx
Para obtener más información acerca de la unidad USB entrada/salida (E/S) y tipos de transferencia de datos, visite el siguiente sitio Web de Microsoft:
http://msdn.Microsoft.com/en-us/library/ms790480.aspx
Para obtener más información acerca de cómo DRIVER_IRQL_NOT_LESS_OR_EQUAL, visite el siguiente sitio Web de Microsoft:
http://msdn.Microsoft.com/en-us/library/ms795930.aspx

Propiedades

Id. de artículo: 969238 - Última revisión: viernes, 07 de junio de 2013 - Versión: 2.0
La información de este artículo se refiere a:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Palabras clave: 
kbautohotfix kbexpertiseinter kbfix kbbug kbsurveynew kbqfe kbmt KB969238 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 969238

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com