Error message when you use Outlook to connect to an Exchange server by using an RPC over HTTP connection on a Windows XP-based computer: "Microsoft Office Outlook has encountered a problem and needs to close"

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Article ID: 969356 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:
  • You are running a Windows XP-based computer.
  • You use Microsoft Office Outlook to connect to a Microsoft Exchange server through an RPC over HTTP connection.
In this scenario, the Outlook client crashes. Additionally, you receive the following error message:
Microsoft Office Outlook has encountered a problem and needs to close. We are sorry for the inconvenience.
This problem occurs when the RPC over HTTP connection is running on a slow link, such as a GPRS/GSM link or a dial-up network link.

CAUSE

This problem occurs because of a timing issue in the RPC over HTTP component. This timing issue allows an uninitialized structure to be used, and this triggers an access violation.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 2 or a later service pack installed.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP with Service Pack 2, x86-based versions
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File nameFile versionFile sizeDateTimePlatformSP requirement
Rpcrt4.dll5.1.2600.3548582,65603-Apr-200913:40x86SP2
Xpsp3res.dll5.1.2600.3548351,74403-Apr-200909:44x86SP2
Windows XP with Service Pack 3, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Rpcrt4.dll5.1.2600.5789585,21603-Apr-200913:36x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
827330 How to troubleshoot client RPC over HTTP connection issues in Outlook 2003
For more information about how to configure Outlook 2003 for RPC over HTTP, visit the following Microsoft Web site:
http://office.microsoft.com/en-us/ork2003/HA011402731033.aspx

Properties

Article ID: 969356 - Last Review: October 7, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Keywords: 
kbautohotfix kbexpertiseinter kbfix kbbug kbsurveynew kbqfe KB969356

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