Installers running in Terminal Server may not copy all per-user Default settings to each user's HKCU hive.

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Article ID: 969523 - View products that this article applies to.
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Source: Microsoft Support

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Symptom



Under the following conditions:
  • a Terminal Server unaware app running in Terminal Server execution mode deletes entries in the HKCU key
  • a program is installed/re-installed in Terminal Server (in install mode) OR installed via the MSI installer


Then some per-user registry entries written by the installer to the default user profile (HKU\.Default\Software) may not be copied to the current user (HKCU\Software).

This may cause some of these symptoms:
  • Programs to have unintended or non default per-user behavior due to HKCU registry entries not being set to the default
  • In some cases, it also been observed that some installers may continue to look for HKCU to be written, and continually launch into a reinstall cycle due to these missing entries.

Cause



This issue can be caused when  HKCU\Software registry entries are deleted by an application. The delete can result in a TermSrvCopyKeyOnce key being applied to the Terminal Server's view of the registry.

Afterwards, at the end of the same program install or re-install, and during per user login, when the HKU\.Default\Software settings are copied to each user's HKCU\Software hive; the TermSrvCopyKeyOnce is checked for each sub-key in the tree. If this key is present, the copy operation will not continue for that key.

Resolution



If your user's are using Terminal Server, and you suspect that the initial default settings are not being copied to the HKCU for each user.

Then compare: HKU\.Default\Software\<Vendor>
With: HKCU\Software\<Vendor>

If the values are not being applied to HKCU, it is possible that you are facing this issue.

In order to resolve the issue, search for and delete all instances of the TermSrvCopyKeyOnce under the following registry path: HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Terminal Server\Install\<Vendor>.
For example, you may need to delete:

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Terminal Server\Install\<Vendor>\<Product>\TermSrvCopyKeyOnce
HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Terminal Server\Install\<Vendor>\<Product>\<Feature1>\TermSrvCopyKeyOnce
HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Terminal Server\Install\<Vendor>\<Product>\<Feature2>\TermSrvCopyKeyOnce

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Article ID: 969523 - Last Review: March 25, 2009 - Revision: 1.0
APPLIES TO
  • Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Datacenter x64 Edition
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Standard x64 Edition
  • Microsoft Windows Server 2003 R2 Standard Edition KN
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Keywords: 
kbrapidpub kbnomt KB969523

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