Serviço de transferência inteligente em segundo plano (BITS) não inicia no Windows XP e você recebe uma mensagem no log do sistema: "O plano de fundo serviço serviço de transferência inteligente terminou com erro específico do serviço 2147500037 (0 x 80004005)"

Traduções deste artigo Traduções deste artigo
ID do artigo: 969632 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Em um computador que esteja executando o Windows XP, o serviço de transferência inteligente em segundo plano (BITS) não é iniciado. Além disso, o evento ID 7024 é registrado no log do sistema com uma mensagem semelhante à seguinte:

O serviço serviço de transferência inteligente em segundo plano terminou com erro específico do serviço 2147500037 (0 x 80004005).
Quando esse problema ocorre, os aplicativos que usam o BITS para transferir arquivos entre um cliente e um servidor não são executados com êxito.

Considere o exemplo a seguir. O administrador do sistema implanta um pacote para o seu computador utilizando o Systems Management Server (SMS). No entanto, não é possível iniciar o BITS no seu computador. Portanto, não é possível baixar o pacote do servidor de distribuição.

Causa

Esse problema ocorre quando o BITS não chama a função SHGetFolderPath. Para BITS iniciar com êxito, a função SHGetFolderPath deve receber o caminho para o valor CSIDL_COMMON_APPDATA lendo a entrada de registro Common AppData na seguinte subchave do registro:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders\


No entanto, como BITS é executado em conjunto com outros serviços no processo Svchost.exe, a função SHGetFolderPath pode ser chamada por outros serviços. Portanto, o valor CSIDL_COMMON_APPDATA é armazenada em cache no processo Svchost.exe. Nesse cenário, o valor em cache é passado para o BITS por processo Svchost.exe.

No entanto, se a chamada da função SHGetFolderPath não recuperar o valor em cache, um valor NULL é armazenada em cache para CSIDL_COMMON_APPDATA em vez disso. Portanto, o BITS não é iniciado.

Resolução

Depois de aplicar o seguinte hotfix, o BITS irá ignorar o cache NULL valor e recuperar o caminho correto chamando a função SHGetFolderPath.

Informações sobre hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo do Knowledge Base. Se esta seção não for exibido, envie uma solicitação de suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação: Se ocorrem problemas adicionais ou se for necessária qualquer solução de problemas, talvez seja necessário criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa dos números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Observação: O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque não há um hotfix disponível disponível para esse idioma.

Pré-requisitos

Para aplicar esse hotfix, você deve ter o Windows XP Service Pack 2 (SP2) ou um service pack mais recente instalado no computador.Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322389Como obter o service pack mais recente do Windows XP

Requisito de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações do arquivo

A versão em inglês deste hotfix apresenta os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas em UTC (hora coordenada universal COORDENADO). Quando você exibe as informações do arquivo, ele é convertido em hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Windows XP com Service Pack 2, versões com base em 86 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SP
Bitsprx2.dll6.7.2600.35568.19219-Abr-200910: 28x 86SP2
Bitsprx3.dll6.7.2600.35567,16819-Abr-200910: 28x 86SP2
Bitsprx4.dll6.7.2600.35567,16819-Abr-200910: 28x 86SP2
Qmgr.dll6.7.2600.3556408,06419-Abr-200910: 28x 86SP2
Qmgrprxy.dll6.7.2600.355618,94419-Abr-200910: 28x 86SP2
O Windows XP com Service Pack 3, 86 versões x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Qmgr.dll6.7.2600.5796408,57619-Abr-200910: 19x 86

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações sobre o BITS, visite o seguinte site da Microsoft:
http://msdn.microsoft.com/en-us/library/aa362708(VS.85).aspx
Para obter mais informações sobre a função SHGetFolderPath, visite o seguinte site da Microsoft:
http://msdn.microsoft.com/en-us/library/bb762181(VS.85).aspx

Propriedades

ID do artigo: 969632 - Última revisão: quinta-feira, 16 de julho de 2009 - Revisão: 1.2
A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Professional
Palavras-chave: 
kbmt kbautohotfix kbexpertiseinter kbfix kbbug kbsurveynew kbqfe kbhotfixserver KB969632 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 969632

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com