Article ID: 969858 - Last Review: May 8, 2009 - Revision: 1.0

FIX: Non-convergence occurs when you synchronize a SQL Server Compact 3.5 client database with the server by using Sync Services for ADO.NET in a Hub-And-Spoke configuration

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SYMPTOMS

You use Microsoft Sync Services for Microsoft ADO.NET to set up a bidirectional synchronization in a Hub-And-Spoke configuration. You set up a Microsoft SQL Server Compact 3.5 database as a client database. When the synchronization starts, non-convergence occurs. Additionally, some changes in the client database are not uploaded to the server. When you run the following query against the client database, values of the __sysChangeTxBsn column and of the __sysInsertTxBsn column in the sync table incorrectly roll back to a smaller value:
SELECT __sysChangeTxBsn, __sysInsertTxBsn, UserActivityId, ActivityDate FROM <Sync Table>
WHERE __sysInsertTxBsn IS NOT NULL
ORDER BY ActivityDate ASC
However, you expect that the values will increase because these columns are of the Timestamp data type.

CAUSE

This problem occurs because the metadata in the client database of SQL Server Compact Edition is maintained incorrectly.

WORKAROUND

To work around this problem, do not use the Compact method on the client database. However, because this is not always possible, a hotfix has been provided.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites for installing this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

How to install this hotfix

To install this hotfix, you must first remove the current version of SQL Server Compact 3.5 from your computer, and then install this hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows CE 5.0-based operating systems on ARMV4i-based Smartphone devices
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Sqlce.dev.enu.phone.wce5.armv4i.cabNot Applicable104,72003-Apr-200912:33
Sqlce.phone.wce5.armv4i.cabNot applicable749,77303-Apr-200912:33
Sqlce.repl.phone.wce5.armv4i.cabNot applicable341,89503-Apr-200912:33
Windows CE 5.0-based operating systems on ARMV4i-based Pocket PC devices
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Sqlce.dev.enu.ppc.wce5.armv4i.cabNot applicable104,72003-Apr-200912:33
Sqlce.ppc.wce5.armv4i.cabNot applicable749,78103-Apr-200912:33
Sqlce.repl.ppc.wce5.armv4i.cabNot applicable341,89503-Apr-200912:33
SQL Server 2005 Compact Edition on the x86 platform
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Ssceruntime-enu.msiNot applicable2,505,21623-Apr-200909:29

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

REFERENCES

For more information about the Incremetal Servicing Model, click the following article number to view the article in the Microsoft Knowledge Base:
935897  (http://support.microsoft.com/kb/935897/ ) An Incremental Servicing Model is available from the SQL Server team to deliver hotfixes for reported problems
For more information about the naming schema for SQL Server updates, click the following article number to view the article in the Microsoft Knowledge Base:
822499  (http://support.microsoft.com/kb/822499/ ) New naming schema for Microsoft SQL Server software update packages
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft SQL Server Compact 3.5
Keywords: 
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