Échec de SCVMM et SCVMM R2 P2V avec l’erreur 2910 (0x80070005) Accès refusé

Cet article fournit une solution à une erreur 2910 (0x80070005) qui se produit lorsqu’une conversion physique-virtuelle (P2V) dans Microsoft System Center Virtual Machine Manager 2008 échoue.

S’applique à : Windows Server 2012 R2
Numéro de la base de connaissances d’origine : 969965

Symptômes

Lorsque vous utilisez System Center Virtual Machine Manager 2008 pour effectuer un P2V, vous recevez le message d’erreur suivant pendant la phase d’analyse du système :

Erreur (2910)
VMM ne dispose pas des autorisations appropriées pour accéder à la ressource sur le %server.
L’accès est refusé (0x80070005))

Action recommandée
Vérifiez que Virtual Machine Manager dispose des droits appropriés pour effectuer cette action.

Remarque

L’ordinateur source est l’ordinateur que vous envisagez de virtualiser dans la conversion P2V.

Cause

Ce problème se produit généralement parce que l’une des conditions suivantes est vraie :

  • Les informations d’identification entrées dans l’Assistant P2V n’appartiennent pas à un membre du groupe Administrateurs local sur l’ordinateur source.
  • L’ordinateur source n’autorise pas les appels WMI distants à l’espace de noms CIMV2 vers le compte utilisé pour l’Assistant P2V.

Résolution

Pour résoudre ce problème, procédez comme suit :

  1. Assurez-vous que le compte utilisé pour l’Assistant P2V est membre du groupe Administrateurs local sur l’ordinateur source.

    Remarque

    Cela est particulièrement important si le serveur SCVMM et l’ordinateur source se trouvent dans des domaines différents.

  2. Vérifiez la connectivité WMI à l’espace de noms CIMV2 sur l’ordinateur source. Pour ce faire, procédez comme suit sur le serveur SCVMM.

    Remarque

    Pendant la phase système d’analyse de la conversion P2V, SCVMM effectue des appels WMI à l’espace de noms CIMV2 sur l’ordinateur source pour extraire des informations système de base. Si ces appels WMI échouent, la conversion P2V échoue également.

    1. Ouvrez la fenêtre WBEMtest. Pour ce faire, cliquez sur Démarrer, pointez sur Exécuter, tapez WBEMtest dans la zone Ouvrir , puis cliquez sur OK.

    2. Cliquez sur Se connecter dans le coin supérieur droit.

    3. Connectez-vous à l’espace de noms CIMV2 sur l’ordinateur source. Par exemple, tapez \Source\ROOT\CIMV2.

      Remarque

      Veillez à utiliser le nom de votre ordinateur source.

    4. Cliquez sur Se connecter pour terminer la connexion.

    5. Vérifiez votre connexion en accédant à un exemple d’objet. Pour ce faire, cliquez sur Ouvrir la classe, puis tapez Win32_PhysicalMemory.

      Remarque

      Vous devez voir les objets remplir la fenêtre d’Rédacteur d’objets. Le contenu réel retourné n’est pas important. Cette étape vise uniquement à vérifier qu’une connexion à distance à l’espace de noms CIMV2 a été établie.

  3. Ouvrez wmimgmt.msc pour vérifier la connectivité à l’ordinateur local et également pour case activée les autorisations d’activation à distance. Pour cela, procédez comme suit :

    1. Ouvrez la fenêtre Contrôle WMI (local). Pour ce faire, cliquez sur Démarrer, pointez sur Exécuter, tapez wmimgmt.msc, puis cliquez sur OK.
    2. Cliquez avec le bouton droit sur le nœud Contrôle WMI (local), puis cliquez sur Propriétés.
    3. Cliquez sur l’onglet Sécurité , sélectionnez Racine, puis cliquez sur le bouton Sécurité dans le coin inférieur droit.
    4. Cliquez pour sélectionner l’autorisation Activer à distance pour tout le monde ou le compte d’utilisateur spécifique auquel vous souhaitez accorder cette autorisation à case activée zone.

    Remarque

    Cette action ne nécessite pas de redémarrer l’ordinateur.

  4. Ouvrez dcomcnfg pour vérifier que le service DCOM est en cours d’exécution et également pour case activée l’autorisation Activation à distance. Pour cela, procédez comme suit :

    1. Ouvrez le composant logiciel enfichable Services de composants. Pour ce faire, cliquez sur Démarrer, pointez sur Exécuter, tapez dcomcnfg, puis cliquez sur OK.
    2. Développez Services de composants, Ordinateurs, puis Poste de travail.

    Remarque

    Si le nœud Poste de travail a une flèche rouge vers le bas, cela signifie que le service DCOM n’est pas en cours d’exécution et doit être démarré. 3. Cliquez avec le bouton droit sur Poste de travail, cliquez sur Propriétés, puis sur l’onglet Sécurité COM . 4. Sous Autorisations de lancement et d’activation, cliquez sur Modifier les limites. 5. Pour le groupe d’utilisateurs Tout le monde, cliquez pour sélectionner la zone Autoriser case activée pour la ligne Activation à distance. Vous pouvez également ajouter le compte d’utilisateur spécifique auquel vous souhaitez accorder cette autorisation.

    Remarque

    Vous pouvez recevoir un message d’erreur « Accès refusé » si l’autorisation WMI appropriée n’est pas accordée à l’utilisateur. Le message d’erreur peut inclure code d’erreur 0x80041003.

  5. Vérifiez si la clé de Registre Ole est manquante ou a une valeur incorrecte sur l’ordinateur source. Pour cela, procédez comme suit :

    1. Démarrez l’Éditeur du Registre.
    2. Recherchez la sous-clé suivante : HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Ole
    3. Recherchez une entrée EnableDCOM qui a un type de REG_SZ et une valeur Y.

References

Pour connaître les étapes de dépannage générales de SCVMM, consultez le blog suivant : System Center Virtual Machine Manager

Pour plus d’informations sur les conversions P2V, visitez le site web Microsoft suivant : Conversion d’ordinateurs physiques en Machines Virtuelles dans VMM (conversions P2V)