Update: Können nicht beim unterbrechen oder Orchestrierung Dienstinstanzen beendet, wenn Sie eine Instanz von BizTalk Server Host in Microsoft BizTalk Server 2006 R2 nicht ordnungsgemäß herunterfahren

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 969987 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Auf dieser Seite

Problembeschreibung

Wenn Sie versuchen, Anhalten oder beenden einige Dienstinstanzen Orchestrierung in BizTalk Server Administration Console von Microsoft BizTalk Server 2006 R2, bleiben die Orchestrierung Dienstinstanzen in den Zustand aktiv. Daher werden diese Orchestrierung Dienstinstanzen nicht mehr reagiert.

Dieses Problem tritt normalerweise auf, nachdem einige Host Instanzen von BizTalk Server nicht ordnungsgemäß beendet werden. Beispielsweise reagiert einige benutzerdefinierte Pipelinekomponenten, die Sie verwenden. Dieses Problem kann auftreten, wenn Sie die BizTalk Server-Prozesses (btsntsvc.exe) zur Wiederherstellung nach diesem neu starten.

Ursache

Dieses Problem tritt auf, weil es ein Problem in einer gespeicherten Prozedur in der Datenbank BizTalkMsgBoxDB.

Lösung

Hotfix-Informationen

Ein unterstützter Hotfix ist von Microsoft erhältlich. Der Hotfix ist jedoch nur zur Behebung des Problems das in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt.

Wenn der Hotfix zum Download zur Verfügung steht, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, senden Sie eine Anforderung an den technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Normale Servicegebühren werden jedoch für weitere Fragen und Problemlösungen, die für diesen bestimmten Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen finden Sie auf folgender Website von Microsoft:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen, die für die der Hotfix verfügbar ist. Wenn Sie Ihre Sprache nicht angezeigt werden, liegt dies daran, dass ein Hotfix nicht für diese Sprache zur Verfügung steht.

Informationen zur Installation

Dieser Hotfix aktualisiert die Datenbank BizTalkMsgBoxDB. Um Fehler und unerwartete Abstürze während der Installation des Hotfixes zu vermeiden, gehen Sie folgendermaßen vor:
  1. Beenden Sie den SQL Server-Agent-Dienst, auf dem die BizTalk SQL Server-Agent-Aufträge ausgeführt wird.
  2. Beenden Sie den Dienst Internetinformationsdienste (IIS) So beenden Sie alle isolierte BizTalk-Host-Instanzen.
  3. Beenden Sie alle BizTalk Host-Instanzen, die in der BizTalk-Gruppe ausgeführt werden, in denen Sie das Problem auftritt.
  4. Dieser Hotfix angewendet werden.

Voraussetzungen

Sie müssen BizTalk Server 2006 R2 für diesen Hotfix installiert haben.

Neustartanforderung

Nachdem Sie den Hotfix installiert haben, starten Sie den SQL Server-Agent-Dienst, den IIS-Dienst und die BizTalk-Host-Instanzen neu.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keinen zuvor veröffentlichten Hotfix.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien werden in Coordinated Universal Time (UTC) aufgelistet. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC-Zeit und lokaler Zeit zu ermitteln, verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung.
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Msgbox_application_logic.SQLNicht zutreffend529,12803-Jun-200914: 42Nicht zutreffend
Hinweis: Aufgrund von Dateiabhängigkeiten kann der aktuellste Hotfix, der diese Dateien enthält auch weitere Dateien enthalten.

Abhilfe

Gehen Sie folgendermaßen vor um um dieses Problem zu beheben:
  1. Beenden Sie alle BizTalk-Host-Instanzen in BizTalk-Verwaltungskonsole.
  2. Beenden Sie IIS auf den Servern in der BizTalk-Gruppe, in der Sie das Problem betroffen sind, indem Sie den folgenden Befehl ausführen:
    net Stop Iisadmin/y
  3. Warten Sie fünf Minuten.
  4. Halten Sie in BizTalk-Verwaltungskonsole an oder beenden Sie die problematische Orchestrierung Dienstinstanzen.

Notizen
  • Wenn Sie beenden Sie alle Instanzen des BizTalk-Host und SQL Server Agent Auftrag, DeadProcess_Cleanup, die für einige Zeit ausführen lassen Sie dann die problematischen Dienst Orchestrierungsinstanzen in Ihren normalen Zustand zurück. Daher können Sie anhalten oder beenden Diese Instanzen.
  • Um den IIS-Dienst neu zu starten, führen Sie den folgenden Befehl ein:
    net Start w3svc

Status

Microsoft hat bestätigt, dass dies ein Problem bei den Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind.

Weitere Informationen

Weitere Informationen zum Verwalten und Probleme beim BizTalk Server-Datenbanken klicken Sie auf die folgende KB-Artikelnummer:
952555Verwalten sowie die Behandlung von BizTalk Server-Datenbanken
Weitere Informationen zum Anhalten, fortsetzen und beenden Orchestrierungsinstanzen finden Sie auf den folgenden MSDN-Website:
http://msdn.microsoft.com/en-us/library/dd761762.aspx
Weitere Informationen zum Dienst Orchestrierung Instanz Zustände finden Sie auf den folgenden Microsoft TechNet-Website:
http://technet.microsoft.com/en-us/library/dd746131.aspx
Weitere Informationen zur Terminologie für Softwareupdates finden Sie die folgende KB-Artikelnummer:
824684Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Eigenschaften

Artikel-ID: 969987 - Geändert am: Mittwoch, 8. Juli 2009 - Version: 1.2
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft BizTalk Server 2006 R2 Standard Edition
  • Microsoft BizTalk Server 2006 R2 Enterprise Edition
  • Microsoft BizTalk Server 2006 R2 Developer Edition
  • Microsoft BizTalk Server 2006 R2 Branch
Keywords: 
kbmt kbbtsadmin kbautohotfix kbbiztalk2006r2sp1fix kbbug kbexpertiseinter kbfix kbhotfixserver kbqfe KB969987 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 969987
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com