CORRECTIF : Vous ne pouvez pas suspendre ou arrêter les instances d'orchestration de service après avoir arrêté incorrectement une instance d'ordinateur hôte de BizTalk Server dans Microsoft BizTalk Server 2006 R2

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Sommaire

Symptômes

Lorsque vous essayez de suspendre ou arrêter des instances d'orchestration de service dans BizTalk Server Administration Console de Microsoft BizTalk Server 2006 R2, les instances d'orchestration de service restent dans l'état actif. Par conséquent, les instances de cette orchestration de service apparaissent ne répond pas.

Ce problème se produit généralement après que certaines instances d'ordinateur hôte de BizTalk Server sont arrêtés de façon incorrecte. Par exemple, certains composants de pipeline personnalisé que vous utilisez cesser de répondre. Si vous redémarrez le processus de BizTalk Server (btsntsvc.exe) pour récupérer à partir de là, vous pouvez rencontrer ce problème.

Cause

Ce problème se produit car il y a un problème dans une procédure stockée dans la base de données BizTalkMsgBoxDB.

Résolution

Informations sur le correctif

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, il est conçu uniquement pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant ce problème spécifique.

Si le correctif est disponible pour téléchargement, il existe une section «Téléchargement de correctif logiciel disponible» en haut de cet article de la base de connaissances. Si cette section n'apparaît pas, soumettre une demande de service clientèle de Microsoft et de support technique pour obtenir le correctif.

Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes qui ne relèvent pas de ce correctif spécifique. Pour obtenir une liste complète des numéros de téléphone service clientèle de Microsoft et de support ou pour créer une demande de service distincte, reportez-vous au site Web de Microsoft à l'adresse suivante :
http://support.microsoft.com/contactus/?ws=support
Remarque Le formulaire «Téléchargement de correctif logiciel disponible» affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, il est, car un correctif n'est pas disponible pour cette langue.

Informations d'installation

Ce correctif met à jour la base de données BizTalkMsgBoxDB. Pour éviter les erreurs et des blocages inattendues pendant l'installation du correctif, procédez comme suit :
  1. Arrêtez le service de l'Agent SQL Server qui exécute les travaux de SQLServerAgent BizTalk.
  2. Arrêtez le service IIS (Internet Information Services) pour arrêter toutes les instances d'ordinateur hôte BizTalk isolés.
  3. Arrêtez toutes les instances d'ordinateur hôte BizTalk qui sont exécutent dans le groupe BizTalk dans lequel vous rencontrez le problème.
  4. Appliquer ce correctif.

Conditions préalables

Vous devez disposer de BizTalk Server 2006 R2 pour appliquer ce correctif.

La nécessité de redémarrer

Après avoir installé le correctif, redémarrez le service SQL Server Agent, les services Internet (IIS) et les instances d'ordinateur hôte BizTalk.

Informations sur le remplacement du correctif

Ce correctif ne remplace pas d'un correctif publié précédemment.

Informations fichier

La version anglaise de ce correctif a les attributs de fichier (ou attributs de fichier version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont répertoriés en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, il est converti en heure locale. Pour connaître le décalage entre l'heure UTC et l'heure locale, utilisez l'onglet fuseau horaire dans l'élément de date et heure dans le Panneau de configuration.
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-forme
Msgbox_application_logic.SQLNon applicable529,12803-06-200914 : 42Non applicable
Remarque En raison des dépendances de fichiers, le correctif plus récent qui contient ces fichiers peut également contenir des fichiers supplémentaires.

Contournement

Pour contourner ce problème, procédez comme suit :
  1. Fermez toutes les instances d'ordinateur hôte BizTalk dans la Console Administration de BizTalk.
  2. Arrêtez les services Internet (IIS) sur les serveurs du groupe BizTalk dans lequel vous rencontrez le problème en exécutant la commande suivante :
    net stop iisadmin /y
  3. Patientez cinq minutes.
  4. Dans la Console Administration de BizTalk, suspendre ou arrêter les instances d'orchestration service problématique.

Notes
  • Lorsque vous fermez toutes les instances d'ordinateur hôte BizTalk et laissez ensuite le travail SQL Server Agent DeadProcess_Cleanup exécuter pendant un certain temps, les instances d'orchestration service problématique revenir à leur état habituel. Par conséquent, vous pouvez suspendre ou arrêter ces instances.
  • Pour redémarrer les services Internet (IIS), exécutez la commande suivante :
    net start w3svc

Statut

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section "S'applique à".

Plus d'informations

Pour plus d'informations sur la façon de gérer et dépanner les bases de données BizTalk Server, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la base de connaissances Microsoft :
952555Comment faire pour gérer et dépanner les bases de données BizTalk Server
Pour plus d'informations sur la façon de suspendre, reprendre et terminer les instances d'orchestration, visitez le site Web MSDN à l'adresse suivante :
http://msdn.microsoft.com/en-us/library/dd761762.aspx
Pour plus d'informations sur les états instance des services d'orchestration, visitez le site Microsoft TechNet Web suivant :
http://technet.microsoft.com/en-us/library/dd746131.aspx
Pour plus d'informations sur la terminologie de mise à jour de logiciel, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la base de connaissances Microsoft :
824684Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft

Propriétés

Numéro d'article: 969987 - Dernière mise à jour: mercredi 8 juillet 2009 - Version: 1.2
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft BizTalk Server 2006 R2 Standard Edition
  • Microsoft BizTalk Server 2006 R2 Enterprise Edition
  • Microsoft BizTalk Server 2006 R2 Developer Edition
  • Microsoft BizTalk Server 2006 R2 Branch
Mots-clés : 
kbmt kbbtsadmin kbautohotfix kbbiztalk2006r2sp1fix kbbug kbexpertiseinter kbfix kbhotfixserver kbqfe KB969987 KbMtfr
Traduction automatique
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La version anglaise de cet article est la suivante: 969987
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